Luminar AI fails to login

Answered

Comments

19 comments

  • Avatar
    Patrick Manley

    I'm getting the same thing and I'm thinking its for that same reason too

    0
    Comment actions Permalink
  • Avatar
    Robert Cross

    Exact same problem here.  Will not allow me to sign in in any way:  Facebook, email and password, forgot password for a reset. All give the same message you indicate here.

    0
    Comment actions Permalink
  • Avatar
    Henry Balen

    It succeeded now. Either they fixed the server issue or the load has gone down.

    0
    Comment actions Permalink
  • Avatar
    Robert Cross

    Same here.  It works now.  Just takes 40 seconds to launch (way longer than PS, LR, or any of the Topaz apps on my Mac).  Also, no water reflections feature despite this as the key selling point promised upon release.  It was the main reason I even considered the software. 😒

    0
    Comment actions Permalink
  • Avatar
    Marco N

    I still have the problem with "network error". I wrote an email to Skylum support many hours ago. Until now there was no answer.


    I was really looking forward to Luminar. This is quite frustrating...

    0
    Comment actions Permalink
  • Avatar
    Tommy Toussaint

    Same problem here :/

    0
    Comment actions Permalink
  • Avatar
    John hallgrimsson

    same here -   hate when they can't get their login server up -       and they post nothing.   

     

    they should know by now that there are lots of folks that can't use the software because of their login server/s 

     

    but their payment taking servers work fine -    and now over 1 hour and no reply or comment -  they are probably all gone home for the day 

     

    they have spent lots of money and effort in advertising this software but can't get their software login server to stay up 

    I also had problems --- or they had issue when I bought Luminar 3 and 4.  

    0
    Comment actions Permalink
  • Avatar
    Saif Shah

    This is Indeed Frustrating.

    I have 2 activations. I tried on my laptop and it was activated right away. Where as trying on my PC for a while and still tells me to check connection -_-

     

    0
    Comment actions Permalink
  • Avatar
    Tommy Toussaint

    I find a way ! Go to C:\Windows\System32\drivers\etc\ and renaming the hosts file to hosts2. That did the job for me ! Good Luck !

    0
    Comment actions Permalink
  • Avatar
    Marco N

    I´m working on a Mac....

    My frustration is greater than the joy of Luminar. Why do I as a customer have to solve the problems?

    I want my money back!!!

    0
    Comment actions Permalink
  • Avatar
    Tommy Toussaint

    Ohh, that's bad :/. I understand you.

    0
    Comment actions Permalink
  • Avatar
    Alfredo Martínez

    I have exactly the same problem. Any solution please...

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello all!

    Please ensure that your antivirus or firewall isn't blocking outgoing connections.

    If the issue persists, try an alternative Internet connection if possible - there may be a setting on your network that blocks outgoing connections.

    If you still get the same error:

    1. Open Finder.
    2. Click Go in the top menu > click Go to Folder.
    3. Paste the following path: /etc and click Go.
    4. In the folder that opens find the file named hosts and send it to support@skylum.com

    Here is the video tutorial that may also be helpfulhttps://www.loom.com/share/002448d84b244728adf6b861e9aa0af3  

    1
    Comment actions Permalink
  • Avatar
    Rosemary Armel

    login problem   so frustrating not working for hours

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi Rosemary Armel,

    Have you tried the steps above described by my colleague?

    0
    Comment actions Permalink
  • Avatar
    Rosemary Armel

    This app cost a lot more money than others and shouldn't have all these issues. I am requesting a refund. 

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi Rosemary Armel,

    Please reach out to our support team at http://skylum.com/support and we will be happy to help you.

    0
    Comment actions Permalink
  • Avatar
    Member

    I have just used Tommy Toussaint's solution above and I got straight in after previously having loads of failures with the message. He said "Go to C:\Windows\System32\drivers\etc\ and renaming the hosts file to hosts2." No idea why this works but it does

    1
    Comment actions Permalink
  • Avatar
    JORGE VILLEGAS

    I have also used Tommy Toussaint's solution above and I got straight in with "Go to C:\Windows\System32\drivers\etc\ and renaming the hosts file to hosts2." 

    0
    Comment actions Permalink

Please sign in to leave a comment.