Cannot edit photos with Luminar 4 on latest update of Big Sur

Answered

Comments

7 comments

  • Avatar
    Lance Ransom

    Sorry, this ended up in the wrong area...

    0
    Comment actions Permalink
  • Avatar
    Lance Ransom

    I also tried to use the Locate function.  That just crashed Luminar 4.

    Upon re-launch, I still have the triangle with the exclamation marks.

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Lance,

    Is the folder you tried to locate a system one? (e.g. Pictures, Desktop, Documents, etc.)

    Please reach our team at https://skylum.com/support and provide a screenshot of your Catalog file structure: http://prntscr.com/w77shs

    I may suggest creating an empty folder on your computer and copy / move all the files located in the lost folder there. After this, in Luminar right-click the lost folder > Locate Folder > select the newly created folder that contains all the files from the lost folder. 

     

    0
    Comment actions Permalink
  • Avatar
    Lance Ransom

    My photos reside in a structure under my Pictures directory located in my home directory:  ~/Pictures/Photos

    For clarity, I used Luminar 4 the day before the Big Sur update to 11.1 and it worked fine.  I tried to use Luminar 4 the day after the Big Sur update to 11.1 and I had this problem.

    Your suggestion to move / copy is not feasible, unless it is a guaranteed solution.  My photo library is 600gb in size.  That will trigger an arbitrary massive Time Machine event.

    If that is the solution, I would like an articulation as to what happened and why that solves the problem because it will cause me to loose data on my backup as Time Machine will discard other backups.

    Also, since I granted Luminar full disk access, accessing the files in my home directory should not be an issue.  There is something else going on with your software.

    While I appreciate the privacy, there is nothing concerning to me about posting the screenshot in this context.

     

    0
    Comment actions Permalink
  • Avatar
    Lance Ransom

    I experimented with this Sklyum problem with Big Sur by turning off Time Machine and renaming the folder with pictures from "Photos" to "myphotos".  I then did the "Locate Folder" in Luminar 4 to point to the renamed directory and Luminar 4 worked as expected.

    I then renamed the directory back to "Photos" and now Luminar 4 crashes on launch.

    PLEASE NOTE SKYLUM:  None of this was an issue until the 11.1 update of Big Sur.  It would seem that you still have issues with Big Sur.

    0
    Comment actions Permalink
  • Avatar
    Benedikt

    I have the same problem. 

    0
    Comment actions Permalink
  • Avatar
    Lance Ransom

    Interestingly, I downloaded the On1 Raw trial today and it had absolutely no issue loading and editing my photos exactly where they reside:  ~/Pictures/Photos

    By comparison, Luminar 4 just crashes now.

    Wonder what it will take for Skylum to acknowledge their support for Big Sir is lacking...

    0
    Comment actions Permalink

Please sign in to leave a comment.