AI installation - error on Mac

Pinned Answered

Comments

35 comments

  • Official comment
    Avatar
    Alina Skylum

    Hi Ajay, 

    Please try using this alternative installer: https://downloads.skylum.com/luminarai/mac/Luminar_AI_Release.dmg 

    Let us know how it goes. 

    Comment actions Permalink
  • Avatar
    John hallgrimsson

    the issue is not downloading -    issue is when already installed and one launches the app -    then the app wants to sign in -  and one enters user and password   and then one gets this error 

     

    2
    Comment actions Permalink
  • Avatar
    John hallgrimsson

    other posts show that folks have been having this problem and that it started working for some -    but now it is just down down down 

    is there anyone looking at the server that handles registration and activation ?????

    2
    Comment actions Permalink
  • Avatar
    Member

    Its downloaded for me but does not open. Gives a bad gateway error. The same error was showing up when I was downloading the install file. I have Imac with 32gb ram and 1.6tb free. I know its not my hardware. so far I have uninstalled twice to see if it would work but it doesnt. This is so far the worse roll out of new software from Skylum

    0
    Comment actions Permalink
  • Avatar
    John hallgrimsson

    I am frustrated that on a release date that this happens and there seems only one person in support -  

    I see in forum that many with my problem -   can download and install ok -   but once launched it wants to activate and I suspect that servers is crashing and is down -    

    sad thing I had similar problems when I bought Luminar 3 and 4.   -   still have not their process in order 

    I see no reply from Skylum in a long time now 

    2
    Comment actions Permalink
  • Avatar
    Patrick Porter

    Thank you! This solution worked perfectly and I have installed the software and registered it. Everything works fine.

     

    -1
    Comment actions Permalink
  • Avatar
    Shannon Tompkins

    EDIT:  The alternative download link mentioned above fixed my problem.  Thank you.  Sorry, I did not notice the alt download link until after I posted the following comment.   I'll keep my original comment here in case anyone else experiences the same issue and also overlooks the comment above providing an alt download link.     

    Original post:

    I am unable to run the Luminar AI Installer after unzipping the download.   The installer opens the license agreement.  When I accept the license agreement the screen changes to an installation screen but then immediately pops up an error window: "Oops!  We've run into an issue while installing the app.  The network connection was lost." I'm trying to install on a 2019 Macbook Pro running 11.1 Big Sur.  My networking is working properly.  I've rebooted multiple times.  I've re-downloaded and re-tried installing multiple times.

    2
    Comment actions Permalink
  • Avatar
    James Lewis

    I am having the same issue in trying to use my second authentication on my MacBook Pro.I emailed support and was told to buy an addtional "seat." I have tried to explain the situation, but they do not respond. I am about to ask for a refund. 

    1
    Comment actions Permalink
  • Avatar
    James Lewis

    And using the alternate download link does not address my problem. (It was never about downloading the software anyway, just activating it. It's really annoying that Luminar expects me to pay an additional fee to install this on a second computer. This has never been its policy in the past. 

    1
    Comment actions Permalink
  • Avatar
    Member

    finally installed but totally disappointed. It feels like a re-skin of Luminar 4 with just the ability to create presets (templates). The sky AI feature is still buggy as hell as it cannot distinguish objects and buildings from skies. To make the mattes worse, its extremely slow.  I cannot use adjustment brush as every stroke takes 5-8 seconds to render. My specs are 3.3ghz Core I.5 32gb ram, and 2tb HDD with 1.6 free. I might as well use the Luminar 4 as this version seems the least inspired release from skylum in a long time. Feel free to disagree and change my mind.

    1
    Comment actions Permalink
  • Avatar
    James Lewis

    I agree. A big letdown. The triumph of marketing.

    1
    Comment actions Permalink
  • Avatar
    SteveC

    I downloaded the original installer.  It asked to install as plug-in to LR and PS.  Only installed to LR and then launches.  Skips over installing into PS so I can't call it from PS.  I tried using your alternate DMG installer, same results. 

    0
    Comment actions Permalink
  • Avatar
    Yelton Correa
    I have the same problem. I can't activate it
    1
    Comment actions Permalink
  • Avatar
    Dave Parker

    Similar problem. Running an iMac Pro with Big Sur v 11.0.1. Logged into the Skylum web site and downloaded my pre-purchased Luminar AI app. It downloaded fine but attempting to validate my email and password simply sent me to a new screen to setup a new account. I already had an account . . . that's how I got the downloaded app. Even changed my password because I thought that might be an issue. No, that wasn't the issue. As stated by someone, above, there appears to be a disconnect in the validation of user id's and passwords. I created a ticket yesterday but by the looks of the complaints, I'm sure it will take a while to get to the bottom of the issue. Perhaps Skylum will offer some sort of bonus to those of us who could not get started on the big day.

    1
    Comment actions Permalink
  • Avatar
    Brian Fox

    I'm not able to get the install download to work either. I get an error message - tried the alt download on this string, no go either

    1
    Comment actions Permalink
  • Avatar
    Enzo Aliotta

    I'm also having issues launching the program on my Mac Pro I have tried to load and re load the program even downloaded the link above with no luck. The program installed but when I go to start the program it hangs and doesn't respond.

     

    I think Skylum have some serious issues to find a fix for.  

     

    0
    Comment actions Permalink
  • Avatar
    Julian Plant

    CUSTOMER SUPPORT posting here in the hope you read this

    Still experiencing the same issues as above, can't log in, have tried all suggestions and don't want to waste any more time with it.

    Simple fix - it's not the end of the world - please just issue a refund so we can move on.

    Probably happy to have another look when you have sorted it out.

    Thanks in advance.

    (any degree of support may be a good idea for the future, just a thought, there are a growing number of fed-up people here)

     

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi. Please contact us via https://skylum.com/support and we will be glad to help you.

    0
    Comment actions Permalink
  • Avatar
    Dave Parker

    Dear Kirk Osborn,

    I contacted your support portal 2 days ago and the only response I got was an automated email that said you would attempt to respond within 24 hours. It's been 46 hours and I know you are busy but if you've read the similar issues in this thread I would think there would be an acknowledgement that Sklyum is working on a fix and a target date for that fix. This is not very impressive for a rollout of a highly advertised app. 

    If I don't get a satisfactory response inn the next 48 hours I will be asking for a refund for the app as well as a refund for the 1 year subscription in the Luminar X Membership which I also purchased. It's no good without the app.

    2
    Comment actions Permalink
  • Avatar
    Julian Plant

    Dear Kirk Osborn,

    We appreciate that you are experiencing issues at Skylum, however,

    same as Dave, contacted support two days ago (now day three).

    From your contact suggestion above the possibilities are:

    a) you didn't check for correspondence (I have an email confirmation).

    b) your checked but your customer service system is also hopelessly broken.

    Have requested a refund as cannot log in and use the software. 

    Please advise.

     

    0
    Comment actions Permalink
  • Avatar
    Brian Fox

    I'll pile on as well, same as everyone else, sent issue to Sklyum support haven't heard back in 2 days. Also tried the revised install link that was posted in this thread by Skylum , that did not revolve the issue either. I like their products, however, they have failed miserably  on customer service. At minimum, Skylum should be sending out update emails on their resolution of this major issue. It wouldn't cost them hardly anything to offer a free product to those who have submitted issues on this to their support. Doing nothing is about the worst "action" they can take in impacting a loyal customer base!!

    2
    Comment actions Permalink
  • Avatar
    Brian Fox

    And one more thing, now that I'm getting worked up again, what really ticks me off is viewing the Trey Ratcliffe and Jim Nix videos doing all of the great stuff with Luminar AI, and here is sit with a "damaged" product, not able to process my photos, enjoying the same results that they are showing in their tutorials. Oh well, the world has bigger problems.......................

    2
    Comment actions Permalink
  • Avatar
    Julian Plant

    With you on the frustration front Brian :) hope they can sort us out swiftly.

    I just want to get my money back, I won't be using the product now (not that I can lol).

    0
    Comment actions Permalink
  • Avatar
    Gordon Alderson

    Same here, nearly three days since I emailed their 'support (non)' team!
    I had the same issues with an earlier Luminar version and swore never to deal with them again, you just can't change stupid, can you?
    Incidentally I have been a customer since the early MacPhun days as it was such a breath of fresh air! Hey ho!

    2
    Comment actions Permalink
  • Avatar
    Erich Vieth

    Luminar AI keeps crashing on my brand new iMac running Catalina 10.15.7 with i9 processor and 32GB Ram.  It crashes while it is "Updating Image Gallery."  I uninstalled and reinstalled but it keeps trying to update my image gallery and while it does that it crashes.  The program is thus currently useless to me.  How do I get a completely CLEAN install where the program thinks I've never before installed it, so it doesn't try to update the image gallery?  Maybe I can at least edit individual files while you try to figure out why it keeps crashing while it tries to update the image gallery.  

    1
    Comment actions Permalink
  • Avatar
    David Ariño

    I have the problem: 

    "LuminarAI can’t sign in to your Skylum account at the moment. Check your internet connection and try again"

    I try without Firewall but I always have the same problem. 

    I also don't have an answer from the support. How do I request a product refund?

    Thanks

     

    1
    Comment actions Permalink
  • Avatar
    James Lewis

    Until a few days ago,  https://skylum.com/support had a link that said, "How to apply for a refund." That link said "Submit your request by filling out the form at the bottom of this page." But there was no such form. 

    Now even the link has been removed.

    I wrote a week ago asking for a refund but have not received a response to that request. (They have messaged me about another issue.)

    I would advise you to go to that page and fill out the customer support form, using "Other" as the category. But don't hold your breath. 

    I do not wish to trash this company, because I think they produced useful software through Luminar 4, but I feel they faced a self-imposed end-of-year deadline to deliver a product and did so before it was thoroughly tested. Just my opinion. 

     

     

    0
    Comment actions Permalink
  • Avatar
    Chris Fletcher

    Luminar AI keeps crashing on my  iMac running Big Sur with 32GB Ram.  It crashes while it is "Updating Image Gallery."  I have uninstalled and reinstalled and tried the alternative provided in this thread,  but it keeps trying to update my image gallery and while it does that it crashes.  

    I have logged a support ticket but have had no response apart from we are busier than normal..... It would be useful to have a support rep at least let me know that they are working on it, rather than getting no response at all!!!!

    0
    Comment actions Permalink
  • Avatar
    Enzo Aliotta

    It's interesting you can't even buy Ai it seems the buy option has been taken away

     

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Guys, 

    Our support team has received a huge number of support requests due to the Luminar AI release, which is why it may take us a couple of business days to get back to you. However, please rest assured that we're doing our best to reply to every single one of your emails as soon as possible. 

    Erich Vieth 

    Please try the following steps:

    1. Hold down Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
    2. Select a backup that has been created prior to when you encountered the issue with the library and click Restore from Backup.
    If the issue persists:
    1. Make sure Luminarᴬᴵ is closed.
    2. Locate your Luminar AI Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar AI Catalog folder as well as Luminar AI Catalog.luminarai file inside this folder. Choose any name you like.
    4. Open Finder.
    5. Navigate to Applications > Utilities.
    6. Launch Terminal.
    7. Paste the following string into the Terminal window: defaults delete com.skylum.luminarai
    8. Press Enter on your keyboard.
    9. Close Terminal.
    10. Launch Luminarᴬᴵ. Go through the initial setup. Leave the location of the catalog at the default (in Pictures folder). 

    Also, please provide the info requested via email. 

     

    David Ariño, see my reply to you here: https://community.skylum.com/hc/en-us/community/posts/360010191720/comments/360002543920 

     

    James Lewis - We've replied to your email a couple of days ago.  Please check your inbox. Make sure to check the Spam folder. 

    As for the refund, the form is still in its original place. See the screenshot: http://prntscr.com/w7tick 

     

    Chris Fletcher - See my reply to you here: https://community.skylum.com/hc/en-us/community/posts/360010152699/comments/360002576679 

     

    Enzo Aliotta - The software's still available for purchase. For instance, here: https://skylum.com/checkout/luminar-ai/au 

     

    Gordon, Julian, Brian - I can see your support requests have been processed. 

     

     

     

    I appreciate the submitted screenshots! Could you let me know the last steps that you did in the software prior to encountering this issue? 

    Where are your images located? Is the path Volumes/PermMedia...on an internal or external drive? 

    Please try the following steps:

    1. Hold down Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
    2. Select a backup that has been created prior to when you encountered the issue with the library and click Restore from Backup.
    If the issue persists:
    1. Make sure Luminarᴬᴵ is closed.
    2. Locate your Luminar AI Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar AI Catalog folder as well as Luminar AI Catalog.luminarai file inside this folder. Choose any name you like.
    4. Open Finder.
    5. Navigate to Applications > Utilities.
    6. Launch Terminal.
    7. Paste the following string into the Terminal window: defaults delete com.skylum.luminarai
    8. Press Enter on your keyboard.
    9. Close Terminal.
    10. Launch Luminarᴬᴵ. Go through the initial setup. Leave the location of the catalog at the default (in Pictures folder). 

    Please let us know how it goes.

    0
    Comment actions Permalink

Please sign in to leave a comment.