Luminar AI requires OpenGL 3.3 or greater to run

Answered

Comments

21 comments

  • Official comment
    Avatar
    Austin Miller

    Hello Matthias.

    If you are receiving the “OpenGL 3.3 and later is required for this application to run” error message when launching Luminar 4, please make sure your machine meets the minimum requirements listed here: https://manual.skylum.com/4/en/topic/technical-requirements

    If you are not sure whether or not your GPU supports OpenGL 3.3 or above, please refer to its manufacturer's website. If your GPU does support OpenGL 3.3 and above, updating your graphics driver should fix this issue.

    Automatically update NVIDIA Graphics Drivers:

    http://www.nvidia.com/Download/index.aspx?lang=en-us 

    After you have updated your GPU drivers from the manufacturer’s website, make sure you set your discrete adapter to run Luminar 4 by default (usually this concerns laptops). 
    Please refer to your graphics card's manufacturer's website if you need help with that.

    If your discrete card is Nvidia, you can find the instructions here. 

    If your discrete card is AMD, the video instruction is accessible here. 

    If none of the steps above helped, please provide us with your complete system summary:

    • Press the Windows logo key + R.

    • Type msinfo32 in the dialog box that opens and hit Enter on your keyboard. 

    • In the window that opens, make sure you have System Summary highlighted on the left.

    • Click File > Export.

    • Type the name of the file (you can choose any you like), save it somewhere where you can easily find it, and attach this text file to your reply to this email.

    N.B. The links are clickable and show the screenshots that can guide you, if necessary.

    Here is the video tutorial on how to retrieve your system infohttps://www.loom.com/share/97aff7951ee3412daa020f1d88eb36e8     

    Looking forward to hearing back from you. 

    Comment actions Permalink
  • Avatar
    Gerd Leimann

    NVIDIA GeForce GTX 1650 Ti

    The same Problem

    1
    Comment actions Permalink
  • Avatar
    Andreas Epmeier

    Do you ever read the questions?
    He stated clearly that he uses a Nvidia card(Nvidia GTX 1050 Ti). So why you write solutions for AMD cards?
    Only the same standard cut&paste answers for every problem.

    I use a Nvidia RTX 2070 super without Nvidia drivers and I have no opengl problem with Luminar AI. So how can this be?? Any ideas? :-)

    1
    Comment actions Permalink
  • Avatar
    Mehdi Mahjoubi

    Hi,

    i also have this issue with an RTX2060 on my Laptop HP Omen 15.

    i just updated all drivers from Nvidia and Intel, restarted computer but Luminar AI is still complaining about OpenGL.

    In addition: Luminar 4.3.0 runs without complaining about Open GL. Only Luminar AI is asking for it.

    Please note that Intel UHD on Intel Core processors are all compatible with Open GL 4.6.

    I don't even mind saying that the Nvidia Turin GPU are compatible with Open GL.
    So now, Luminar AI isn't working as expected, what's the problem ? does it require a patch ?

     

    EDIT:
    I am using a Dell Universal Dock D6000 in order to use multiple screens on DisplayLink and my USB devices, when i unplug it Luminar AI starts without complaining about OpenGL.
    It means that Luminar AI assumes DisplayLink output as a separate display which is not the expected behavior.

    0
    Comment actions Permalink
  • Avatar
    Andreas Epmeier

    This is a problem with the docking station and sometimes with a dual gpu setup with Intel UHD. Had the same issues at my workplace with Dell and Lenovo docking stations. Displaylink uses a compression technology and needs a driver to work. This works for some programms as a "new gpu" and brings a few interesting problems with it.
    So try to connect your monitor with HDMI to the docking station and look if you can set the default gpu to the nvidia gpu.You can change this setting with the NVidia control panel.

    1
    Comment actions Permalink
  • Avatar
    Andreas Epmeier

    The updated Nvidia Diver 460.89 supports opengl 4.6.0

    0
    Comment actions Permalink
  • Avatar
    Mehdi Mahjoubi

    Thank you Andreas

    Connecting through HDMI don't solve the issue as Luminar AI still considers the Dock as a seperate GPU, even when DP isn't plugged in.
    Setting Laptop's embedded screen as Primary Display made Luminar use the correct drivers.
    but this is not the expected behavior. i am sitting in front of the external monitor and it should be my primary display.
    i'll be waiting for Skylum to fix this GPU detection thing.

    1
    Comment actions Permalink
  • Avatar
    Matthias Schaetzle

    Update:

    Based on another comment to my inquiry, I have unplugged my second display from the docking station. I use a VisionTek 4K docking station with a 27" HP monitor over HDMI.

    Surprise, surprise! The program works as expected and no complains about OpenGl etc...!

    How can I get around this issue? I don't want to unplug my main monitor each time I use the program.

    0
    Comment actions Permalink
  • Avatar
    Matthias Schaetzle

    Thank you Mehdi. I tried it that way (switching monitors) and it worked well for me. This is definitely a workaround until this gets fixed by Skylum.

    1
    Comment actions Permalink
  • Avatar
    Mehdi Mahjoubi

    BTW, Austin's comment didn't solve the issue. This thread should not be flagged "Answered" :)

    0
    Comment actions Permalink
  • Avatar
    Mark Haskell-Cooper

    It would appear that they don't care. This is getting worse by the day - a great pity - was hoping this was going to be good.

    0
    Comment actions Permalink
  • Avatar
    Andreas Epmeier

    OK. This second monitor problem is really strange. But we learn every day, through our own experience or that of other people, in sharing them with us, a few new tricks. So good and open communication is half the way to the solution of the many obstacles and problems we share. :-)

    Second monitor is a good advice for some little tests of my own. I can reproduce it with my friends Lenovo laptop and docking station and 2 monitors or 1 monitor and a Valve Index VR headset(detected as a second monitor but not shown in the device manager). If I use a computer with an built in gpu and an external gpu, Luminar AI has the same problem, until I set the default gpu to the external NVIDIA gpu.
    VR headsets are a bit tricky. If you try to boot into the UEFI bios setting and a monitor and a VR headset are connected to the computer, this could result in a black screen. Disconnecting the headset - problem solved. So this was a hint to look further. And after some digging and questioning, I got the answer that some headsets are "internally" will be recognized as monitors and not be shown in the Win10 device manager.

    Another problem could be my graphictablet. The pentablet driver could be a problem. I will try to test this. But not on x-mas or I get killed by my girlfriend. :-)

    0
    Comment actions Permalink
  • Avatar
    Andreas Epmeier

    Matthias I'm not sure if your docking station has the function, but some could passthrough a videosignal without the problem, that it appears like a second monitor. HP has a really good knowledge base and a good support. I have contacted them before for some help in the past with thunderbolt and MAC passthrough problems. They are really helpful and most of the time their solutions work like a charm. :-)

    Based on your name I would guess your are also from germany? 

    0
    Comment actions Permalink
  • Avatar
    Matthias Schaetzle

    Andreas, yes I am from Germany, but after living in the United States for 18 years I am now in Portugal.

    I have contacted VisionTek as well about this issue. As soon as I get a response I will keep you updated.

    0
    Comment actions Permalink
  • Avatar
    Andreas Epmeier

    I have another idea. Tested it on another computer and it worked:

    This is a fix/workaround when your computer has more than 1 gpu!
    Under Win 10 in the sytemsettings you can select which gpu will be the dedicated gpu for a program and which performance mode the program will use. I don't set my pc to english, because I think the picture speak for themselves(or I'm just lazy)
    Win 10 systemsettings:

     

     

    Add the exe file of the program to add to the settings:

     

    Then you will see a small window where you can set the program to the gpu it should use and set the performance mode. This overwrites any Win10 global settings.

    If you have a multi gpu setup, you will see all gpus in the system in the window.
    I have used this with them other programs and it solved some really nasty bugs for me with other programs too.

    1
    Comment actions Permalink
  • Avatar
    Mehdi Mahjoubi

    Hi Andreas,

    Prior to posting my conclusion, i tested setting specific GPU for Luminar, and unfortunately, it didn't changed anything.

    I will test with a TB3 dock, if i receive enough gift cards this christmas to buy it :D :D

    0
    Comment actions Permalink
  • Avatar
    Matthias Schaetzle

    UPDATE:

    I found a solution by trying to resolve an issue with my wife's identical Laptop:

    The issue was the Intel UHD Graphics driver.

    After disabling the Intel driver and only using the Nvidia the program opens and works flawlessly! No switching of monitors etc.! Yay!

    I will continue to leave it disabled and see if this creates any other issues with the laptop.

     

    0
    Comment actions Permalink
  • Avatar
    James Montgomery

    Similar issue as Mehdi above. Am using two external monitors through a universal docking station using DisplayLink divers. Updated all drivers including the displaylink driver but no improvement. Bypassing the docking station however did work. I am convinced the problem is the docking station, displaylink drivers, or both. Trouble is I need to use the external monitors and the only way to connect them to the laptop is through the docking station.

    0
    Comment actions Permalink
  • Avatar
    Freidbert Schulze

    The OpenGL problem comes from the two graphiccards in your computer.
    The simple graphiccard can't do OpenGl so Luminar fails on this card.

    The better graphiccard can do OpenGl but Luminar doesen't use this card or fails to tell the system switch to the better card. So you have to do it manualy as Andreas Epmeier shows above.

    The easy solution is to plug a second monitor into your laptop. The simple card can't drive that aditional monitor and the system switches automatically to the better card with OpenGl now Luminar sees only the Card with OpenGL. Cheers

    0
    Comment actions Permalink
  • Avatar
    chebbi skander

    Hi everyone, i had the same problem here, OpenGl 3.3 error. Finally I found a solution.
    Right click on the Luminar's shortcut, open file location, and just delete this file "opengl32.dll"
    Let me know if it works for you

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Chebbi,

    Please kindly note that we do not recommend removing any files from Luminar's program folder, as it may affect the app's operation.

    0
    Comment actions Permalink

Please sign in to leave a comment.