Luminar AI Crashes Repeatedly on Open

Answered

Comments

46 comments

  • Avatar
    Elena O'Brien

    Hi,

    We are very grateful to have such an experienced artist on board such as yourself.

    We really do value your feedback and in case you have any bugs to report, please Please reach out to us at http://skylum.com/support and we'll get that sorted out for you ASAP or pass the info to our team.

    Also, just in case, we are not abandoning Luminar 4 in any way. We will continue to support it.

    -5
    Comment actions Permalink
  • Avatar
    Deborah Stitt

    I am also having an issue with Luminar AI. I was in the process of adding a folder of photos to the catalog and the program crashed. Now it will not open up without crashing. I never even got to use it. Not off to a good start.

     

    3
    Comment actions Permalink
  • Avatar
    Rob de Ruiter

    I also had several crashes when I want things to erase and when I am replacing skies in AI working on Mac version Catalina and had 5-6 Gb free memory at that time. Also Luminar 4 crashes still a lot.

    2
    Comment actions Permalink
  • Avatar
    Robert Cross

    I haven't even been able to get into the app yet, as upon opening, it sits there not responding for a minute or so, before giving me a login screen.  Then when I go to log in it says that there's an internal error and I need to recheck my internet connection or contact support.  My internet connection is rock solid and pushing 2 GBps up and down.  Not a good start at all. 🤬

    2
    Comment actions Permalink
  • Avatar
    Member

    I have the same issue.  I just downloaded and installed the software.  I added a single picture and when I'm about to start editing, it crashed and keep crashing each time I open it.  It won't even stay on for 1 min before crashing. Im using Mac with Catalina.  

    4
    Comment actions Permalink
  • Avatar
    James Gerboc

    Installation was fine except it offered plugin installation for Photoshop but not Lightroom. It thinks I have Photoshop and I dont, never did. But, I just tried to add folders and it crashes every time I try to launch. I was simply trying to point the catalog to an external hard drive. First drive worked. Second drive crashed. Can open Luminar but cant stop the cataloging process before it crashes again. 

     

    1
    Comment actions Permalink
  • Avatar
    Shashank Katiyar

    L-AI seems to have so high potential, especially for quick edits...but

    I have two systems, one with intel 8700K and another with i9 9900K, with NVME drives and Gigabit connections. The experience on 8700K so far is extremely abysmal and will be testing i9 9900K this evening.  

    Installation time: ~60 minutes (???, not to mention website loading time) 
    Loading of image (24 Mp to 96 mp): slow to unusable

    I can edit usually with acceptable speed once the image is loaded.

    And this is the big one, I can hardly export any image, it just crashes. 

    1
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Everyone,

    We're sorry to hear that you're facing issues. We really want to help. Please, reach out via https://skylum.com/support so we could assist you in a more effective way.

    Please, note that usually, we reply within 24 hours, however, due to Luminar AI release, we receive a great number of emails, thus, it might take us a bit longer to get back to you. however, we want to assure you that we reply to each and every request we receive.

    -1
    Comment actions Permalink
  • Avatar
    Anthony Cousins

    If this problem with Luminar AI crashing all the time is not fixed then I will not be buying any more products nor am I recommending it to anyone. Very lazy way to release a product with so much issues and not swiftly fixing the issues.

    4
    Comment actions Permalink
  • Avatar
    James Gerboc

    I had the same problem. I deleted the catalog. It creates a new one. I am able to launch and edit now. I haven’t tried adding another folder yet. There should be more information available so we can help ourselves overcome these issues. I had this same problem when updating to L4 and I remembered what I did to fix it.

    0
    Comment actions Permalink
  • Avatar
    Member

    I make edits and cannot see any changes when I try to preview.

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Member, 
    I replied to you here:
    https://community.skylum.com/hc/en-us/community/topics/360000866320-Luminar-AI-for-Windows 

    By the way, if you don't see any changes when you apply edits and your graphics card is Intel XE Graphics, you must be encountering the issue described in this post:
    https://github.com/dotnet/wpf/issues/3817 

    Please try turning off Hardware Acceleration, it should help.
    https://www.thewindowsclub.com/hardware-acceleration-windows-7 

    If that's not the case, please proceed with the instructions from my previous reply.

    0
    Comment actions Permalink
  • Avatar
    Member

    A waste of time. I sent you as system summary for the second time.

    0
    Comment actions Permalink
  • Avatar
    Michael Prewitt

    I bought Luminar AI yesterday, I had ZERO issues and was in love with the software. Today it crashed in the middle of an edit and every time I try to open it, it starts loading my catalog and crashes before it can load up. This thing absolutely will not open, I’ve uninstalled and reinstalled, I’ve shutdown my computer and restarted it, I’ve cleared the dns and cache and still nothing. I paid for the software and membership yesterday and to have this major of an issue the next day with absolutely no way to get in contact with anyone except a robot is completely unacceptable.

    1
    Comment actions Permalink
  • Avatar
    Kathy Emerton

    I purchased Luminar AI, I was able to edit 2 pictures and then it froze and crashed. I wasn't happy in fact, I was angry. I understand that new programs have problems when they're first released etc. So I kept searching for an answer.

    Now I don't know if this solution that I found on a Skylum forum will work for everyone, it worked for me. I'm running Luminar AI on a Windows 10 system
    https://community.skylum.com/hc/en-us/community/posts/360010201239-Luminar-AI-CRASHING

    If you scroll down to where it talks about renaming Luminar AI Catalog perhaps this solution may help.

    1
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Michael Prewitt,

    Please, reach out via https://skylum.com/support so we could assist you in a more effective way.

    -1
    Comment actions Permalink
  • Avatar
    Mark Hudson

    I have had about a dozen crashes in the week of trying out LAI. I think the vast majority of them are due to particular image(s) I added to the folder. So as a workaround I was able to back them out and the app would launch again. So for those images I just have to go back to LR. Skylum should definitely prioritize on fixing the crashing.

    As Reid Hoffman said "If you're not embarrassed by the first version of your product, you've launched too late", I don't hold this too much against Skylum given LAI's initial release. But I sincerely hope that your v1.1 would have drastically improved stability.

    0
    Comment actions Permalink
  • Avatar
    Julia Olsen

    Mac BigSur 11.1

    32GB RAM

    1TB HDD

    Just re-downloaded/re-installed after reformatting MacHD, crashes every time I try to open it.  I paid for this product ...

     

     

    0
    Comment actions Permalink
  • Avatar
    James Gerboc

    @juliaolsen I had to delete it through App Cleaner before reinstalling. My crashes were caused by catalog issues. Once I reinstalled it was fine except I had reorganized by folders/files and it couldn’t find anything. I just created a new catalog. But now it doesn’t seem to work as a plug-in anymore. When I go out to AI from Lightroom and save the image, it doesn’t come back into Lightroom. Not sure why.

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Julia Olsen,

    Please try reinstalling the app in the following way:

    • Delete the app with AppCleaner. Download AppCleaner from here: http://www.freemacsoft.net/appcleaner 
      Drag Luminarᴬᴵ from your Applications folder into the AppCleaner window. When removing Luminar, mark all the files and folders in the list, except for RTW788AXG3.com.skylum.luminarAI.
    • Go to Pictures -> Luminarᴬᴵ Catalog and rename this folder (if you have created the Catalog in another Location, please navigate there and rename the Catalog folder).
    • Open Luminarᴬᴵ Catalog folder, locate the file LuminarAI Catalog.luminarai and change its name too. 
    • Go to Application Support (launch Finder > Go > Go to Folder > paste /Library/Application Support/Skylum Software and delete LuminarAI folder.
    • Go to Terminal and paste: defaults delete com.skylum.luminarai , then press Enter
    • After that please install Luminarᴬᴵ back from the link below:
      http://skylum.com/download/luminar-ai-download 

    If the issue persists, please get in touch with our team at https://skylum.com/support so we could help you to get it up and running. 

    ----------------------------------------------------------------------------------------------------------------

     

    @James Gerboc

    Could you please try to access LuminarAI from Adobe Lightroom this way?

    • Right-click on the image > Export >  LuminarAI > You have an option to Open Source Files or, if you've made any changes in Lightroom that you'd like to transfer over to LuminarAI, you can also choose Edit a Copy with Lightroom Adjustments.

    Please note that when you invoke Luminar as a plugin, LR takes off the focus of the folder from which you took the photo to send to Luminar. When you hit Apply in Luminar, and your image is put into the folder on your HDD, the only thing you need to do in order to make the image appear in LR is to click the folder where your photo was: LR will re-focus on the folder and pull the files that are currently in it.

    The new photo should also appear in Lightroom's Catalog > All Photographs.

    If that doesn't help, please file a support request at https://skylum.com/support so our support team could take a closer look at your case. 

    0
    Comment actions Permalink
  • Avatar
    Jim Reminga

    Horrible experience with Luminar AI. Crashes, stalls on loading, stalls adding new directory, takes forever to load relatively small catalogs. Very interesting approach to editing, but terrible and unacceptable implementation. Unusable!

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi Jim Reminga

    I am terribly sorry to hear about your experience with Luminar! Please reach out to us at http://skylum.com/support and we'll get that sorted out for you ASAP.

    1
    Comment actions Permalink
  • Avatar
    Ross Paguinto

    There is a bug in the software and that is the real issue. We keep on sending data but there is no solution yet. Software that causes the computer to crash is basically useless. All other software does not cause any crashing issue, only Luminar. Please fix your software and provide us with the fix. Thank you.

    0
    Comment actions Permalink
  • Avatar
    Tim Berquin

    hi,

    I just installed latest rtx studio drivers and luminar AI keeps crashing on start up.
    Also seems to slow down my system.

    Please fix asap

    1
    Comment actions Permalink
  • Avatar
    Lee Greer

    ’m a portrait photographer who depends on software that works . I wasted so much time editing just to find out I can export them. I’ve tried every single trick to try and fix . The step by step uninstall method , turning off antivirus and firewalls, changing the display setting on monitor and managing the 3D graphics and boom still crashes .I’m on one of the most powerful computers around . So it back to Lightroom and photoshop plus the customer support sucks.

    1
    Comment actions Permalink
  • Avatar
    Member

    My Luminar AI on Win10pro is as good as bricked.

    I switched from jpeg to raw NEF files and after an hour it started to crash when reversing an action.

    WORKS AGAIN

    Had to delete the files in pictures/Luminar AI Catalog/CacheDocuments and in CacheDocuments/recources the files from that NEF crashing day.

    Do not promote happily Luminar AI handels RAW images with no problem. Stay serious.

    1
    Comment actions Permalink
  • Avatar
    Michael Fousie

    I started having the same problem of having Luminar AI version 1.0.1 simply crashing to the desktop after about 20 seconds. I never had this problem until this week, up to now it's worked as it should. I'm using the latest Win10 pro build on a Puget Systems machine with lots of memory and the latest drivers on my nvidia card. It's frustrating to have seen the LuminarX member workshops last week and then have the program completely fail. I hope you'll find the issue so we don't have to start requesting refunds. I really enjoyed the program while it worked. I

    Maybe this will help.... I was able to get the Luminar AI photoshop plugin to work, but for how long is yet to be seen.

     

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Michael,

    Please accept our apologies for the inconvenience.

    We've just sent you an email with an experimental build that should fix the issue you're facing.
    Please check your email inbox.

    0
    Comment actions Permalink
  • Avatar
    Tim Berquin

    Helga Rowles could this build fix my problems too?

    0
    Comment actions Permalink
  • Avatar
    Michael Fousie

    Thanks Helga, the "experimental build" you sent me seems to have repaired my Luminar AI application. Everything is working properly now. Your quick response is very much appreciated. Now I can get back to work.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.