Can't Open Luminar AI

Answered

Comments

125 comments

  • Avatar
    Mark Altmeyer

    Thank you Skylum support team, your recommendations via email solved the problem.

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Member - Please, check if you have LR plugin installed: close LR, start LuminarAI, go to LuminarAI > File > Install plugin > Install in front of LR.

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Mark - Glad to hear that! Hope you'll enjoy editing with Luminar AI :)

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Dan - You can use the download link available in your Skylum account.

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Pamela - As far as I can see, your request has already been processed by our support team. Kindly make sure to check your inbox and Spam folder. Thanks!

    0
    Comment actions Permalink
  • Avatar
    Dan Dunnum

    Agatha Winter, I just uninstalled Luminar AI and went to my list of software, downloaded it and got the same results.  I assumed, based on your earlier post, that there was an updated file.  

    Either the link in my software does not take me to that link or I still have a problem.  I have already updated all files I was directed to do, and when I downloaded and installed the file, again, nothing changed.  

    There is one thing that is interesting to me.  The option to be added as a LR plugin is grayed out.  and EVERY time that I have downloaded the file to install after I get past the agreeing to terms and conditions etc... it starts at 21% rather than at 0%.  This is wearing me out.  

    0
    Comment actions Permalink
  • Avatar
    Member

    I have the same issue. I couldn't start it.

    0
    Comment actions Permalink
  • Avatar
    Peter Stäblein

    There seems to be a lot of trouble with installing Luminar AI. I've pre ordered it and got a download link today. I could download an installation file (4.062 KB in size) and tried to install the software with it. Nothing happens. No error message nothing. I'm using Windows 10

     

    0
    Comment actions Permalink
  • Avatar
    Rob Bowes

    I'm on a Mac , in LR its doesnt open in "edit in" and no plug in in PS , also twice it has crashed my Mac twice by maxing out the cpu , I see lots of people are having issues , can't beleive this was release before fully testing , even worse I cant beleive I paid for rubbish software , where do I complain and get a refund !!!!!!!!!

    0
    Comment actions Permalink
  • Avatar
    Bruno Pinto

    So, again ? the same as with the luminar 4?
    Ive installed on a toshiba tecra w50, it's an i7 and it worked, hadn't had time to test it, but, worked. On my desktop, ryzen 5 5600, doesn't open ?

    :(

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hello,

    We're really sorry some of you still facing this issue. We really want to help you with this. Thus, for us to provide you the most effective help, lease, reach out via https://skylum.com/support so we could assist you.

    Please, note that usually, we reply within 24 hours, however, due to Luminarrelease, we receive a great number of emails, thus, it might take us a bit longer to get back to you. however, we want to assure you that we reply to each and every request we receive.

    0
    Comment actions Permalink
  • Avatar
    Member

    I have the same issue. I couldn't start it

    0
    Comment actions Permalink
  • Avatar
    Erika Humke

    I'm on a Mac. Finally thought I could work with it tonight (so excited!). Complete fail, won't launch!!! So disappointed. 

    0
    Comment actions Permalink
  • Avatar
    Martin Lewis

    Been trying everybody's suggestions, no luck! Luminar AI just wont launch.

    So many hours spent trying to get this to work.

    Not sure if this is an issue.

    When I install my percentage starts at 21% then creeps along. Fails a few times telling me I have no internet but we get there in the end. Then I go to open and I get the spinning icon for 1sec and that is my Luminar AI experience.

    I am no longer angry, just very tired and disappointed....

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Martin,

    Please try this full installer:

    https://downloads.skylum.com/luminarai/win/Win_Luminar_AI_Release.msi 

    If it doesn't help, please try the following:

    If the solution above doesn't work, please try resetting your hosts file back to the default value: https://support.microsoft.com/en-us/help/972034/how-to-reset-the-hosts-file-back-to-the-default 

    Here is the video tutorial that may also be helpfulhttps://www.loom.com/share/0cf4050f5e3a4551880bbd0eb2ea0684 

    0
    Comment actions Permalink
  • Avatar
    Martin Lewis

    Thank you Margaret
    I will keep you posted

    0
    Comment actions Permalink
  • Avatar
    Dan Dunnum

    Well, I got another build and another method to fix my issue...  Here is what Elena outlined.  It did not work for me, but maybe it might work for someone else. 

    Let's try reinstalling LuminarAI . Please follow the steps below:

    Uninstall Luminar.

    How to uninstall an app on Windows 10 (click this text to open link).

    Clear your registry:

    • Visit https://www.ccleaner.com/ccleaner/download?pc
    • Scroll down to the bottom of the table and click Download from CCleaner.com in the first column.
    • Once the download has finished, launch the file and install CCleaner on your computer.
    • Launch CCleaner.
    • Click Registry on the left.
    • Click Scan for Issues in the lower left. Wait for the scan to finish.
    • After the scan has finished, click Fix Selected Issues in the lower right.
    • Close CCleaner.

    Reboot your PC.

    Download the latest version of LuminarAI from here: 

    https://downloads.skylum.com/luminarai/installer/win/LuminarAISetup.exe

    Once the installer has finished downloading, locate it in your Downloads folder (or wherever you chose to save it), right-click the file, and click Run As Administrator. A prompt might appear asking you whether you wish to confirm your action, click Yes and wait for the installer to load. Then, follow the instructions on the screen.

    I really hope this helps. Let us know how it goes.

    0
    Comment actions Permalink
  • Avatar
    Josef Havranek

    The same as the rest of guys - Luminar AI doesn't work at all. Great disappointment after such a long time of waiting. 

    0
    Comment actions Permalink
  • Avatar
    Dan Dunnum

    Margaret Bright,

     I found that I had a similar issue with Luminar4.  I had forgotten the experience.  Below is what I sent to support.  I am copying you here because you folks here seem more responsive. I am still having an issue.

    I think I may have diagnosed the problem I am having with downloading and installing Luminar AI.  It seems I had a very similar problem when downloading and installing Luminar 4.  

    I tried repeatedly with that file downloading it and deleting it and trying again.  I was even given the exact same directions to clean up my registry with "CCleaner", uninstalling Luminar 4 and rebooting the computer.  
    I followed these directions several times, but it did not work. I finally received a special link that took me to a file "Luminar4setup_ofline" that was 729,902 KB instead of the 2897KB of the "Luminar4Setup" link that I had been using.  
     
    The much larger file did work.  when I ran it.  It did take some time but it worked.  
     
    It was interesting reading the old emails. The setup file was doing pretty much everything this setup file is doing.  The only difference is that it is not crashing.  It just fails to load.  Maybe I could benefit from a "LuminarAIsetup_ofline"
     
    Just a thought.
    0
    Comment actions Permalink
  • Avatar
    Ray Alstrom

    Apparently, as per Skylum support, my problem lies with my CPU, specifically my AMD A6-3620 APU processor. Evidently, when Skylum said you need an Intel iCore 5 or AMD Ryzen processor, they meant it. LuminarAI downloads and installs fine on my machine, but it refuses to launch. I guess I'm locked into Luminar 4 until I can afford a new machine. It's going to have to be more than the ability to use LuminarAI to get me to purchase a new machine, though. Amazing that this is the 1st software that has ever refused to run on this machine... including all things Adobe & Corel....

    0
    Comment actions Permalink
  • Avatar
    Josef Havranek

    Thanks to all responded. I'm not gonna buy new "iron" because of AI, for sure. Especially when the rest of applications works fine... For my money I'm waiting for some update solving that issue!

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Dan,

    Thanks for contacting our support team. We will get back to you soon.

    0
    Comment actions Permalink
  • Avatar
    Barry Schwartz

    I payed for use on 2 computers.  It opened on my windows 10 laptop, but not on my windows 10 desktop.  same configuration.   I received tech support help which told me to delete the software, run cc cleaner and clear the registry, and redownload, then open using right click to run/open as administrator.  It still did not work.  I again restarted the pc, but still does not work. I hope they solve the problems soon.

    0
    Comment actions Permalink
  • Avatar
    Ray Alstrom

    Barry Schwartz may I ask what your CPU processor is on your desktop? If it's not an Intel iCore 5 or 7 or AMD Ryzen you're probably not going to get LuminarAI to run.

    0
    Comment actions Permalink
  • Avatar
    Carl Lum

    Adding my voice to the complaints. I just tried installing Luminar AI today. The installation appeared to complete properly. But when I try to launch, I get an incomplete home screen and it just stays there. Tried running the repair option, but same thing.

    Skylum has botched the rollout of this heavily-hyped release. 

    *** UPDATE DEC 22 *** I finally got Luminar AI to install and run, after I uninstalled, ran a registry clean, rebooted, and then reinstalled.

    0
    Comment actions Permalink
  • Avatar
    Member

    Probably no one will ever read this, but the latest Windows Update resolved the problem for me. I never uninstalled, cleared registers or deactivated antivirus.

    It seems it is just a matter of the .NET Framework changes. Maybe I am wrong. Cheers

    0
    Comment actions Permalink
  • Avatar
    Dan Dunnum

    @Member, I did this, and it did not work.  I wish it had.

    0
    Comment actions Permalink
  • Avatar
    JOe Amodei

    I have done everything they have posted. My guess is the put out an inferior produce so they could charge our credit cards before the end of the year and collect money for something that does not work for a lot of people.

    in addition they will not respond when you ask for help so terrible!...been waiting 7 days now for someone to help me.

    0
    Comment actions Permalink
  • Avatar
    JOe Amodei

    Just update your windows.............. then it will works !!!! thank you to the group member that told us to to this . could have been waiting months to hear from Skylum

    0
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    Just downloaded and installed AI on my desktop...well, "just" meaning about 3 hours ago. Did not open at all. SO I have been looking over this thread and tried/down everything including the Uninstall and reinstall and repairing the reg entries Does nothing still so trying one more uninstall and and install to see.

    Should note Luminar 4.x runs fine, latest updated installed just now.

    As with others more than frustrated right now. Hopefully there will be some sort of patch sooner than later.

    0
    Comment actions Permalink

Please sign in to leave a comment.