Problems with Luminar AI menu items

Answered

Comments

26 comments

  • Official comment
    Avatar
    Helga Rowles

    Hi Torsten,

    A very similar issue in Luminar 4 was caused by Nahimic service.

    Could you please try to update your Nahimic drivers? We can recommend following either method 1 or 2 in this article: https://www.drivereasy.com/knowledge/update-nahimic-audio-driver-quickly-easily/ 

    If updating the drivers does not help, could you please try to disable Nahimic (or nahimicservice.exe) in your Task Manager? (How to run a task manager: click here)

    If you're prompted to restart the computer after you disable this service, please make sure to run Task Manager once again after the restart and verify that this service is still disabled. 

    Once you've made sure that Nahimic is not active, please try to run Luminar and check whether the issue persists.

    If further assistance is needed, please reach us at skylum.com/support. We will be happy to help. 

    Comment actions Permalink
  • Avatar
    David Moss

    C'mon Skylum, this is beginning to look like a repeat of Luminar 4.

    1
    Comment actions Permalink
  • Avatar
    Ronald Lashley

    What happened to Ctrl Z for undo, it doesn't work?    Also there is no user guide posted on the Skylum website for Luminar AI.   It was difficult to figure out how to save a look (or user template) and it is not obvious.   

    1
    Comment actions Permalink
  • Avatar
    Bert Friedrich

    I do not have Nahimic drivers/services, but I do have the same problem on Win10.

    There seems to be a randomness there, sometimes I can click the next choice, most times they just disappear when I move my cursor.

    it looks like this was not tested properly. This is clearly (again) a Skylum issue, pls fix this a.s.a.p. as this really is very basic functionality.

    0
    Comment actions Permalink
  • Avatar
    David Moss

    Unfortunately Skylum has an atrocious track record when it comes to fixing things. Just ask them about Luminar 4.

    0
    Comment actions Permalink
  • Avatar
    Dave Hamilton

    I am also having the menu problem.  Can not right click on any drop down menu as described above.  Dave.

     

    0
    Comment actions Permalink
  • Avatar
    Torsten Kraus

    I don't have nahimic drivers on my system (I have realtek audio drivers). Nevertheless I have disabled all my audio drivers. But the problem still exists.

    0
    Comment actions Permalink
  • Avatar
    Serge BARTH

    Hi,

    I've exactly have the same problem and I don't have activated nahimic service on my computer. By the way, I don't understant how an audio service could interact with the mouse when I move I rhe submenu area

    0
    Comment actions Permalink
  • Avatar
    Peter Scrimshaw

    I too have this submenu problem, Win10 PC with latest updates, GeForce GTX960 graphics card, don't believe that I have Nahimic audio drivers installed (certainly no obvious process running)

    0
    Comment actions Permalink
  • Avatar
    David Gillett

    I have same problem using win 10. Do not have Nahimic drivers..

     

    0
    Comment actions Permalink
  • Avatar
    Alan Brown

    Ditto all problems highlighted on my Win10 desktop. Its not been mentioned but as a workaround the up and down keyboard arrows can be used to select from a submenu. I've just downloaded an update to Ai today and hoped Skylum had address and resolved but I'm afraid not. I really can't image how they passed thro the beta stage with such an issue. 

    0
    Comment actions Permalink
  • Avatar
    Roger Talley

    I had the same problem.  Today Skylum support asked for a screen cap.  I opened the program and got a requestor to install an update.  I did, and the problem went away.

     

    0
    Comment actions Permalink
  • Avatar
    Serge BARTH

    This miracle isn't for me Roger! The problem isn't solved in the last update. It seems to be a basic programming problem under windows staying unsolved curiously

    0
    Comment actions Permalink
  • Avatar
    Peter Scrimshaw

    Yes, same here, I could only get Luminar AI to run at all AFTER the update, so that's when I found the menu problem!

    As Alan said above, it is possible to use the sub-menus via the up/down arrow keys, but it isn't very nice like that, so I can see that there are no further updates available; reported build is 1.0.0 (7348), but I still have the menu problem

    0
    Comment actions Permalink
  • Avatar
    Peter Wells

    For what its worth I also have the same menu problem on my PC AND I cant get the programme to launch on my 64bit i7 laptop either! What a shambles.............

    0
    Comment actions Permalink
  • Avatar
    Ronald Lashley

    I'm using Windows 10 x64 ver 20H2 on my computer (Ryzen 5 2600X CPU) and have not had any problem with Luminar AI launching or menu vanishing.   It is a little slow launching but much faster than MS Flight Simulator.   So I don't think it is a problem with Windows10.  Perhaps launching has something to do with your anti virus software.  I also use a Logitech mouse and Wacom Pen tablet.   Be sure your mouse driver is up to date.

    0
    Comment actions Permalink
  • Avatar
    Peter Scrimshaw

    This is now fixed for me, with further advice from Skylum support, but it does involve editing the Windows Registry, using RegEdit, as follows:

     

    Could you please make sure that the menu delay is set to the default value (400)
    Here's how you can do that:

    https://winaero.com/how-to-speed-up-menus-in-windows-10-and-change-the-menu-delay/

    If the issue persists, please make sure that your WIndows is up-to-date:
    https://support.microsoft.com/en-us/windows/update-windows-10-3c5ae7fc-9fb6-9af1-1984-b5e0412c556a

     

    My windows is up-to-date, but I did find that MenuShowDelay was set to 0 (not sure how, when or why!)

    Setting this registry value to 400 did nothing until after a PC restart, but today the sub-menus seem to be working as expected!

    Hope this helps someone else figure it out

     

    0
    Comment actions Permalink
  • Avatar
    Peter Scrimshaw

    There is a perceptible delay as the sub-menus open, but at least I can actually use them now - I might experiment with a lower value (200 or 300 maybe?), but it definitely needs to be greater than 0!

     

    0
    Comment actions Permalink
  • Avatar
    Peter Wells

    Yes this hack worked for me although I dont recommend messing with the registry if you are not 100% certain what you are doing. Skylum need to find a fix pdq.

     

    I now need them to wake up and find out why it wont load on my windows laptop....................

    0
    Comment actions Permalink
  • Avatar
    Serge BARTH

    Hi Peter,

    In win10, the MenuShowDelay property indicates the time, in milliseconds, that the system waits before displaying a cascaded shortcut menu
    when the mouse cursor is over a submenu item
    On my PC (ASUS Rog Strix 17), MenuShowDelay=0 worked well with all my photo softwares (and others) but not with Luminar Ai.
    Using regedit, I've changed this value to MenuShowDelay=20 and everything is ok now.
    But it's a little surprising to have to use regedit with an official udate

    0
    Comment actions Permalink
  • Avatar
    Dave Hamilton

    The regedit worked for me too.  I set mine to 400 but will reset to a lower value. 

    Are they not going to fix things with small patches like other early release developers have to?

    Other than that issue all else seems to working for me and I really like the value of Luminar Ai. 

    Thanks everyone!

    0
    Comment actions Permalink
  • Avatar
    Torsten Kraus

    I have now tried all the tips that have been presented here. But none of these suggestions led to a solution of the problem. Even the update did not bring a solution. It is very disappointing that there is no effective solution from Skylum. After all, I bought the software and it does not run properly. What does Skylum have to say about this?

    0
    Comment actions Permalink
  • Avatar
    Dave Hamilton

    https://community.skylum.com/hc/en-us/community/posts/360010097820-Luminar-AI-Menu-Doesn-t-Work-with-Mouse-Windows10- 

    It reads a fix will be rolled out with a new update in about two weeks.  Latest post by support.

    Hope so, as the regedit works but does not stick and I have do it again.  Reads 0 not 100.

     

    0
    Comment actions Permalink
  • Avatar
    Torsten Kraus

    Well, the new update did not solve the problem either. The menus still disappear. Interestingly, Luminar AI now takes 98 seconds to start. For comparison: PS CC needs 16 seconds to start on my computer....

    0
    Comment actions Permalink
  • Avatar
    Victoria Grace

    Hi Torsten,

    That's indeed strange. Could you please reach our techs via https://skylum.com/support so that they could check it for you?

    0
    Comment actions Permalink
  • Avatar
    Torsten Kraus

    I think I have found the solution to my problem with Luminar AI.

    After not finding any active Nahimic drivers or service in the task manager, I searched the Sytstem32 folder of my Windows installation for any Nahimic files. There I found the following drivers:

    NAHIMICAPOlfx.dll
    NahimicAPONSControl.dll
    NAHIMICV2apo.dll
    NAHIMICV3apo.dll

    I disabled the drivers by changing their names and saw what happened on reboot. On the following reboot I was told to update the Sonic Suite 2 sound drivers from Asus. I undid the name changes and deactivated Sonic Studio on startup.

    The problems with the disappearing menus have not occurred since then. So it was Sonic Suite 2 that caused the problems. However, this surprises me. After all, it is a tool for the computer's sound. But the problem with the sound drivers is well known.

    Overall, however, the performance at startup of Luminar AI is still poor. The first start of the program after a system boot takes 2 minutes and 48 seconds.  If the program is closed and started again (without a system reboot), the start still takes 44 seconds. Comparable programs start faster.

    0
    Comment actions Permalink

Please sign in to leave a comment.