Luminar 4.3 compapability with macOS Big Sur

Answered

Comments

92 comments

  • Avatar
    David Martin

    Luminar4 4.3.2 (just released) seems to have fixed the problem ..... any chance Skylum might now learn from the experience and do some homework BEFORE and OS release in future?

    -1
    Comment actions Permalink
  • Avatar
    Sam Friedman

    Upgrade did not help me, still can't edit etc. Still useless.

    0
    Comment actions Permalink
  • Avatar
    Armin Hadzic

    I've just updated Luminar to 4.3.2 (Big Sur) but when I load an image (any image) it gets a proclamation mark and after that everything is locked inside the software. Computer restart doesn't help with Luminar and this proclamation.

    2
    Comment actions Permalink
  • Avatar
    John Tweddell

    Armin, that’s bad news, so much for the update. Starting to get an even bigger concern about all of this. Will they ever get it right or will AI be the only way they allow us to use Big Sur?

    0
    Comment actions Permalink
  • Avatar
    Sam Friedman

    New Photos app helps in apathy...

    0
    Comment actions Permalink
  • Avatar
    John Tweddell

    Sam, is the Photos app getting anything near to Aperture (hopefully as I loved Aperture)

    0
    Comment actions Permalink
  • Avatar
    Sam Friedman

    I haven't tested it enough but funny thing, I used Luminar as a plugin for Photos and perhaps it refreshed something as for the moment Luminar is ok and even exported edited pic back to Photos so fingers crossed need to test more.

    BigSur & Luminar 4.3.2 works after a miracle.

    0
    Comment actions Permalink
  • Avatar
    Espen Ekeroth

    To those of you who have the triangle issue: have you tried the locate function? (Right click, locate on the catalog)

    0
    Comment actions Permalink
  • Avatar
    Craig Herrick

    Upon upgrading iOS, Luminar was not showing the Looks or the edit tasks. I had an alert arrow next to each folder though I could still see the files.

    At Customer Supports suggestion I right clicked on the folder alert arrows, repointed at the proper folders and all the issues cleared.

    2
    Comment actions Permalink
  • Avatar
    Sam Friedman

    Yes, for me the pic I was trying to edit before doing the Photos export is still uneditable even every new pic I add for edit is ok.

    Id suggest trashing old catalog etc.

    I did delete catalog from hd and upon restart Luminar recreated the catalog and you need to add folder / folders etc where your photos are but after that all fine. 

    0
    Comment actions Permalink
  • Avatar
    jo bekaert

     

    i have the same problem as Mr. Armin Hadzic... 

    "I've just updated Luminar to 4.3.2 (Big Sur) but when I load an image (any image) it gets a proclamation mark and after that everything is locked inside the software"

    photos which are placed into the "wastebusket" are impossible to remove 

    in "Aurora HDR 2019" i can edit photos but I can't export them... 

    3
    Comment actions Permalink
  • Avatar
    Armin Hadzic

    As few have mentioned, the problem seems to be the catalog/folder settings/history. I deleted (only from Luminar, not hard drive) the whole catalog/folder and now everything seems to be working fine again.

    0
    Comment actions Permalink
  • Avatar
    jo bekaert

    apparently the problem with the proclamation mark in Luminar 4 is solved after I made a new catalog...

    the problem with the wastebasket in Luminar 4 is still the same... (impossible to remove the photos)

    exporting photos out of Aurora HDR 2019 is impossible...

     

    0
    Comment actions Permalink
  • Avatar
    Espen Ekeroth

    The patch seem to work fine for me. I have upgraded, relocated to solve ! and exported one image to disk

    0
    Comment actions Permalink
  • Avatar
    Raymond Griffiths

    Updated L4 and Aurora, initial results are good. More testing needed to restore full confidence.

    0
    Comment actions Permalink
  • Avatar
    John Tweddell

    As others - I had to start a new catalogue as I got proclamation marks. However I cannot export as file - only export to Photo seems to work

    0
    Comment actions Permalink
  • Avatar
    Espen Ekeroth

    John: Did you try to "locate" instead of creating a new catalog? Did work fine for me. 

    What I notice is that Apple has changed the name of my disk partitions. (Check disk Utility) I would guess this is why we get the !s.

    1
    Comment actions Permalink
  • Avatar
    John Tweddell

    Thanks Espen - will try those

    0
    Comment actions Permalink
  • Avatar
    John Tweddell

    Well done Espen - It worked - can you export files OK?

    0
    Comment actions Permalink
  • Avatar
    David Martin

    Quite amazing that Skylum can't work this all out for their customers!

    0
    Comment actions Permalink
  • Avatar
    John Tweddell

    I seem to be fine now export working again 

    0
    Comment actions Permalink
  • Avatar
    Espen Ekeroth

    Me to - export is fine.

    0
    Comment actions Permalink
  • Avatar
    Emmanuel Awemu

    Finally, the latest updates have worked for me. However, I think Skylum for the pain and sufferings that we have all endured should give us something in return such as extra discounts on products or free stuff.

    0
    Comment actions Permalink
  • Avatar
    Alan Woodgyer

    It it would be good to see this issue resolved. I’m starting to consider alternatives but I don’t want software available only on subscription. Can’t help but think that the timing of this, and the fact that Luminar have yet to fix the export functionality, the company would rather we jettison Luminar 4 in favour of their new AI software that they are heavily promoting. A week ago we were promised a fix in the next few days, so when can we expect to see the problem rectified. In a few days, weeks, months or sometime never?

    0
    Comment actions Permalink
  • Avatar
    Espen Ekeroth

    Alan: Do you still have trouble after installing the patch? It works fine for me.

    0
    Comment actions Permalink
  • Avatar
    Alan Woodgyer

    Hi Essen, I installed the update around 3 hours ago and the export functionality is now working, so all is well. Great to be able to get on with processing the photos I had from last week.

    0
    Comment actions Permalink
  • Avatar
    Member

    I have a related problem with Noiseless. I realize this is an older program inherited from Macphun, but I would hope that since Noiseless CK is still available for sale (and which I bought today hoping it would solve the export problem), Skylum will update it so I can export and actually use the photos I've taken. 

    Although I realize Noiseless is now part of a much larger photo editing environment, I would expect it still to be supported. Please LMK whether there is an update forthcoming that will make this software the great tool it's been for the past 6-7 years for me.

     

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi! Please note that Noiseless CK is our legacy app and we are not selling it anymore. Could you specify where did you find the purchase link? Please reach our support team and we will proceed with the refund: https://skylum.com/support

    0
    Comment actions Permalink
  • Avatar
    Sam Friedman

    Another update for macOS 11.1 and again I'm having catalog-issues and easiest way forward again was catalog_show in finder _delete

    0
    Comment actions Permalink
  • Avatar
    Espen Ekeroth

    Did you try just to use the locate function from top in your catalog first? Worked well for me.

    0
    Comment actions Permalink

Please sign in to leave a comment.