Luminar 4 now supports macOS Big Sur!

Pinned Featured

Comments

77 comments

  • Official comment
    Avatar
    Elena Blum

    Hi Richard Goldstone, Paul Jeromson,

    If you have exclamation marks next to the image folders, please, follow the steps below in order to reconnect Luminar 4 catalog with missing folder:

    1. Go to the Library tab;

    2. Right-click the missing folder;

    3. Choose Locate Folder from the drop-down menu: https://prnt.sc/syjwtz;

    4. Find and point to the missing folder.

    Here are the video tutorials that might also be useful:

    Comment actions Permalink
  • Avatar
    René Zuber

    Hi Angela these are great news!! Is Luminar 4 also supporting the Fotos application from Apple? Foto in apple Fotos Open with Luminar 4, do changes in Luminar and send back to Apple photos? Is that also possible as in Catalina?

    0
    Comment actions Permalink
  • Avatar
    Jan Schoonakker

    Hi,

    great news, I tryed it out and it works fine

    thank you

    0
    Comment actions Permalink
  • Avatar
    Alex Flinsch

    Great news - I updated Luminar 4 & Aurora this morning.

    Is there any chance of getting Luminar Flex updated? I realize that you consider ti to be a legacy application, but there is no good way to do batch photo processing in Luminar 4. 

    1
    Comment actions Permalink
  • Avatar
    Jim McNaughton

    I just updated to Big Sur and I updated Luminar 4 to 4.3.2. And now I get al Explanation Marks <!> on the files and folders in my catalog.  All the photos are just blurs when I bring them into the editor.

    Is there a fix for this or did I just loose all my work AGAIN!  Let me know

    Every time an upgrade gives me an issue.

    Jim Mc

    4
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    René Zuber - Yes, Apple Photos is supported. You can use it as an extension with Luminar 4 in both Big Sur and Catalina.

    Alex Flinsch - Unfortunately, Luminar Flex will not be updated. You mention batch processing - have you tried syncing adjustments in Luminar 4 and then exporting the batch? If so, what in that workflow do you find lacking?

    Jim McNaughton - I'm sorry you encountered an issue! Please reach out to us at www.skylum.com/support so we can help resolve the problem.

    0
    Comment actions Permalink
  • Avatar
    Alex Flinsch

    One of my normal workflow steps is to drag a set of raw files into Flex and apply a custom preset to every image, and have them exported to a directory with a custom name with the suffix containing the preset name. I could switch to using the batch process in L4, but Flex was much quicker - and a bit more intuitive since the option was right on the first screen..

    0
    Comment actions Permalink
  • Avatar
    Thierry Costes

    Hé.lo,

    When I use Luminar as a plug-in for Photoshop, I can work. Bur when I export the photography to Photoshop I have a black photography. 

    I have the lastest version of Luminar, downloaded tonight. And I've made a clean installation. 

    Please help. 

    Regards. 

    Thierry 

     

     

    3
    Comment actions Permalink
  • Avatar
    DJ Davros

    Is there a stand alone download link I can use for the Big Sur update? My Luminar 4 won't fully open, so using the update option thru the program isn't an option. Thanks.

     

    0
    Comment actions Permalink
  • Avatar
    Анатолий Ерехинский

    Yes, updated Luminar 4.3.2 works under Big Sur... as a standalone app. But when I tried it as a Photoshop plugin, I got a black photo.

    1
    Comment actions Permalink
  • Avatar
    Thierry Costes

    Well, it seems that the problem is the plug-in. 

     

    0
    Comment actions Permalink
  • Avatar
    Thierry Costes

    DJ, you dowload thé trial version. Install it and it's OK. But the software doesn't work as plug-in 

    0
    Comment actions Permalink
  • Avatar
    Анатолий Ерехинский

    Hi, Angela Andrieux

    So, we know that the problem is in the plug-in. And now what? Is there any intent to resolve this issue?

     

    1
    Comment actions Permalink
  • Avatar
    Thierry Costes

    I hope that Skylum will resolve this problem very quickly.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Thierry Costes - Please reach out to us at www.skylum.com/support so we can investigate this issue.

    DJ Davros - Absolutely:  https://l.skylum.com/luminar4_mac  or https://downloads.skylum.com/luminar4/mac/Luminar4.dmg

    Анатолий Ерехинский - Please reach out to us at www.skylum.com/support so we can look into this and get it fixed as quickly as possible.

    1
    Comment actions Permalink
  • Avatar
    Анатолий Ерехинский

    Dear Angela, why should I follow your link? You know the problem - just solve it. Your product is not yet compatible with actual macos. Make it compatible please.

    P.S. And how can I ask your cusomer support about compatibility with Big Sur if there is no Big Sur in your list of operation systems?

    0
    Comment actions Permalink
  • Avatar
    Nam Ing

    I reinstalled the plug in...however when I run it, whatever change I made in Luminar plug in, I just got the same image, as if the plug in doesn't do anything once it came back to Photoshop.

     

    1
    Comment actions Permalink
  • Nam Ing

    Same for me if the plugin is applied to a new layer. If there is only one layer, the photo just turns black.

    0
    Comment actions Permalink
  • Avatar
    Verlon Smith

    Will Luminar 4 or Luminar AI be native on the M1 Apple machines that were just released?  AI and all that AI pressing power sounds like a nice combination.

    0
    Comment actions Permalink
  • Avatar
    Richard Goldstone

    I have the same problem Jim McNaughton describes. All of my images are rendered blurry and out-of-focus and every one of them has the exclamation point in the triangle attached.  This was true when I installed Big Sur before upgrading to 4.3.2 and remains true after installing 4.3.2; it hasn't fixed a thing. (Well maybe exporting got fixed but I have nothing to export at this point.)  Note that this is not a plugin issue.  Exasperating!

    4
    Comment actions Permalink
  • Avatar
    Paul Jeromson

    As with Jim McNaughton and Richard Goldstone all of my images are rendered blurry and out-of-focus and every one of them has the exclamation point in the triangle attached. My version is standalone and not a plug in.

    2
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Verlon Smith,

    We are working on it and will ensure that Luminar will be compatible with these new processors.

    We need to thoroughly test Luminar on these new machines before and we will announce an estimated timeframe for compatibility with new chips as soon as we're ready to release it.

    -1
    Comment actions Permalink
  • Avatar
    Thierry Costes

    Hi Angela,

    I have the lastest version of Luminar 4. And it still doesn't work. 

    One more thing. My original photographies are in 300 dpi. When I work with Luminar as stand olone (I can't work with it as a olug for Photoshop) thé photographies are exported in... 72 dpi. 

    1
    Comment actions Permalink
  • Avatar
    Nam Ing

    To add to what Thierry Costes said...as stand alone when I open in photoshop the resolution got reduced comparing to the original.

    0
    Comment actions Permalink
  • Avatar
    Kevin Lane

    Very frustrating. I didn't update and it was working fine... saw the update that said it was for Big Sur and now I can't use it as a plugin - which let's be honest is the only way to use it in an actual workflow.  

    Is there an ETA on a fix? I emailed support... didn't even know this community thing existed. 

    1
    Comment actions Permalink
  • Avatar
    Richard Goldstone

    The response that Luminar has lost contact with the folders containing the original images suggests using the Missing Folder feature to reconnect.  This doesn't work for me.  My missing folder is the Camera Uploads folder on Dropbox and Luminar can't find it.  I have no problem accessing the folder via Finder and other applications have no problem accessing that folder and others on Dropbox so it isn't a Dropbox issue. 

    Bottom line: I still have no access to any of my edits.  Maddening!

    2
    Comment actions Permalink
  • Avatar
    Rick Law

    Reporting my own experience...

    Updated to 4.3.2.  Ran Luminar 4 in plug-in mode from PS, did an AI Sky Replacement, saw the "Processing..." dialog box, Luminar crashed, and the layer in PS was filled with black.

    Tried again, and instead of a black the layer consisted of the original image.

    It's unbelievable that the public beta of Big Sur has been out for months, issues have been reported here in the forum with responses from the forum admin.  Because of those responses, an obvious assumption can be made that the development team was aware of the issue, and yet rather than get ahead of the issue, they waited until the new OS went live to address it, pretending that they weren't aware of the issues.

    2
    Comment actions Permalink
  • Avatar
    Henric

    I still get big hangups. I see nothing under activity monitor and can't force quit L4, when L4 hang ups. I must do a complete restart mac OS/the Mac via power button... After over 10years of using Macs I have never seen this behaviour. Something is really really strange, bad code etc? What to do? It happens to often, everytime a new version comes out Im hopping for change and a stable one.

    Should I use AFP or SMB when I having my photo library (its huge 2TB) on a Synology NAS

    1
    Comment actions Permalink
  • Avatar
    Member

    I cannot even get Luminar 4 to load it crashed every time I try to open it to get to my folder. Not sure how to correct anything when it won't even open.  

     

    I would appreciate some assistance, please don't jus tell me to contact tech support. All that I ever receive is canned responses.

    0
    Comment actions Permalink
  • Avatar
    DJ Davros

    Angela, I am still having the same problem after the 4.3.2 install. The app still won't open and crashes within 20 seconds. Thanks again.

    0
    Comment actions Permalink

Please sign in to leave a comment.