Luminar 4 hangs on the splash screen after the update: solutions

Answered

Comments

475 comments

  • Avatar
    Member

    Well, I have that problem on an absolute fresh install of 4.3 on a brand new Laptop (bought a day before Luminar). There was never a 4.2 on that machine. I reinstalled several times, cleaned registry and tried nearly anything that seemed useful in this thread. After another uninstall i now tried the link to 4.20 from the post before mine. That produces a "Database opening failed" error. I have no clue what database, as I never even came so far to create any database. After a restart of the PC i get the same hang in Splash-Screen in 4.2 as in 4.3. So I won't even get 4.20 to run.

    Thank god I am in "Get your money back" time, as I already regret spending money on that software. 

    1
    Comment actions Permalink
  • Avatar
    Don Evans Photography

    Member  Sorry you got caught up in this at the wrong time.  I will reiterate, selling 4.3 to new users is shameful.  At the very least, they should revert back to 4.2 if they choose to keep selling this.  

    I believe "your issue" may be your catalog, created when 4.3 was installed.  Go to the top of this page for instructions on fixes... Do NOT pay attention to Registry Cleaning, or Firewall.... pay particular attention to steps 4 and 5, and then skip to the bottom line where the link to 4.2 is located.

    1. Reboot your PC.

    2. Uninstall Luminar.

    How to uninstall an app on Windows 7 (click this text to open link).

    How to uninstall an app on Windows 8 (click this text to open link).

    How to uninstall an app on Windows 10 (click this text to open link).

    4. Type %appdata% in Search (folder Roaming should open).

    Find the folder “Luminar 4” and rename it to "Luminar 4 old". Please note that this folder contains your license for Luminar 4, as well as your Custom and downloaded Looks. You will be later to access them later if necessary.

    5. Go to Pictures folder and rename the folder called "Luminar 4 Catalog" (if you have your Catalog anywhere else, find it and rename it to "Luminar 4 Catalog old").

    Open the folder and locate the file with .luminar file extension. Change the name of this file to "Luminar 4 Catalog old" as well.

    6. Reboot your PC.

    Install 4.2  https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline_420.exe

    2
    Comment actions Permalink
  • Avatar
    Member

    Don Evans I believe you are right to suggest that it all revolves around the creation of the Catalogue. For what ever reason sometimes the Catalogue creation  works, sometimes it doesn't. For me it worked AFTER the upgrade to Windows 10 xxx.450 but would not work before this update (unless I completely removed the Avast antivirus).

    The big question for Skylum is why. 

    I also agree that your excellent annunciation of a solution for a reversion to 4.2 should work. 

    Good luck everyone.

    0
    Comment actions Permalink
  • Avatar
    Member

    Don Evans Photography Thanks a lot, I just had figured that out before I saw your answer. I just deleted the catalog-folder and started 4.2 again. Then it recreated the catalog and worked as expected. So I will wait for a running 4.x now. Thank you again

    1
    Comment actions Permalink
  • Avatar
    Ronald Peters

    What worked for me was to add Luminar to the Windows Defender allow list, rather than turn off Defender. I also added Luminar to Malwarebytes allow list.

    0
    Comment actions Permalink
  • Avatar
    Philippe Carlier
    When version 4.3 was released, it worked for me for a few days, and then it didn't work at all.
    
    I wasted a lot of time trying to get 4.3 to work.
    The compatibility mode worked for a few days and then the blockage reappeared.
    
    So I uninstalled everything and went back to 4.2.
    
    I don't understand that a fix is ​​not available after more than a month.
    0
    Comment actions Permalink
  • Avatar
    EM

    My -meanwhile no longer working-  solution:

     

    - new start of Windows. Then don't start Luminar 4.2. or older

    - backup your Luminar Database in C:/Users/YourName or rename it

    - search at C:/Users/All Users/ the folder named "Luminar 4". Rename this folder. Later after success you can delete it. Or move or delete this folder in this step.

    - deinstall the old Luminar version with System Control. If it not works, delete the Skylum folder under C:/Users/YourName

    - install Luminar 4.3 with offline-installer. You find the link in the discussion above

    - start Luminar 4.3 and chose a new catalog

    - import at least one folder of your photo collection

    - play with Luminar 4.3, stop it, start it again, restart PC ...

    - after restarting pc you have to wait 10...15 sec at splash screen.

    - if Luminar 4.3 still works after these tests, chose your old catalog

     

    I think, the clue ist deleting, moving or renaming the Luminar 4 folder in C:/Users/All User ;)

    You don't need compatibility mode or admin rights.

    Good Luck
    EM

     

     

    Edit: sorry folks. 4 h after my "solutions" Luminar 4.3 hangs at splash-screen :-(((
    I'll install 4.2 again.

    @Skylum: don't count on my cents for upgrading to Luminar 5. Sorry, but programming skills of Skylum seems to be a joke.

    More than one month without a solution. Sorry Skylum, but you'l loose one more customer ! 

    1
    Comment actions Permalink
  • Avatar
    Member

    Count me in as one of the disaffected.  I would probably have received a free month of Adobe CC as some sort of compensation for paying for a product that doesn’t work.

    1
    Comment actions Permalink
  • Avatar
    Muhammad Al Shanfari

    I just paid $189 for both Luminar 4 and Aurora HDR, was a very happy customer. Funnily, I can't export on Luminar 4 anymore, it just jams when I choose "Export" and need to force the program to end from Task Manager. Is this related to this update or the timer must pass 24 hours since I exported 1 photo from the free trial and liked it! I hope this problem could be solve soon.

    1
    Comment actions Permalink
  • Avatar
    Victoria Grace

    HI Muhammad, we've sent you an email regarding this issue recently, could you please check your inbox?

    -1
    Comment actions Permalink
  • Avatar
    William Brooks

    Hard to believe Skylum has let this problem go unresolved for over a month.  I have recommended Luminar on multiple photography forums many times, but I no longer do so.  The problem with the 4.3 release is fairly common.  Here's how I now respond to anyone who has a problem with Luminar 4.3:

    There is a known issue with the Luminar 4.3 release, and Skylum has not issued an update to fix it. I tried Skylum's tech support suggestions, and none worked. Finally I uninstalled the program, cleaned the registry with CCleaner, and reinstalled the previous version (4.2) which is stable and works fine. The 4.2 version is available on their website.

    For anyone inquiring as to whether they should purchase Luminar, I advise them to hold off until Skylum issues an update to fix the problem.

    Aside from Photoshop, Luminar has been my favorite editing program.  What a shame Skylum has let this problem drag on.  I don't think they really understand the damage they are doing to their future sales.

    2
    Comment actions Permalink
  • Avatar
    Don Evans Photography

    William Brooks, I gave pretty much the same advice/warning to potential buyers in comments 2 days ago after having watched a sponsored Youtube video on Phlearn.  I can only assume that they provided Aaron with a 4.2 copy because it actually worked during the tutorial.  But I felt obligated to warn potential buyers that Luminar has been broken for over a month now.  EVEN IF a new buyer purchases and downloads 4.2 from the beginning, the VERY FIRST thing that happens when you open 4.2 is a prompt to upgrade and download 4.3... are you kidding me??????  

    2
    Comment actions Permalink
  • Avatar
    Member

    Don, maybe it just makes sense to start going to all the sponsored YouTube reviews and tutorials and commenting on how we all have unusable (literally) products. It would be one thing if Skylum acknowledged a serious flaw in their software, removed 4.3 from their servers completely, and advised customers to revert to 4.2. But that the first thing you see is a notification to upgrade back to 4.3? Negative press seems to be the only motivator these days. I wonder if anybody at Petapixel or DPReview uses any Skylum products.

    2
    Comment actions Permalink
  • Avatar
    Muhammad Al Shanfari

    This is very sad, I was insanely excited for the program after the free trial of Luminar 4.3 (worked perfectly). Now it works but I can't export, done the advises about firewalls but nothing. There was like a 1 day export for the free trial, and done one. Maybe this is a glitch that I need to wait for 24 hours and check again? I seriously can't see a better program, but in the same time I didn't buy it to preview potential photos that I can't export!

    Aurora HDR is working 100% fine though.

    1
    Comment actions Permalink
  • Avatar
    William Brooks

    One other thing that has me baffled.  Skylum is not giving us any information on the status of an update for fixing this bug.  Is it possible they're not working on it?

    2
    Comment actions Permalink
  • Avatar
    Bert van Barneveld

    Perhaps they skip 4.3 and deploy 4.4 straight away

    2
    Comment actions Permalink
  • Avatar
    Gordon Hendry

    Have to agree with Don and William, I don't get any feeling that this is being treated urgently.  All we get from Skylum in this thread is the oft repeated advice to clean up your registry and go back to version 4.2. 

    While that appears to work for most of us, we still get the laughable "upgrade now" message every time we open Luminar.  After more than a month we deserve better.

     

    Come on, Skylum, we are waiting!!

    2
    Comment actions Permalink
  • Avatar
    Muhammad Al Shanfari

    At least 4.2 is working perfectly after following the instructions, thank you guys! I'll keep an eye for the next update, hoping it will not be broken.

    1
    Comment actions Permalink
  • Avatar
    Member

    Just had an invite to join Luminar X Membership. They've got to be kidding me right?

    2
    Comment actions Permalink
  • Avatar
    Member

    You mean you don’t want to pay a monthly fee for a broken product?

    3
    Comment actions Permalink
  • Avatar
    Gordon Hendry

    Me too!  Do they really expect us to shell out more money when we currently aren't getting value from what we have already paid for?   I, for one, will certainly think long and hard before parting with any more cash to Skylum.  Luminar isn't the only software out there and I'm losing patience.  While I don't expect them to lose any sleep if I don't stay with them, they shouldn't expect me to be singing their praises to my fellow photographers.

     

    2
    Comment actions Permalink
  • Avatar
    Don Evans Photography

    Member, but it comes with tech support.... lol

    3
    Comment actions Permalink
  • Avatar
    EM

    So, what's new?

    Hanging at splash screen. Arghhh :(((

    @Skylum: after more than a month there is no solution for hanging in the splash screen?

    Very embarrassing performance of Skylum!

    How about more HI -> more human intelligence -> better programming skills of your team instead of AI in a program that won't start for some customers!

    As I said. Embarrassing performance of Skylum!

    3
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Everyone,

    The new Luminar X membership does not change your existing Luminar license. Rather, it is an optional add-on for those who already own Luminar and would like to get access to exclusive education resources and assets such as skies, Looks, LUTs, and more. We hope you'll check it out!

    -1
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi EM,

    Please reach out to us at www.skylum.com/support so we can assist you and look in to your particular case.

    -1
    Comment actions Permalink
  • Avatar
    Steve Daggar

    Likewise I have tried every solution offered here and also by communication with support and still can not get past 4.3 hanging on splash screen. Have a few emails back and forth with support 4 weeks ago, but not a word since

    1
    Comment actions Permalink
  • Avatar
    Przemysław Wiktorczyk

    Angela Andrieux 

    When we will get 4.3 version running properly?

    What will be compensation for lost time, databases etc? I lost database containing my 7-8 months work. 

    Yesterday I got info with your offer, but it's funny, Skylum is trying to sell licence/software, but don't care about people, who bought it!

    1
    Comment actions Permalink
  • Avatar
    Member

    Obviously the few users here can't generate enough pressure on skylum to really try and fix the problem. I bet the moment one of the great photography blogs would pick up the issue and generate negative publicity, everything would be fixed pretty quickly.

    1
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    We are extremely sorry for this inconvenience. Our tech team is doing its best to find a solution to this problem. For now, you may try reverting back to the previous version of Luminar and use it until the issue is fixed:

    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline_420.exe 

    Thank you for your understanding.

    0
    Comment actions Permalink
  • Avatar
    Robert Simoneau

    I had updated to 4.3 sometime ago and it works great. I tried to open it five hours ago and it stuck at the splash screen. I uninstalled several times, and it would launch properly from the installer. But once you exited the program, it will not start again. I have given up, and loaded version 4.2 which works every time.

    0
    Comment actions Permalink

Please sign in to leave a comment.