Luminar 4 hangs on the splash screen after the update: solutions

Answered

Comments

475 comments

  • Avatar
    Austin Miller

    Hi everyone! We are working around the clock on fixing the issues with the update 4.3.0. Please stay tuned!

    1
    Comment actions Permalink
  • Avatar
    Jared Ikeda

    I can't get it to load either. It works on my desktop but not on my laptop.  On my laptop it just hangs at the splash screen.  I tried all the recommended instructions to no avail.  How can I get tech support to respond?

     

    0
    Comment actions Permalink
  • Avatar
    Member

    I have followed these instructions and have completely failed to get past the splash screen in any mode.

    Skylum have not covered themselves in glory on this issue.

    I have wasted hours of my time. Not happy.

    0
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    Hi, I've also tried (most of the) suggestions provided. None worked beyond a one-time application launch. The very next starting attempt ended up in a permanent splash screen. After one week of  messing around I'll give it up for now and wait for a more sustainable solution. Meanwhile I'm even unable to reinstall version 4.2. Ok, my own fault I should have let it untouched.

    I've read several posts here and I learned that both MacOS and Windows users seem to have this problem. If that's true, I'd  doubt, that a specific component in the operating environment is the only culprit like an antivirus scanner. Beyond that, both operating systems are based on different platforms (some kind of Linux or Unix and on the other hand the Microsoft code base). Anyway ...

    I saw that serveral people meanwhile have sent you a lot of information about their systems and environment. I hope that's actually helpful. I would be interested in the results that you have found so far. Maybe you could share a few findings with us, and perhaps some information on how your approach is towards the solution finding process. I think this would give us a better feel for how long we still might have to wait until you could provide a stable update. 

    I'm fortunately not too dependent on Luminar at the moment, I can switch to a different image processor. But nonetheless, I'd appreciate if it doesn't take too long before we can get our hands on a stable release.  

    Good luck!

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Please try launching Luminar in Compatibility Mode:

    • Go to C:\Program Files\Skylum\Luminar 4 and right-click Luminar 4.exe file. Choose Properties option.
    • Go to the 'Compatibility' tab and choose a setting as shown in the screenshot: http://prntscr.com/tka660 
    • Click 'OK' button and try to launch Luminar.
    -1
    Comment actions Permalink
  • Avatar
    Xiao Ho

    This is broken.

    I installed the 4.2.0 version via the link, and now that doesn't work either. Doesn't matter if I'm running it as an administrator or not - not even the startup screen will show up. Tried running it from Windows Explorer and from Run, too - it does nothing, launches nothing, doesn't even start any new processes or use any resources.

    My previous version (4.1.0) used to work perfectly.

    Running Windows 7, for what it's worth.

    1
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    Hi Kirk,

    first of all, I uninstalled Luminar 4 after experiencing the before mentioned issues with the 4.2 version. So neither Luminar 4.3 nor Luminar 4.2 is actually on my computer.

    So, now I reinstalled v. 4.3 (offline installer). Contrary to my expectations, Luminar 4.3 ran up through to displaying the last image I was about editing when I first ran into the problems (a few days ago after the first updating).

    After a few seconds . I was just about to start feeling happy - Luminar ended itself without any indication. It just disappeared from the screen.

    Recalling the shy feeling of happiness a minute before, I did what you suggested, went to 'program files' and choose 'Windows 8 compatibility mode' and launched Luminar from that postion. This time - surprise - it opened up and showed the same image at the same state as before, but unfortunately it didn't give me time to feel the same happines as before. It crashed after - I counted - 3 seconds.
    I must admit, this compatibility issue was one of the few suggestions I hadn't tried before.

    I might try the same for v.4.2 later on.

    1
    Comment actions Permalink
  • Avatar
    Geoffroy VEGER

    Same problem here, 4.3 and 4.2 doesn't work, they show splash screen fo few seconds and close. Only the 4.1.1 works

    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline_411.exe

    I don't have any 3rd party antivirus software and no dedicated GPU.

    2
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    There seems to be a conflict between the luminar program (C:\Program Files\Skylum\Luminar 4\Luminar 4.exe) and MS's own ntdll.dll (C:\WINDOWS\SYSTEM32\ntdll.dll). At least that's my interpretation of some entries in the application event log.

    0
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    forgotten to mention that I tried to insall vers. 4.2 the same way as I did with vers. 4.3 yesterday (incl. Windows 8 compatibiliy mode). Got an error while showing the splash screen (Database opening failed).

    0
    Comment actions Permalink
  • Avatar
    Bruno F.W. Ristl, Bakk.phil.

    You have to unistall and delete all folders and files from version 4.3.0!
    Reboot and install version 4.2.0

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Stefan,
    If you're receiving the Database opening failed error, the steps below should help:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is C:\Users\%username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like. Don't remove this folder.
    4. Press the Windows logo key + R.
    5. Type %appdata%\Luminar 4 in the dialog box that opens and press Enter on your keyboard.
    6. Next, remove all the contents in Luminar 4 folder. Please note that this will remove your user looks and workspaces, so back up the folder into the safe location before removing it if necessary. You can then put your looks and workspaces back later.
    7. Start Luminar. It will ask you to complete the initial setup. 

    Geoffroy VEGER, could you please contact our support team at skylum.com/support regarding the crash? It doesn't sound like the issue discussed in this thread.
    We'd really appreciate it if you could provide our team with event logs.

    1. Reproduce the issue.
    2. Press the Windows logo key + R.
    3. Type eventvwr in the dialog box that opens and hit Enter on your keyboard.
    4. In the window that opens click the triangle next to Windows Logs on the left. A directory tree should open.
    5. Click Application in the directory tree. 
    6. In the main part of the window find the two topmost entries marked with Error named Application Error and .NET Runtime.
    7. Hold CTRL and click your left mouse button on each entry to select them both.
    8. Right-click on any of the two selected entries and click Save Selected Events.
    9. Name the file, save it, and attach it to your support request at skylum.com/support.


     

    0
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    @ Bruno F.W. Ristl, Bakk.phi

    Thanks, I actually did this before I re-installed 4.2.

    @ Helga

    Also thanks. Did what you suggested and after reactivating my license actually the installation of 4.2 successfully went through. I'm currently (Luminar is..) building a new Image gallery. That's no big problem for me.

    I'll wait for the catalog to be finished and will then restart the application. If something is going wrong I'll coming back.

    Any advancements in finding the cause for all these issues with 4.3 update?

    0
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    Helga,

    first it looked good. Then I imported a few (well roughly 15K) images and then ist closed without warning.

    I saw in the application event log:

    Faulting application name: Luminar 4.exe, version: 4.2.0.5577, time stamp: 0x5dedc13b
    Faulting module name: ntdll.dll, version: 10.0.19041.207, time stamp: 0xcad89ab4
    Exception code: 0xc0000374
    Fault offset: 0x00000000000fdec9
    Faulting process id: 0x1bcc
    Faulting application start time: 0x01d665c283d12e93
    Faulting application path: C:\Program Files\Skylum\Luminar 4\Luminar 4.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
    Report Id: 828a0304-9909-49d2-937d-0fc1b5fd2928
    Faulting package full name:
    Faulting package-relative application ID:

    I'll try reinstalling 4.2 tomorrow and will try a few other things.

    0
    Comment actions Permalink
  • Avatar
    Jaesung Lee

    It's been 2 weeks and I tried everything they suggested... still does not start on multiple devices. The update is broken. Please send a patch or something. It is so frustrating. 

    1
    Comment actions Permalink
  • Avatar
    Peter CLAIRHOUT

    Hi.

    I have approx. the same issue.

    Luminar 3 & 4.2 only open on the splash screen for a few seconds.

    I can't even uninstall. Uninstall failed.

    When I try installing new version 4.3 it's not even starting the installation process.

    update: when starting windows 10 in safe mode I get following error in Luminar 4: "Hard Error".  In Luminar 3 I get "A break point has been reached". In safe mode I also can't uninstall.  Setting luminar in compatibility mode "Windows 8" is also  given no results.

    I'm completely stuck

    0
    Comment actions Permalink
  • Avatar
    Matteo D'Errico

    i solved doing this after installation:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is C:\Users\%username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like. Don't remove this folder.
    4. Press the Windows logo key + R.
    5. Type %appdata%\Luminar 4 in the dialog box that opens and press Enter on your keyboard.
    6. Next, remove all the contents in Luminar 4 folder. Please note that this will remove your user looks and workspaces, so back up the folder into the safe location before removing it if necessary. You can then put your looks and workspaces back later.
    7. Start Luminar. It will ask you to complete the initial setup.

     

    then luminar ask me to insert account and key. Now it work

    0
    Comment actions Permalink
  • Avatar
    Don Goldman

    I rarely add to these discussions.  The latest release of Luminar 4 works fine on my Win10/64 desktop, and following their procedure, got the plug-ins for Photoshop and Lightroom to work.  However, I could not get Luminar 4 to run on my new Win10/64 laptop.  Uninstalled/reinstalled.  Worked once and then hung on the splash screen every other time.  Skylum advertises phone support, but there is none.  Received several emails after going through their on-line help center that didn't help.  I requested a call-back.  Now it's nearing the end of the week and almost gave up.  Accidentally arrived at a solution.  Right-click on the Luminar 4 icon and click on Troubleshoot Compatibility.  It found Luminar 4 not to be compatible, but was able to fix it.  Now it runs every time, including from Photoshop  Perhaps I overlooked this in reading all the questions you get when you initiate a technical support inquiry, but I wasted a lot of time and had high frustration with the lack of any phone support.  Although I like Luminar 4, it is difficult to recommend a company that refuses to provide phone support.

    0
    Comment actions Permalink
  • Avatar
    Steve Daggar

    Don Goldman tried this but didnt work for me. Tried autofix compatibility, also tried win8 & winVista compatability modes, splash screen still hangs

    0
    Comment actions Permalink
  • Avatar
    Stefan Schneider

    I have managed to install Luminar ver. 4.3.0 (6175) and start it five times in a row and was able to import approx. 12K images without experiencing a crash or so. Although I wouldn't call it a solution for everyone.

    It took me several hours and this is what I did:

    First of all I ran CCleaner and scanned the registry, then I let it fix found issues.

    Next I opened the registry ('regedit') and searched for all occurences with the strings ("luminar 4" and 'luminar4' in it) that were still left. I subsequently deleted all of those keys/parameters by hand.

    There were a few that I could not get rid of, these were entries in the 'HKEY_LOCAL_MACHINE\SYSTEM\....\Services\bam'-branch.

    After having done this (I backuped the original registry and the one after CCleaner had finished) I ran the luminar 4.3 offline setup. I chose to build a new catalog in a different position than before. I had of course to re-activate the license.

    After finishing the setup procedure, I closed Luninar. Then I restarted the and expected a hanging splash screen. I took some 20 secs for the splash screen to disappear but the application started through. I did the same once again: OK! it opened.

    I then imported approx. 8.000 images, which worked as expected. I closed the application. I did the same another 3 times and imported two other chunks of images (3.5 an 1K). After that I briefly edited an image. It worked as expected.

    The only nuisance is, that the application seems to behave very sluggish. Partly this is probably because I chose a normal HDD for the catalog to be placed instead of a SDD, where I had it before. At the moment I don't dare to move it.

    As I said, that's certainly not a solution in it's original sense. It just works for now.

     

    0
    Comment actions Permalink
  • Avatar
    Geoff Stokes

    Updated to version 4.3 seven days ago and system worked well for first few days both direct and as link through Photoshop.

    Then started to get hang up on "Splash" screen like many other users.

    Deleted complete program from laptop (New DELL I5 Inspiron), removed all Luminar directories, both hidden and visible, edited Windows Registry to remove all reference to Luminar, turned off antivirus and Firewall. Reinstalled version 4.3 from local file. System still hangs on "Splash" screen...........Once again completely removed all reference to version 4.3 from system.

    Reinstalled version 4.2 from local file.......program now works again correctly, both as a stand alone and via Photoshop.

    Will not be using 4.3 until receive confirmation that bugs have been sorted.

    0
    Comment actions Permalink
  • Avatar
    Bert van Barneveld

    What a mess... Having the same problem here.

    Just need to do some quick editing, not rebuilding my system!!

    Can someone @Skylum get us a simple, quick and easy solution to this??

    Till then I'll abandon Skylum

    0
    Comment actions Permalink
  • Avatar
    Helga Hufflepuff

    Hello everyone,

    Please, accept our apologies for the issues encountered with the new update. This problem turned out to be more complicated than we expected, thus we have not come up with a fix yet. Please, stay tuned.

    If offered solutions did not help, we would suggest reverting to previous version of Luminar 4.

    Please follow the steps below:

    Uninstall Luminar.

    How to uninstall an app on Windows 7 (click this text to open link).

    How to uninstall an app on Windows 8 (click this text to open link).

    How to uninstall an app on Windows 10 (click this text to open link).

    Clear your registry:

    • Visit https://www.ccleaner.com/ccleaner/download?pc
    • Scroll down to the bottom of the table and click Download from CCleaner.com in the first column.
    • Once the download has finished, launch the file and install CCleaner on your computer.
    • Launch CCleaner.
    • Click Registry on the left.
    • Click Scan for Issues in the lower left. Wait for the scan to finish.
    • After the scan has finished, click Fix Selected Issues in the lower right.
    • Close CCleaner.

    Reboot your PC.

    Download the previous version of Luminar from here: https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline_420.exe 

    Once the installer has finished downloading, locate it in your Downloads folder (or wherever you chose to save it), right-click the file, and click Run As Administrator. A prompt might appear asking you whether you wish to confirm your action, click Yes and wait for the installer to load. Then, follow the instructions on the screen.
     
    Please note that you'll need to start with a new catalog if you decide to switch back to 4.2.0. Therefore, I'd suggest creating a .zip out of your current Luminar 4 Catalog folder (by default, it's located in the Pictures folder unless you've specified otherwise). This will allow you to open your catalog later after you update back to the latest version.
    0
    Comment actions Permalink
  • Avatar
    Jared Ikeda

    Helga, the link you posted to download the previous version is broken.  It comes up with a 404 error.  I followed all your instructions to uninstall and clean the registry and would like to download the previous version of Luminar.  Can you please fix this and send out a new notice.

    Thanks

    1
    Comment actions Permalink
  • Avatar
    Charatpong Chotigavanich

    Every time I restart the computer and launch luminar 4.3 for the first time after restart, it would work like normal.  But after closing the program and launch again (without restarting computer), it would hang on the splash screen.  Have to restart the computer again to get it to work. 

     

    Edit: after adding the luminar .exe file in the firewall and windows defender's white list, it now works as normal.  I am running on windows 10 without Lr's plug-in.

    0
    Comment actions Permalink
  • Avatar
    Anthony Gouge

    I'm having the same issue.  After installlation of 4.3, I could open it as a standalone.  However, it would freeze when I tried to invoke it from PS CC.  I've rolled back to 4.2 and will await a solution.

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi guys! We are sorry for all the inconvenience. We are working hard on this case. As soon as we have some updates we will let you know.

    0
    Comment actions Permalink
  • Avatar
    Miguel Fernandes

    2
    Comment actions Permalink
  • Avatar
    William Brooks

    Fixing this problem seems to be taking a very long time.  I'm hoping Skylum is viewing this as priority #1.  On the photography sites I frequent people are now being warned to stay away from Luminar 4.  

    1
    Comment actions Permalink
  • Avatar
    Martin Ische

    I am still convinced that we are all test persons in an experiment (an American or Russian university), in which it is to be tested, how long users are willing to use a basically very good, but in important points useless software or even buy updates :-)

    Of course, this is not one of the stupid conspiracy theories that are currently in circulation.

    But I do wonder why Luminar does not get better with every update, but even worse (export function) or even a complete failure (can't be started anymore).
    I am a programmer myself and know about the difficulties of developing software. But here obviously important basics and test scenarios are not considered... Or the development runs so chaotically that nobody can see it anymore or is it due to a too high fluctuation of the programmers?
    No, it is a pure marketing product and a test balloon :-)

    0
    Comment actions Permalink

Please sign in to leave a comment.