Luminar 4 hangs on the splash screen after the update: solutions

Answered

Comments

475 comments

  • Avatar
    Jaesung Lee

    It's been 2 weeks and I tried everything they suggested... still does not start on multiple devices. The update is broken. Please send a patch or something. It is so frustrating. 

    1
    Comment actions Permalink
  • Avatar
    Jared Ikeda

    Helga, the link you posted to download the previous version is broken.  It comes up with a 404 error.  I followed all your instructions to uninstall and clean the registry and would like to download the previous version of Luminar.  Can you please fix this and send out a new notice.

    Thanks

    1
    Comment actions Permalink
  • Avatar
    William Brooks

    Fixing this problem seems to be taking a very long time.  I'm hoping Skylum is viewing this as priority #1.  On the photography sites I frequent people are now being warned to stay away from Luminar 4.  

    1
    Comment actions Permalink
  • Avatar
    Martin Ische

    @Steve Dagger:

    Nobody has actually written about the "end of the world" here, the caricature also goes in a different direction.
    And for which target group is Luminar a great product?
    I would not use "great" in this context.
    The program has some excellent implemented features and is therefore very well suited for editing single photos or for special effects on single photos, but sometimes only if you have patience.
    But for a "great product", in my opinion, a lot of features are still missing and of course a corresponding performance, which even 4.2 does not have.
    Especially if you have to view and edit many photos, the program is useless.

    1
    Comment actions Permalink
  • Avatar
    Steve Daggar

    As I said, have tried all suggested fixes including cleaning registry and deleting appdata, renaming catalog, installing as admin, setting Luminar 4.3 to open as admin and in compatibility mode & tried with Kaspersky paused and it still always hangs on the splash screen....so I never get a chance to create a new catalog because it wont start. Happily using 4.2 for now and waiting patiently for Skylum to come out with a fix rather than a suggested workaround

    1
    Comment actions Permalink
  • Avatar
    Member

    This may just be my first and last time with Skylum / Luminar 4. I just purchased Luminar to use in conjunction with and / or possibly get away from Lightroom and their subscription service. I'd heard good things about the program especially when retouching blotchy and acne filled faces. However, it's been one giant headache and loss of work time attempting to install, un-install, download and run CCleaner, rename files, turn off anti virus, edit to allow program through anti virus, restart, re-install, troubleshoot, retry compatibility mode, un-install, restart then attempt the offline version and the 4.2 version etc...etc...etc...with zero luck.I've requested a refund, but who knows if that will happen. ....have never had such issues with a program before, too bad, I was really looking forward to trying this out.

    1
    Comment actions Permalink
  • Avatar
    Member

    Just to add my "fourpenny worth", having hit the hanging splash screen issue, I decided that Luminar 4.3 didn't offer anything I desperately needed, and followed the instructions to revert to 4.2

    I have stopped worrying about it until it is corrected,

    Note that if you revert, having installed 4.2, delete folders Luminar 4 and Luminar Catalog 4 and the OLD.luminar file and rename the OLD files back to their original names (ie delete OLD) (AYOR) ... and ignore any invitation to update to 4.3.

    1
    Comment actions Permalink
  • Avatar
    William Brooks

    This is taking far longer than expected.  I'm not sure I can remember another company that couldn't make their software work as a Photoshop plugin.  I hope that Luminar is going to come out with a fix available in the software itself, as opposed to asking users to do one-off fixes.  I'm also a little concerned with the possibility that Skylum may not view this as a priority, particularly if the problem is affecting a (relatively) small number of users.

    1
    Comment actions Permalink
  • Avatar
    Matthias Meyerhof

    Der Tip funktioniert bei mir nicht. Ich komme nicht mal bis zu Punkt 2. Das Programm öffnet nicht, es bleibt im Startbildschirm hängen! Auch eine Neuinstallation bringt nichts!

    The tip doesn't work for me. I don't even get to point 2. The program doesn't open, it gets stuck on the start screen! Even a new installation is of no use!

    Grüße aus Berlin

    1
    Comment actions Permalink
  • Avatar
    Johann-Peter Petz

    Hallo zusammen!

    Nach 2 kumulativen Win10-Updates am 12.8.2020,

    habe ich probiert Luminar 4.3 nicht mehr als Administrator und im Kompatibilitätsmodus Win8 zu starten.

    Hurra! Es startet ganz normal und ist deutlich schneller.

    Grüße aus dem Allgäu! 

    1
    Comment actions Permalink
  • Avatar
    Member

    Johann-Peter Petz-  copy that.

    After the update of Windows 10 this morning Luminar 4.3 worked just fine even when using Avast. I found that I did not need to run as Admin or in comparability mode - worked just fine. 

    Strange that! Thanks Johann-Peter Petz for pointing that out.

    Barrie Edwards

    1
    Comment actions Permalink
  • Avatar
    Member

    Helo Christian Perret,

    A allech chi gyfieithu hynny i mi. Diolch

    1
    Comment actions Permalink
  • Avatar
    Miguel Fernandes

    Bom, aberto o precedente da valorosa germanofonia, convoco a turma lusófona a discutir mais à vontade: tem alguém aí conseguindo dar jeito nisso?

    Cordiais saudações cariocas (e rubro-negras, naturalmente...)

    1
    Comment actions Permalink
  • Avatar
    Mike Nogawd

    ^ No, not everything will be fine.

     

    Some of us have tried similar steps, but I figured to try yours exactly, even running the Wise "deep clean" option and restarting, but still hangs.

     

    This whole thing has been a joke.

    1
    Comment actions Permalink
  • Avatar
    Michael Eicher

    Ich wünsche mir die ältere Version ohne den Splash Screen, der den Murks mit der neuen Version bewirbt- das müsste doch wenigstens als Update für die ältere Version zu realisieren sein.

    1
    Comment actions Permalink
  • Avatar
    Member

    I won't echo the criticisms being voiced - suffice to say I agree with them all.

    It would be nice (but a dream) if the Luminar CEO came on this forum and explained what was happening!

    The good news is that eleven days ago (apparently I thought that it was longer) I reported that I had reverted to 4.2

    When Barrie (6 days ago), reported that, following that day's Windows 10 update, Luminar 4.3 was working for him, I decided to update. I cleaned out caches etc using CCleaner, updated to Windows 10 1909 and clicked the button in the pop-up window inviting update and waited. Things happened and I had a fully working Luminar 4.3 installation!

    The details - Windows 10 Pro. Version 1909 OS build 18363.1016.
    AMD Ryzen 5 2600X with 8GB RAM

    I then updated Windows 10 on my laptop and installed a copy of Luminar 4.3 (which had never had Luminar installed on it). That works as well.

    The details - Windows 10 Home Version 1909 OS build 18363.1016
    Lenovo Ideapad 320 Intel i3-7100U

    So I appear to have two problem free installations.

    The slight worry that I have is that there is a pending update on the desktop (Version 2004). Hopefully this won't upset things.

    If so I'll report back.

    Andrew

    UPDATE - Have installed W10 2004 OS build 19041.450 and all still works on the desktop

    UPDATE 2 - To use Luminar 4.3 as a plugin for Affinity Photo see this post
    https://community.topazlabs.com/t/affinity-photo-and-luminar-4-3/15684 - it works for me.

    1
    Comment actions Permalink
  • Avatar
    Member

    Well, I have that problem on an absolute fresh install of 4.3 on a brand new Laptop (bought a day before Luminar). There was never a 4.2 on that machine. I reinstalled several times, cleaned registry and tried nearly anything that seemed useful in this thread. After another uninstall i now tried the link to 4.20 from the post before mine. That produces a "Database opening failed" error. I have no clue what database, as I never even came so far to create any database. After a restart of the PC i get the same hang in Splash-Screen in 4.2 as in 4.3. So I won't even get 4.20 to run.

    Thank god I am in "Get your money back" time, as I already regret spending money on that software. 

    1
    Comment actions Permalink
  • Avatar
    Member

    Don Evans Photography Thanks a lot, I just had figured that out before I saw your answer. I just deleted the catalog-folder and started 4.2 again. Then it recreated the catalog and worked as expected. So I will wait for a running 4.x now. Thank you again

    1
    Comment actions Permalink
  • Avatar
    Erhard Markscheffel

    My -meanwhile no longer working-  solution:

     

    - new start of Windows. Then don't start Luminar 4.2. or older

    - backup your Luminar Database in C:/Users/YourName or rename it

    - search at C:/Users/All Users/ the folder named "Luminar 4". Rename this folder. Later after success you can delete it. Or move or delete this folder in this step.

    - deinstall the old Luminar version with System Control. If it not works, delete the Skylum folder under C:/Users/YourName

    - install Luminar 4.3 with offline-installer. You find the link in the discussion above

    - start Luminar 4.3 and chose a new catalog

    - import at least one folder of your photo collection

    - play with Luminar 4.3, stop it, start it again, restart PC ...

    - after restarting pc you have to wait 10...15 sec at splash screen.

    - if Luminar 4.3 still works after these tests, chose your old catalog

     

    I think, the clue ist deleting, moving or renaming the Luminar 4 folder in C:/Users/All User ;)

    You don't need compatibility mode or admin rights.

    Good Luck
    EM

     

     

    Edit: sorry folks. 4 h after my "solutions" Luminar 4.3 hangs at splash-screen :-(((
    I'll install 4.2 again.

    @Skylum: don't count on my cents for upgrading to Luminar 5. Sorry, but programming skills of Skylum seems to be a joke.

    More than one month without a solution. Sorry Skylum, but you'l loose one more customer ! 

    1
    Comment actions Permalink
  • Avatar
    Member

    Count me in as one of the disaffected.  I would probably have received a free month of Adobe CC as some sort of compensation for paying for a product that doesn’t work.

    1
    Comment actions Permalink
  • Avatar
    Muhammad Al Shanfari

    I just paid $189 for both Luminar 4 and Aurora HDR, was a very happy customer. Funnily, I can't export on Luminar 4 anymore, it just jams when I choose "Export" and need to force the program to end from Task Manager. Is this related to this update or the timer must pass 24 hours since I exported 1 photo from the free trial and liked it! I hope this problem could be solve soon.

    1
    Comment actions Permalink
  • Avatar
    Muhammad Al Shanfari

    This is very sad, I was insanely excited for the program after the free trial of Luminar 4.3 (worked perfectly). Now it works but I can't export, done the advises about firewalls but nothing. There was like a 1 day export for the free trial, and done one. Maybe this is a glitch that I need to wait for 24 hours and check again? I seriously can't see a better program, but in the same time I didn't buy it to preview potential photos that I can't export!

    Aurora HDR is working 100% fine though.

    1
    Comment actions Permalink
  • Avatar
    Muhammad Al Shanfari

    At least 4.2 is working perfectly after following the instructions, thank you guys! I'll keep an eye for the next update, hoping it will not be broken.

    1
    Comment actions Permalink
  • Avatar
    Steve Daggar

    Likewise I have tried every solution offered here and also by communication with support and still can not get past 4.3 hanging on splash screen. Have a few emails back and forth with support 4 weeks ago, but not a word since

    1
    Comment actions Permalink
  • Avatar
    Przemysław Wiktorczyk

    Angela Andrieux 

    When we will get 4.3 version running properly?

    What will be compensation for lost time, databases etc? I lost database containing my 7-8 months work. 

    Yesterday I got info with your offer, but it's funny, Skylum is trying to sell licence/software, but don't care about people, who bought it!

    1
    Comment actions Permalink
  • Avatar
    Member

    Obviously the few users here can't generate enough pressure on skylum to really try and fix the problem. I bet the moment one of the great photography blogs would pick up the issue and generate negative publicity, everything would be fixed pretty quickly.

    1
    Comment actions Permalink
  • Avatar
    Member

    Andrew J - it's clear they can't figure out the issue and rather than acknowledging this early on (when it would have been excusable to "force" people to downgrade back to 4.2) they've built up a lot of enmity with their customers.  In some ways this works for them - we are not on a subscription model, so we've already forked over our money for what is now a very flawed product.  We don't need to be kept happy.  Perhaps their CEO (who surfaces now and again) would dispute this, but their actions have made it clear we are flies buzzing in their ear.

    If we really wanted to motivate Skylum, it would be to prevent new customers from falling into this trap.  To that end, I may contact Pye Jirsa (who is probably not shooting many, if any, weddings right now) and all of the folks from the YouTube tutorials and see if THEY have this issue too. Thanks to social media's foundation of self-promotion, these folks aren't hard to reach.If they have any integrity, they could echo our sentiments more publicly.  Companies really only seem to listen once a problem becomes too big to ignore.  Maybe it's come to that.

    1
    Comment actions Permalink
  • Avatar
    Miguel Fernandes

    Dear Member, that is exactly why I decided, long ago, to deal with this matter as a joke, mockery. Since the second week I realized that it was not serious. I have some experience with developers, in Russia, the USA and the Netherlands. Never, never, NEVER before have I received such negligent treatment. The only appropriate answer to this joke is sarcasm. They are not taking this seriously. At least, of course, in the hypothesis that it is the most complex algorithm in the history of digital photography.

    1
    Comment actions Permalink
  • Avatar
    Gordon Hendry

    An open letter to the CEO of Skylum.

     

    Sir,

     

    On 16 July I attempted to install the 4.3 update to Luminar and found that, subsequently, Luminar no longer opened. I tried a re-install with the same result. I therefore contacted Skylum Support for advice and a solution to my problem. I was asked to send information on my Windows 10 system. I sent information to Support on three separate occasions and got no feedback on whether or not the information was of any use, simply the advice to roll back to version 4.2.

     

    By this time I had discovered on the forum that I was by no means the only user with this problem with a Windows 10 machine and Skylum Support were asking the users the same questions and offering the same advice to revert to the previous version. It appears that many of us have done this and I am certainly not the only user to get frustrated at having to bypass the exhortation to update every time I open the program.

     

    It is now 47 days since I first experienced a problem and there seems to be no resolution in sight.

     

    We are assured that Support are working flat out to find a solution – how long should it take?

     

    I suspect that most of us are using fairly “standard” Windows 10 installations, which begs the obvious question: “How much testing was carried out on the upgrade software before it was rolled out?”

     

    I, and I’m sure everyone else with this problem, would appreciate a bit of honesty from Skylum on what is actually being done to resolve this issue and what are you going to do to restore confidence in your product.

     

    I have enjoyed using Luminar but, at present, it would take a lot to convince me to part with any more of my money to a company that appears to distribute software that has not been thoroughly stress tested before release.

     

    1
    Comment actions Permalink
  • Avatar
    Marco Callegari

    End of my luck (well, maybe not)

    As others pointed, I just discovered Luminar works as "normal user" after a boot. But if you run other software, probably it will hangs (discovered yesterday... usually I was booting, starting luminar and shutting down after my editing)

    Now setting again the app to run as Admin solved the hang, so I can start Luminar, close it and then start it again without problems.

    Not sure why. Maybe due to a Windows change in some libraries...

    For example... I'm learning iOS with an "old" book (ios12 examples) and 2 days ago I forfaited about an example, as in iOS13 Apple changed some code and I got no clues for fixing the errors... Probably I'll need a more recent book... 
    So I don't exclude Microsoft changed something within the Windows core files. 

    Actually I can use Luminar so it's okay. Of course, as a developer (mainly in PHP and that's different from c# or java or whatever language they used for the desktop app so maybe I'm missing something) I'm wondering about the lack of news about the bug. I think they could open a ticket with a Microsoft engineer, or asking help from external developers. 
    Being transparent with us, actually, could be the best thing to keep their loyal customers.

    Luminar is cool, I can edit pictures in minutes and getting great results. Using Affinity Photo or other apps will require for sure more time. In my workflow, Luminar let me save a lot of time, so I'll keep using, hoping in a fix or a major release.

    Also, my business is in another field than photography, so for me it's okay.

    But I can understand all photographers angry, specially if the program don't start at all.

    So, c'mon Skylum, give a boost to Luminar devs, make us happier, and keep your user base! ;)

     

     

     

    1
    Comment actions Permalink

Please sign in to leave a comment.