Luminar 4 hangs on the splash screen after the update: solutions

Answered

Comments

475 comments

  • Avatar
    Gary Hutchings

    Barry Buehler  Scary?  Of what?  Are you three? 

    I know your type, just because it is is not a problem for you, then it shouldn't be even talked about when a problem for others. 

    Not the way it works.

    Being a suck up will not get you free software. Well, it might, free buggy software..  You are dismissed. 

    There is no value in conversation with you, so just stop talking AT me .. 

     

    0
    Comment actions Permalink
  • Avatar
    Gary Hutchings

    Mike Schwitalla Do you export images to an external drive? Or store the Luminar Cat on an external drive?  Luminar dose poorly when it comes to remembering paths. It seems to get hung real easy when paths in the app are pointing to extremals. I just built a $1000+ computer, fresh install of Win10 Pro, and the program still losses export paths. 32Gigs of ram 125watt Gen 10 processer, Nvida 1030 Graphics, it is still slow to process. I have not had the hung on boot screen since I moved all connections to internal drives. I copy files to the external for storage. Bought a big internal specifically because I invested money in this program.  

    0
    Comment actions Permalink
  • Avatar
    Member

    Had the same problem with Luminar 4.3 hanging on the Splash Screen but appear to have solved it.

    Decided to uninstalled Avast (antivirus) which had appeared to interfere with the saving of the catalogue file in some way. After the interference the next time I launched  Luminar it hung on the splash screen.  It continued to do this despite several reboots.

    I decided to roll back the Windows 10 system to a point just before I upgraded to 4.3 (I always back up the System Drive before installing or upgrading software).

    Having restoring the system I removed Avast and rebooted twice  I then installed a trial version of Bitdefender and configured the same. Then reinstalled  Luminar 4.3 using the offline installer (mentioned above). All then worked as it should albeit somewhat slower than in version 4.2.

    Having been using Luminar off and on for five hours all seems all seems stable if slower. 

    Hope my ramblings help. Good luck everybody.

    [Edit]

    Still running the morning after I did the above. However found that the erase tool won't work . Not at all!  Fortunately I found that if you run Luminar as Administrator erase works just fine.

    To run Luminar as Administrator permanently do the following:

    Right click on the Luminar Icon. select Properties and then Advanced. Put a tick in the box and your good to go.

    -1
    Comment actions Permalink
  • Avatar
    Helga Hufflepuff

    Hello Stephen,

    Please do the following to get Luminar up and running:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is C:\Users\%username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like. Don't remove this folder.
    4. Press the Windows logo key + R.
    5. Type %appdata%\Luminar 4 in the dialog box that opens and press Enter on your keyboard.
    6. Next, remove all the contents in Luminar 4 folder you opened in Step 5. Please note that this will remove your user looks and workspaces, so back up the folder into the safe location before removing it if necessary. You can then put your looks and workspaces back later.
    7. Start Luminar. It will ask you to complete the initial setup. While performing the setup, leave the location of the catalog at the default.
    8. When Luminar has loaded, click File > Catalog > Open > navigate inside the folder you renamed in Step 3 > double-click Luminar Catalog.luminar file. Your previous catalog should load.

    Please note: File > Catalog > Open is for opening catalog files, not photos. If you try to open a photo like this, you will receive a Database Opening Failed error.

    -1
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Please try launching Luminar in Compatibility Mode:

    • Go to C:\Program Files\Skylum\Luminar 4 and right-click Luminar 4.exe file. Choose Properties option.
    • Go to the 'Compatibility' tab and choose a setting as shown in the screenshot: http://prntscr.com/tka660 
    • Click 'OK' button and try to launch Luminar.
    -1
    Comment actions Permalink
  • Avatar
    Steve Daggar

    some perspective amongst all the angst in this thread. Luminar 4.2 is a great product, except for being oh so slow to launch.  If Skylum had not come up with an update, Luminar 4.2 users would have been happy to continue using 4,.2. Skylum didnt have to come up with an update. That the update is not working for some of us is regrettable, but not the end of the world

    -1
    Comment actions Permalink
  • Avatar
    Steve Daggar

    I should also add that 4.2 takes me 2 mins to launch. Dont recall 4.1 being anywhere near as slow

     

    -1
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Member,

    I am really sorry that you've had such a frustrating experience with our software. I will have someone from our support team locate your request and get back to you ASAP.

    -1
    Comment actions Permalink
  • Avatar
    Johann-Peter Petz

    Hi!

    Luminar: 4.3.0 (6175)

    Viel Erfolg!

    PS: Bei mir läuft es sogar mit Avast + Malwarebytes (Premium)

    -1
    Comment actions Permalink
  • Avatar
    Victoria Grace

    HI Muhammad, we've sent you an email regarding this issue recently, could you please check your inbox?

    -1
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Everyone,

    The new Luminar X membership does not change your existing Luminar license. Rather, it is an optional add-on for those who already own Luminar and would like to get access to exclusive education resources and assets such as skies, Looks, LUTs, and more. We hope you'll check it out!

    -1
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi EM,

    Please reach out to us at www.skylum.com/support so we can assist you and look in to your particular case.

    -1
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi J B,

    I am sorry to hear that none of the suggested solutions has helped you get this issue resolved. 

    We can suggest reverting back to 4.2.0 for the time being, while we are working on a permanent fix. And in case you would just prefer to go with the refund, we will respect your decision and issue it for you.

    Please get in touch with our support team at https://skylum.com/support and they will provide you with further assistance.

    -1
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    Mike Nogawd: The 30000 'first to preorder' sale is nearly sold out so I do not believe their sales have been significantly impacted. How do I know this? I received an email  the other day stating only 5000 spots were left. So, at this point in time over 25000 photo enthusiasts have preordered Luminar AI, I being one of them. I also joined the Luminar AI Insiders group (open to anyone who preorders)  and I can tell you that over 12000 photographers from all over the globe are there, young and old; male and female, amateurs, and professionals. There is no nightmare.

    This is a support forum and obviously attracts those that have issues with the software and some of these issues are serious, such as the point of this thread. That said, there is a much larger number of users not having any issues or only minor performance ones.

    -1
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi everyone,

    First of all, please allow me to extend my sincere apologies for the fact that finding a permanent fix for this issue is taking so long. I understand how much frustration and inconvenience we've caused you, and we are truly and deeply sorry for that.

    Our techs are still investigating this issue, and we believe we may be getting closer to the solution. I wish I could give you all a precise ETA for the fix, but we still don't have any information on this. 

    In the meantime, I can see that some of you would prefer a full refund - and we respect your decision. You can apply for a full refund at skylum.com/support. And our support team will issue it for you.

    For those of you, who will continue waiting for a fix, I would like to say a big thank you for your patience. I hope we can deliver good news to you soon.

    -1
    Comment actions Permalink
  • Avatar
    Barry Buehler

    I think this thread should be closed, since the initial problem has been solved.

    A new thread related to Windows upgrade problems, should be started.

    This will avoid confusion and help to track/diagnose unresolved issues, if any.

    It will also make clear that most of us have been made happy campers by the 4.3 upgrade.

    -1
    Comment actions Permalink
  • Avatar
    Barry Buehler

    Glenn Nosworthy ;  I was being facetious.  There was a know-it-all pretender who I enjoyed tweaking.  I realize there were/are problems, but since the initial "fix." we don't have a handle on how widespread any new problems are.  If you go back to posts after update 4.3 (6886?) many reported their problems fixed and there are few new complaints.  I know it is frustrating to buy a program and have it fail, but Skylum posted a link where you can ask for a refund.  That, to me, is a very satisfactory solution.  Nobody asked us to spend our time trying to solve Skylum(s) problems.  Take the money and run.

    -1
    Comment actions Permalink
  • Avatar
    Christian Perret

    Hi there,

    AFAIC I fixed this inconvenience by forcing Luminar not to use the IGP



    HTH

    -2
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi guys! I am sorry to hear if the issue remains for you. Our technical department is working on it. You can roll back to 4.2.0 for now. We are sorry for these inconveniences.

    -2
    Comment actions Permalink
  • Avatar
    Helga Hufflepuff

    Dear Xiao Ho,

    We are terribly sorry for the issues you encountered with 4.3.0. I just wanted to let you know that our development team is still working on this issue, so I can assure you that we did not forget about it. This turned out to be more complicated problem, thus it takes more time than we expected to fix. Of course, we will keep everyone updated once the ultimate solution is found. I made sure to reach you via e-mail to see if we can assist you to get Luminar up and running. 

    Even though we announced Luminar AI, we did not stop supporting and improving Luminar 4. I do understand your frustration about this problem and we will do our best to resolve it. Thank you very much for your cooperation and patience on this matter.

    -2
    Comment actions Permalink
  • Avatar
    Barry Buehler

    Hutchings:  It is not your job to fix Skylum.  Ask for a refund and go away, so most of us can enjoy Luminar 4.3.

    What do you hope to gain by your screeds?  We know you are soooo smart and knowledgeable.  Leave it at that.

    -2
    Comment actions Permalink
  • Avatar
    Barry Buehler

    ooooooooooooo.  Scarey. 

    I rely on W.S. 

    "Told by an *****, full of sound and fury,
    Signifying nothing."

    -2
    Comment actions Permalink
  • Avatar
    Barry Buehler

    Here's lookin' at youuuu kid.  Some folks are really fun to tweak for a response.

    Skylum is great!  Best ever.  I never have a moments triouble with their software.

    I just hope my photos keep winning competitions and complements.

    -2
    Comment actions Permalink
  • Avatar
    Barry Buehler

    -2
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi guys, we're sorry to hear that the issue persists. Our developers are working around the clock to find the root cause of the issue. As soon as we have a solution, we will let you know.

    We'd really appreciate if you could provide our team with your system info and event by attaching them to your support request at skylum.com/support.
    (You will find the instructions in Helena's post)

    While we're investigating the issue, you can install the previous version of Luminar. 
    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline_420.exe 


    You can also try following the steps outlined in this post: https://community.skylum.com/hc/en-us/community/posts/360009455080 

    -4
    Comment actions Permalink

Please sign in to leave a comment.