Luminar 4 hangs on the splash screen after the update: solutions

Pinned Answered

Comments

473 comments

  • Avatar
    Gaëtan LE TINEVEZ

    This version is ok for me too (Windows 10 2004).

    0
    Comment actions Permalink
  • Avatar
    Chris Brown

    Margret Bright, the test build works for me! Ran as administrator. No splash screen lock! Hallelujah 

    Windows 10, 2004 

    Build 19041.508

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    Chris Brown - what is the test build you are referring to?  Is that a Skylum build?

    0
    Comment actions Permalink
  • Avatar
    Martin Ische

    Yes, an official build of Skylum, see instructions at the beginning of this thread, page one, 2nd post (official)

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    Martin Ische - should the version number after install of the new test build still show 4.3.0 (6886)?

    0
    Comment actions Permalink
  • Avatar
    Martin Ische

    Yes, I guess so.

    With me this version is displayed.

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    Martin Ische - meaning your version # now shows 4.4.3.0 (6886)?

    0
    Comment actions Permalink
  • Avatar
    Martin Ische

    Yes, this version is displayed right at my place.

    But since I didn't have any problems before, I can't judge if anything has changed.
    The other problems, like speed, will probably not be changed anymore, now AI comes.

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    Martin Ische Clarifying a bit - the new test build zipped file is Luminar_4_430_6886.zip

    When I click on the Luminar 4 menu Help, then About Luminar 4, it still shows the software version number as 4.3.0 (6886).

    0
    Comment actions Permalink
  • Avatar
    Martin Ische

    0
    Comment actions Permalink
  • Avatar
    Martin Ische

    Where is the problem and where is there something to be clarified? I do not understand it right now.
    Yes, I have used the instructions from the Post and now this version.

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    Thanks Martin Ische for your responses.  I thought the new software version menu in Luminar 4 might reflect the version 4.4.3 version number. 

    The really good news is that the test build is working for me.

    0
    Comment actions Permalink
  • Avatar
    Jose F.G.

    La versión de prueba, de momento funciona, pero sigo con el problema de que las fotos tardan mucho en cargarse o se quedan en negro cada vez que avanzo por las imágenes estas desaparecen y se vuelven a cargar de nuevo. Es autentico problema, pues cuando tengo que vorver a una foto anterior tengo que esperar a que se cargue.

    1
    Comment actions Permalink
  • Avatar
    Loïc Deschamps

    Hi

    It's works for me, great

    regards

    0
    Comment actions Permalink
  • Avatar
    Gordon Hendry

    It appears to be working for me too.

    However, I would like some clarification. 

    This is a "build" of Luminar 4.3 which is sitting on my PC in the folder that I unzipped the file into, not an "installation" into Program Files which has updated / overwritten Luminar 4.2. Presumably I should uninstall Luminar 4.2 as they won't run in parallel. 

    Is it Skylum's intention to produce a new installable version based on this "build" version which would then install into Program Files?

    Or, are we all expected to purchase Luminar AI?

    1
    Comment actions Permalink
  • Avatar
    Martin Hyett

    @Gordon Henry - this is a test build giving us early access and helping Skylum test it on more systems. They will package it up in an official update when they are sure it doesn't cause other problems.

    0
    Comment actions Permalink
  • Avatar
    Barry Buehler

    Is this what they told you?

    "Martin Hyett

    @Gordon Henry - this is a test build giving us early access and helping Skylum test it on more systems. They will package it up in an official update when they are sure it doesn't cause other problems."

    0
    Comment actions Permalink
  • Avatar
    Chris Brown

    William Brooks 

    This is not a "build". So, there is not install file. 

    First, I would uninstall any version of Luminar you currently have. Then if you download the .zip file, unzip to a new folder. I created a Luminar folder in my Skylum folder (next to my Aurora HDR). Then I found the executable, right clicked it and checked off to run as administrator. Then when I double clicked on the executable, version 4.3 opened, seamlessly. 

    I haven't dared try getting to it from Capture One yet, but that will come tonight. 

    I imported a folder and was able to work on photos. Pretty quickly as well, I might add. 

    0
    Comment actions Permalink
  • Avatar
    Don Evans Photography

    Just to clarify, this test build will not work as a plug-in PS or LR until the actual update is released. Is that correct? I'm asking because I essentially never use luminar as a standalone, and only use it as a plug-in.

    0
    Comment actions Permalink
  • Avatar
    Barry Buehler

    The download is a portable app, which is great.  No mucking around with my registry.  Luminar 4.3 has always worked for me, but just out of curiosity, I fired up the unzipped download.  No hang.  Looks fine.  I didn't fool around with it, because I didn't want to overwrite anything from my install (skies, catalog, etc).

    0
    Comment actions Permalink
  • Avatar
    Setiawan Kartawidjaja

    Don Evans Photography Help answer: 

    After running first time, the test build will ask you to do update for PS plug-in. Click Yes and next time I tried from PS, it will automatically goes to this test build.

     

    0
    Comment actions Permalink
  • Avatar
    Setiawan Kartawidjaja

    Just sharing, here's the condition in one of my system (ASUS ROG):

    https://youtu.be/Wv7mSNSREKE

     

    With newly-released test build 6886 now installed, I can properly run it.

    The previous L4 4.2.0 build 

     

    However, since this is 'test build' where I instructed to unzip to separate folder, and Photoshop plug-in maybe affected to go to this separate folder - it is important to able to 'relink' again once the future official update build of L4 4.3.0 (after 6886) released.

     

    0
    Comment actions Permalink
  • Avatar
    Glenn Nosworthy

    I had got the 'old' Luminar 4.3 to work by setting Bridge, PS, and Luminar all to 'run as administrator'. Last night I extracted the test build to a folder on my desktop and copied across (overwrite) the files to the existing Luminar folder. I then started the Luminar test build .exe once as administrator with no problems. I have now removed 'run as administrator' from everything and the test build works as both a standalone app and as a plug-in to PS. Hope it stays that way... 

    That said, I'm not a techie, but I am very curious as to what caused the problem in the first place and so why it affected people in different ways and why it was so hard to pin down... 

    1
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    We are glad to hear that the test build works fine. Please use it until we roll out an update.

    We are grateful to all the customers who helped us identify this issue. Thank you for your cooperation.

    0
    Comment actions Permalink
  • Avatar
    Matthias Meyerhof

    Vielen Dank für die Version 6886. Sie funktioniert sehr gut bisher. Keine Probleme. Die Datenbank wurde konvertiert und die PlugIns Photoshop und Ligthroom aktualisiert.

    Ein Dankeschön aus Berlin

    0
    Comment actions Permalink
  • Avatar
    Miguel Fernandes

    @Jose F.G.

    Amigo, o mesmo -- exatamente o mesmo -- acontece comigo. Ontem, procurei o suporte da Skylum, descrevi o problema em detalhes, mandei um TXT com mais de 1Mb, contendo TODAS as informações do meu sistema. Veja a resposta que recebi. Não sei se é caso de rir ou de chorar. ES UNA BROMA, ESTO DE SKYLUM!

    Veja você mesmo

     

    Ou seja, o suporte tem a desfaçatez de me perguntar se a minha libray era demasiado grande! Se o meu sistema era demasiado lento... Esto es una broma!

    A base de dados, a biblioteca, a pasta em questão tem 12 mil fotos em resolução de Instagram. E isso JAMAIS foi problema para o Luminar 4.2. Por que será que a geração e manutenção de Thumbnails se tornaram subitamente um problema?

    Ou é má-fé ou é incompetência. Ambos inaceitáveis.

    0
    Comment actions Permalink
  • Avatar
    Miguel Fernandes

    @Jose F.G.

     

    Eis minha resposta:

     

    Dear Victoria,

    If I'm not mistaken, I have enclosed an exhaustive description of my system, both hardware and software environment. If you please consult this file, you will see that my settings exceed those recommended by Skylum.

    The library in question is a collection of 12 thousand photographs in Instagram resolution - 72dpi, 1080x1080 or 1080x1350 px. Yes, it seems a lot. It really looks like so many files that no software would be able to manage, doesn't it? However, there was a very good software, called Luminar 4.2, for which so many photos in a folder never, never, never were a problem. This splendid software, this wonderful piece of technology calmly took care of all those pictures.

    I wonder why replacing "4.2" with "4.3" may have caused such a complication, such difficulty, so many prerequisites for a smooth and fluid display of thumbnails. As I said, thumbnails don't just load slowly. They also DISAPPEAR as I scroll up and down. As if in a kind of deceiving game. The thumbnails are built, but they behave like rabbits: they run away. And, worse, every time I look for them in Luminar 4.3 (Jesus, how much difference a mere digit makes!) They refuse to appear, and when they do, just scroll the screen to behave like rabbits again. And again. And again.

    I'm pretty sure that no screenshot is needed.
     
    Sorry for my bad English; I am Brazilian and I would like to master your language as well as I do mine.
     

    B​est Regards

    Miguel Fernandes
    (21) 9000-0000
    0
    Comment actions Permalink
  • Avatar
    Marcel Morel

    Where can I download this Test-Version?

    0
    Comment actions Permalink
  • Avatar
    Martin Hyett

    Barry Buehler - apologies for the delayed reply.  Time zones!

    No, I wasn't told that by Skylum, just my deduction.  A test build is used as a quick way to send out to a wider audience to check for bugs.  I'm sure they will release a full installable update when they are sure it works for everyone.  They don't want to go through another 4.3.0 do that?!!

    0
    Comment actions Permalink
  • Avatar
    Marcel Morel

    I found it, sorry I was blind

    0
    Comment actions Permalink

Please sign in to leave a comment.