Luminar 4 hangs on the splash screen after the update: solutions

Answered

Comments

475 comments

  • Avatar
    Don Evans Photography

    There's still some underlying problem with Luminar though.  Not sure if this is related, I haven't seen others commenting on it as the 4.3 splash screen hang has dominated the conversation, but I have a very similar problem.

    BEFORE the 4.3 release, 4.2 would always work as the Lightroom plugin (and still does).  However, as the Photoshop plugin, it would work exactly ONE TIME after starting Photoshop.  If I tried to edit anything beyond that first photo with the PS plugin, it would show the splash screen, the splash screen would disappear, and PS would lock up.  I have to use Task Manager to kill the process, which leads to losing any unsaved edits in PS.

    After experiencing issues with 4.3 and reverting back to 4.2, it's happening again.  I don't use Luminar as a stand-alone product (only as a plugin), so I can't speak to any instances of that.

    Again, 100% of the time it works as a Lightroom plugin, so I've had to rearrange my workflow and, if I know I'll be using Photoshop and Luminar for edits (i.e. sky replacement), I always make a point to begin the workflow in Lightroom and perform any necessary Luminar edits PRIOR to taking it into Photoshop to do any further editing.

    Not sure if any of that helps, or adds to the confusion.

     

    0
    Comment actions Permalink
  • Avatar
    Glenn Nosworthy

    Well, the only thing that works reliably for me (L4 as stand alone or PS plugin) is to start as Administrator ... otherwise, I get stuck at the splash screen (it does not disappear and I have to end process tree to get back to PS).  

    0
    Comment actions Permalink
  • Avatar
    Steve Daggar

    my Luminar 4.3 was working fine after I reset windows10 until I installed Topaz Detail 3. It was installed before I reset Windows, but only just reinstalled today & after that Luminar would launch stand alone, but not as photoshop plugin. I uninstalled Topaz Detail, now Luminar 4.3 working fine again.  I have Topaz AI which supposedly superseded Detail, but I just liked a couple of the presets under Detail that were not carried over to Topaz AI, but I can live without them

    0
    Comment actions Permalink
  • Avatar
    Loïc Deschamps

    hi

    i will try to change libcef.dll (i put the version 73) and the problem persist. 

    My video card is Nvidia geforce

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    loic perrigaud: I replaced the following three DLL files:
    libcef.dll
    libEGL.dll
    iibGLESv2.dll

    There are a total of six DLLs that start with 'lib' but the above three are the ones I replaced on my machine. Also, note that my issue was not a hanging splash screen but the splash screen disappearing without Luminar 4.3 starting. 

    0
    Comment actions Permalink
  • Avatar
    Xiao Ho

    How do you uninstall every part of the program to do a clean install?

    The previous version (4.1) worked just fine. 4.3 doesn't work at all. Yet, when I uninstalled that and installed 4.2 using the link, the same problem occurs - I suspect it's because something from 4.3 was left behind.

    Running Windows 7 here.

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    William Brooks: It may well be but I personally would be surprised if the Windows 10 v2004 update is at the root of this issue. I have three machines (AMD desktop, i7 Dell laptop and a i7 Surface Pro 3)  all running Windows 10 v2004 without issue with Luminar 4.3.

    0
    Comment actions Permalink
  • Avatar
    Don Evans Photography

    Xiao Ho  I think the most common reason is probably Step 4 (below) during the uninstall/install process.  Check to ensure that this is done.

    If this isn't the cause of your issue, then I'm not sure what it may be.

    4. Type %appdata% in Search (folder Roaming should open).

    Find the folder “Luminar 4” and rename it to "Luminar 4 old". Please note that this folder contains your license for Luminar 4, as well as your Custom and downloaded Looks. You will be later to access them later if necessary.

    5. Go to Pictures folder and rename the folder called "Luminar 4 Catalog" (if you have your Catalog anywhere else, find it and rename it to "Luminar 4 Catalog old").

    Open the folder and locate the file with .luminar file extension. Change the name of this file to "Luminar 4 Catalog old" as well.

    0
    Comment actions Permalink
  • Avatar
    Barry Buehler

    "loic perrigaud: I replaced the following three DLL files:"

    Did anything good happen ?

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    Barry Buehler: Yes, on my desktop machine where I had the issue of Lumina 4.3 not launching, it launched and I am able to process photos with it.

    0
    Comment actions Permalink
  • Avatar
    Philippe Carlier
     
    Hello,
    There is a lot of advertising on Facebook right now for Luminar AI.
    
    Do not hesitate to request the patch for 4.3 by putting a link to this discussion thread.
    0
    Comment actions Permalink
  • Avatar
    Setiawan Kartawidjaja

    Currently my decision of whether preordering Luminar AI or not is more concerned with the recent situation due to pandemic... need to be more careful with my spending. Right now haven't think about it.

    I already have good impression with Luminar 4.3 or 4.2 but really hoping like everyone is, an update.

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    Saw this user's solution to his "Luminar 4.3 hang at splash screen." Posting a link here in case it can help someone else:

    https://community.skylum.com/hc/en-us/community/posts/360009620939

    I sure hope Skylum releases an update soon that resolves this once and for all. Customers should not have to jump through all these hoops to get Luminar to launch properly.

    0
    Comment actions Permalink
  • Avatar
    Chris Brown

    Martin Hyett,

    I don't think they are treating it as an urgent issue. Their urgency is getting AI released. And once AI is released, this will take on even less of an urgency. It is really disappointing, frankly. An update that doesn't work and absolutely NO response from Skylum. And if Skylum treats its paying customers like this, just what incentive do I have to hand over more money to them, for a new release! As bloated as Lightroom is, at the very least, their updates work. 

    And when someone from Skylum replies, it seems like boilerplate. They are working on it! Yeah, it is Milton down in the basement. But they are working on it

    0
    Comment actions Permalink
  • Avatar
    Martin Hyett

    You might be right, Chris Brown, but if I were Skylum and had this problem that doesn't have a solution, I would be worried that Luminar AI might have the same problem.  It needs to be fixed for long term confidence.  They will lose a lot of customers if people think their issues won't be addressed.

    On the subject of Luminar AI, I find it strange that they say Luminar AI is not an upgrade for Luminar 4, then they say that Luminar 4 will stop being supports, lust like Luminar 3 stopped getting support when the Luminar 4 upgrade came along.  Therefore Luminar AI is effectively an upgrade to Luminar 4. I don't see them announcing Luminar 5!

    0
    Comment actions Permalink
  • Avatar
    Nuno Santos

    What version are you on now?

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    It is a strange issue. On my Dell laptop (W10 v2004, 32GB ram, SSD and integrated graphics) I initially had no issues running Luminar 4.3. Then a few days ago it began to hang on the splash screen. Reboot, work once and then hang on the splash screen. Rinse and repeat. Starting just the other day, no more hang on the splash screen. I did nothing except perhaps remove an image or two from single image edits. Do not believe there were any Windows updates in the time frame of this issue. It just started working again. Strange issue. As a side note, I do not use the catalog and only do single image edits. 

    0
    Comment actions Permalink
  • Avatar
    Miguel Fernandes

    If I were the skylum, I'd open my game. If I were Skylum, I would not treat my clients like idiots. If I were Skylum, I would act with maturity and professionalism, in a more and more competitive market. If i were Skylum, it wouldn't allow me to lose customers. If I were Skylum, I wouldn't have released a test, fake update to use my customers as lab mice.

    0
    Comment actions Permalink
  • Avatar
    Steven Webb

    It's been mentioned by a few that having all Windows updates installed got their Luminar 4.3 working again. My Windows 10 Pro was up-to-date before this issue started and is still fully updated. v4.3 still is not working. I had to uninstall it and install the full version of 4.2 available in this thread. v4.2 is working without any issues so far.

    0
    Comment actions Permalink
  • Avatar
    Glenn Nosworthy

    Fall of those who still can't get past the splash screen, have you tried defaulting Luminar 4.3 to run as administrator? That worked for me. And to use the plugin, I had to do the same for photoshop. Been using L4.3 happily again for the past couple of weeks since setting this up. [There are a few inconveniences, like 'open with photoshop' no longer working in explorer, but I can live around that]. 

    0
    Comment actions Permalink
  • Avatar
    Jose F.G.

    Me siento bastante engañado. Compré Luminar porque lo probe y me pareció un gran programa para edicion rápida y como complemento de Adobe, pero actualmente no puedo trabajar con él, se me para, es lento, las imagenes se borran, la base de fotos si es grande, se queda en negro.... En definitiva una pena de programa, espero que al menos pudiésemos actualizar a AI como buena voluntad de Skylum, aunque creo que prima mas el dinero que la voluntad.

    De momento han perdido un cliente, a no ser que arreglen este problema y den un margen de confianza para seguir confiando en sus productos.

    0
    Comment actions Permalink
  • Avatar
    Heather Bartley

    I'd like to thank Margaret Bright and Skylum for the offer above.

    I don't think any company could be more fair about the situation and they have restored my confidence completely.

    0
    Comment actions Permalink
  • Avatar
    Heather Bartley

    Thanks Miguel,
    No, you didn't make me feel uncomfortable :-)

    I've been investing in computer software for my computers for many years, in fact since before IBM sold their first PC.
    I can't begin to tell you how many disappointments I've had with software over those 40+ years.

    Without going into further detail, I just wanted to say that I have never, ever, had an offer for money back even a month after using buggy software, plug-ins or add-ons and so I felt very happy having a refund offer after having access to that software for 11 months.

    I never wrote to Skylum advising that Luminar 4 was no longer running on my PC's as I rarely use photographic software since retiring as a Glamour Photographer 5 years ago.  As far as I know it was working a few months ago when I checked for updates but I did not do any editing. It was really purchased for my wife who plays "occasionally" whilst I still mainly use Photoshop as I'm old school and as I say, retired now.

    Not having written and complained to Skylum until coming to this forum after searching for a solution, I have no idea as to whether or not the outcome would have been the same, but for now, I will happily purchase Luminar AI for my wife as a replacement for Luminar 4 when it is available having every confidence in a 30 day refund option if for some reason it does not work on her PC.

    I know when we first purchased Luminar 4 she got some results which without my many years experience editing tens of thousands of images in Photoshop, she could not have achieved.
    It felt a little buggy at first but seriously, what new packages don't these days?
    The hardware and software differences between our PC's are infinite so how can any developer test their goods completely before release?

    I Beta test various software for a number of BIG companies and after a year of hundreds of testers submitting feedback and bug reports, software is still released full of bugs that some users experience and others do not, and so there are numerous updates day after day from even the largest of companies.

    Sometimes, an update is released and everything is fine for most but we see a number of people are unable to run the software without a crash to desktop or any problems whatsoever - that is often simply due to the complexities and differences in our PC's, messy windows registries and all sort of other possibilities, none of which a developer is aware of until we tell them and provide them with fault logs etc.

    OK, cheers to all, I have no need to come back to this thread.

    0
    Comment actions Permalink
  • Avatar
    Bob Noodle

    How can I get back to the previous version, while I wait for a fix?

    0
    Comment actions Permalink
  • Avatar
    Setiawan Kartawidjaja

    Bob Noodle

    Help answer (can be seen on the first post on this thread)

    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline_420.exe

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi. Please reach us via skylum.com/support so we can look into the issue with the refund.

    0
    Comment actions Permalink
  • Avatar
    Member

    Margaret Bright, the test build works for me.  Don't forget to add the instruction to right-mouse on the executable and unblock it in addition to setting it to run as administrator.

    0
    Comment actions Permalink
  • Avatar
    Gaëtan LE TINEVEZ

    This version is ok for me too (Windows 10 2004).

    0
    Comment actions Permalink
  • Avatar
    Chris Brown

    Margret Bright, the test build works for me! Ran as administrator. No splash screen lock! Hallelujah 

    Windows 10, 2004 

    Build 19041.508

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    Chris Brown - what is the test build you are referring to?  Is that a Skylum build?

    0
    Comment actions Permalink

Please sign in to leave a comment.