Luminar 4 Mac crashed, then doesn't start anymore




  • Avatar
    Helga Egilsdottir

    Hello Gaby Femenia,

    Thank you for your post. We are sorry for the issue you encountered and will do our best to help.

    Please try the following to reopen Luminar: 

    - Open Finder.
    - Click Go in the top menu > click Go to Folder.
    - Paste the following path: ~/Library/Caches/SentryCrash/
    - In the folder that opens, locate Luminar 4 folder and delete it. 

    If it does not help, please do the following:
    - Hold down Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
    - Select a backup that has been created prior to when you encountered the issue with the library and click Restore from Backup.

    Most likely you are experiencing the bug, which has been already fixed. Its fix is going to be added along with 4.3.0 Luminar version. Our team is planning to release it very soon.

    The solutions we sent above are workarounds to make Luminar 4 work.

    We would suggest to do the following to decrease the amount of crashes:

    Launch Luminar 4 > select Luminar 4 in upper left corner > choose Preferences > set Frequency to Once per session ( )

    Let us know how it works, please.

    Comment actions Permalink
  • Avatar
    Gaby Femenia

    Thank you so much Helga Egilsdottir!

    I tried your first instructions, and that worked!

    thanks again!

    Comment actions Permalink
  • Avatar
    Florian Guillin


    I've exactly the same problem but I've bought my Mac only two weeks ago and I don't really undestand the instructions 

    is it possible to have the instructions in pictures please ?



    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi. Please contact us via and we will be glad to help you.

    Comment actions Permalink
  • Avatar
    Lenore Denbin

    I am beyond frustrated by luminar...currently it will not open as an extension/plug in whatever in Photos.

    Comment actions Permalink
  • 0
    Comment actions Permalink

Please sign in to leave a comment.