Luminar 4 and nvidia gpu

Answered

Comments

2 comments

  • Avatar
    Kate Williams

    Hi Ralf,

    We do try to implement improvements step-by-step and target several performance-related issues in each update. However, there are tasks that are rather difficult to implement in a trice, they are large-scale ones and have lots of subtasks. It's a pretty arduous process that takes a great amount of time and effort. Nevertheless, our techs are working around the clock to make the lives of our artists better balancing between cutting-edge AI-based features and performance boosts.

    Right now, our devs are refining the next update that will contain some performance improvements, so we'd highly appreciate it if you could try it out. It's expected to ship quite soon.

    Besides, please contact us at https://skylum.com/support - we'll take a closer look at the performance issues you're facing. 

     

    -1
    Comment actions Permalink
  • Avatar
    Mykola Podolianiuk

    The problem as I understand is that Luminar use GPU0 only even in cases when discreet GPU is available in the system and mapped to GPU1/2/...

    I have two configuration where I held experiments:

    1. Laptop Dell XPS 15 9570 i7 8750h (6 cores, 12 threads), Intel 630 as GPU0, nVidia GTX 1050Ti MaxQ as GPU1.

    2. Desktop with i5 3570k (4 cores, 4 threads), nVidia GTX 1070 only as GPU0, Intel video is disabled in BIOS and not usable.

    I observe that on the laptop Luminar 4 does not use nVidia GPU1 in any variant, but always use Intel GPU0. I tried pining it to nVidia video with nVidia Control Panel, with Windows Default Settings. I tried to set nVidia GPU as default GPU for all apps. I tried running Luminar directly seting GPU. Nothing helps.

    This behavior exists for on board and for external screen (modern laptop architecture is interesting in term how GPUs are linked to different video outputs).

    I use the latest available drivers, but I doubt that such behavior depends on driver versions.

    On the other hand on my pretty old desktop with 1070 Luminar is fast and furious as there is no option what GPU to use. Only nVidia.

    Such Luminar behavior is the only thing that hold me from purchasing eGPU for the laptop and sell old desktop.As such upgrade will not help. Also this problem will stop me from upgrading to newer Luminar versions in case this problem is not resolved till Luminar 5 is released.

    1
    Comment actions Permalink

Please sign in to leave a comment.