Just updated to luminar 4.2, keeps crashing every time I open it

Answered

Comments

26 comments

  • Official comment
    Avatar
    Angela Andrieux

    Hi Ivan,

    I'm sorry to hear that! Please reach out to www.skylum.com/support so our techs can investigate the crash.

    Comment actions Permalink
  • Avatar
    Member

    I am having the same issue. I have deleted and reinstalled the program several times, but it continues to crash.  I had the trial version and loved it so I decided to purchase the program.  Since I have purchased it, the program keeps crashing.  I have it had the program for only two days.  I hope it can be corrected. 

    0
    Comment actions Permalink
  • Avatar
    Member

    I found a fix from a person of FB that showed me how to go into Finder, then folders, and how to delete the crash file.  The program is now working. 

     

    -1
    Comment actions Permalink
  • Avatar
    Ken Salmon

    I am having the same problem it keeps crashing, what the SOLUTION vary frustrated?? 

    0
    Comment actions Permalink
  • Avatar
    Member

    1
    Comment actions Permalink
  • Avatar
    Member

    The above corrected the issue for me.  I am not a computer expert and I am new to Luminar 4.  There are several groups on Facebook for the software.  I jointed a couple and I have found a lot of support.  Hopefully this helps.  I blocked out the name of the person who provided me the information because I did not ask permission before posting this.  

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi all! Please reach us here so we can investigate your issue - skylum.com/support!

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi all!

    Please try the following solution to fix the crash:

    1. Hold down Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
    2. Select a backup that has been created prior to when you encountered the issue with the library and click Restore from Backup.
    Let us know how it worked.
    3
    Comment actions Permalink
  • Avatar
    Mark Hume

    Austin,

     

    this worked for me.

     

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Mark,

    Great to hear! 

    Have a nice day!

    0
    Comment actions Permalink
  • Avatar
    Ellen Rosenberg

    nope didn't work.. i used it a half an hour ago.. .then boom won't open from PS now. . I can open it as separate app,, but that is not how i do it... help.. .

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Ellen,

    Please reach out to us at www.skylum.com/support so we can investigate your particular case. Looking forward to hearing from you!

    0
    Comment actions Permalink
  • Avatar
    Ellen Rosenberg

    I have sent two emails.. willl send another.. 

     

    0
    Comment actions Permalink
  • Avatar
    Helga Hufflepuff

    Ellen Rosenberg,

    Replied to your e-mail. Thanks!

    0
    Comment actions Permalink
  • Avatar
    Paul Heath

    Hi 

    I’m having the same issue. I’ve been through the change catalogue routine and reinstalled. Works fine for a few edits then crashes again. Happened three times. Judging by the number of others sharing a similar fate there is clearly a global issue that doesn’t need us to keep sending you our crash files - they’ll all be the same. I assume you’re working on an update/fix? When will this be resolved please ? In the meantime I’m reverting to Affinity

     

    Regards

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi Paul. Please contact us via https://skylum.com/support so we could investigate your case.

    0
    Comment actions Permalink
  • Avatar
    Carlos Garza

    For now the solution of Austin Miller has worked. 

    I have Luminar 4.2 

     
    0
    Comment actions Permalink
  • Avatar
    Jon Saunders

    Same thing just happened to me. Deleting that crash file did the trick!

    -1
    Comment actions Permalink
  • Avatar
    Member

    Austin Miller Solution did work for me 👍🏻
    Couldn't try the other solution as I dont see a /SentryCrash folder under /Library/Caches

    0
    Comment actions Permalink
  • Avatar
    Andrew Edgecomb

    Deleting the SentryCrash file worked like a charm. Thanks for posting that! The screenshot at the start of this thread is pretty much identical to the error I was repeatedly getting. 

    0
    Comment actions Permalink
  • Avatar
    Bramley Johnson

    Hello all. Does this work for when the program freezes? My program isn’t “crashing” and closing. It’s simply freezing and not allowing me to click anything (usually happens after exporting).
    Luminar support wasn’t helpful - reinstall but use a 3rd party removal program which I am not about to do.
    Any suggestions? Thanks!

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Bramley,

    If the app freezes on export, please try the following:

    1. Ensure that you have all the read-and-write permissions for the export directory, try changing it (preferably, internal drive). 

    2. Ensure that the image file is not exceeding 15,000 pixels on one of the edges. 

    3. There is also a solution to reset your PRAM. This way, your computer will work faster. Here is how you can do that:

    https://support.apple.com/en-us/HT204063 

    Please note that you might be asked to reset some of your computer adjustments such as date and time, mouse settings etc.

    You can also get back to our support team and ask for an alternative solution - they will be happy to further assist you.

    0
    Comment actions Permalink
  • Avatar
    Tamer Zourob

    Hi Austin,

     

    This worked for me.

     

    Thanks 😊 

    2
    Comment actions Permalink
  • Avatar
    Joe Jukkrit Wanichinchai

    Hi Austin Miller,

    Thank you so much 

    1
    Comment actions Permalink
  • Avatar
    Jodi Rumer

    This worked for me as well.

    0
    Comment actions Permalink
  • Avatar
    Bramley Johnson

    Having the same issue. However it seems that it will now freeze only on the first export. Force quit, reopen and it seems to work from there on.

    0
    Comment actions Permalink

Please sign in to leave a comment.