New Luminar 4.2 Update: New Tools Turn Luminar Into a Creative Powerhouse

Comments

96 comments

  • Avatar
    Mats Grehag

    I have discovered a bug that came with this update. I organize my photos after editing based on the date and time the photo was taken. That information remained even after editing and exporting. After the 4.2 update, that information is still available in the RAW format but disappears when I export to JPG format.

    I just noticed when I was organizing the last month's worth of pictures. As a result, I have plenty of nice midday pictures that apparently took place past midnight, and the order and occasion is screwed up.

    EDIT: Found something more. Previously I could go to properties for a JPG file and find the date taken under details -> origin. That field is now empty like I said, so my program that batch renames my photos can't use it. However, the info panel inside Luminar still shows the correct date taken.

    To me that sounds like Luminar now stores that information somewhere that Windows can't find.

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi Mats. Please reach us via skylum.com/support so we can further investigate the issue you are experiencing.

    0
    Comment actions Permalink
  • Avatar
    Christian Baudouin

    Hello,

    I'd like to thank J Bish for his very helpful explanation about Nahimic, the faulty program for GUI instability in Luminar 4.2. On my system, the graphical issues occured when switching from one setting item to another or when changing the display size of the image being edited.
    I would just like to specify that in my case, there is no nahimicservice.exe visible under this name in Windows Services. However, ran in background SS2UILauncher.exe, actually a variant of the Nahimic program linked to A-Volute_3D_Sound_Experts company. This application was installed by default in my ASUS G752VY laptop system. The executable of the program is located by default in this folder : "C:\Program Files\ASUSTeKcomputer.inc\SS2\UserInterface\SS2UILauncher.exe".

    After disabling SS2UILauncher.exe, the stability problem in Luminar 4.2 no longer occurred. I searched for the solution for several days before discovering the component responsible for this problem.

    I also hope that my bad experience sharing will be useful to other Luminar users who may have encountered the same bug.

    Best regard,

    Chris

    0
    Comment actions Permalink
  • Avatar
    Member
    Thanks Chris,
     
    Glad it helped, It all revolves around the realtek sound driver implementation,
    In my case I had the nahemic files,
    So first place for those looking for answers,
    Check your sound files,apps etc... 
     
    Regards,
    J Bish
    0
    Comment actions Permalink
  • Avatar
    Member

    I solved my own problems. Just upgraded my system. Went out and spend $1k bucks on a Lenovo i7, solid state drive, 16gb ram gaming pc and 4.2 installed and works as advertised. Except! when I use layers, then export the edited image, the exported image is the unedited version and not the composited version...there must be a step that I am missing??? is there a way to 'flatten' the layers before export??

    0
    Comment actions Permalink
  • Avatar
    Justin Bonaparte

    Any update on the bug where every time I run Luminar 4.2 I have to enter my activation code?

    1
    Comment actions Permalink
  • Avatar
    Member

    Yep, confirmed new bug alert with 4.2 

     

    As I mentioned above, when using layers and exporting a group of photos, in my case about 30 images, the layered edits do not export...only the unedited version. I just uninstalled 4.2 and reinstalled 4.1 and the issue is not there, layered exported images render just fine with the layered edited image. It seems to happen randomly in 4.2. If you export a single layered image, sometimes the exported image shows the layered composite, then sometimes it doesn't.

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi Justin

    I solved this by deleting an erroneous entry of "C:\Windows\System32" in the Environment Variables Path string which I think gets added by the Luminar 4.2 install script.

    See https://superuser.com/questions/1178674/wmic-is-not-recognized-as-an-internal-or-external-command-operable-program-or and remove the trailing "C:\Windows\System32"

    0
    Comment actions Permalink
  • Avatar
    Justin Bonaparte

    Hey there, thanks for trying, but I don't have an additional path variable.

    0
    Comment actions Permalink
  • Avatar
    Kurt Friis Hansen

    I've recently installed Luminar 4.2.0 (5577) on a completely new Windows 10 Pro machine. Previously mainly used it on Apple machinery the latest months.

    The Windows version is pure horror, compared to Lightroom 6.14 on the same hardware, same environment etc

    Hardware and environment

    Machine: 4CPU/8Threads Intel I7-10510U 1.8-4.8 MHz

    16GB DDR3 2133 Dual Channel RAM installed/soldered-in

    Samsung NVMe 3, 4-lane 1TB SSD (typically >2.500 megabyte/sec read and >1.800 megabyte per second write - sustained data transfers of tens to hundreds of gigabytes). Two Thunderball 3/USB-C connections as well as direct Gigabit Ethernet or 802.11ac (WiFi-5) in short distance (WiFi-6 present in machine, but not yet in my network).

    Gigabit network, cabled or via Thunderbolt dock (speed as expected), 866Megabit 802.11ac (typically 70+ megabyte/second throughput for simple image transfer of the same 30 GByte image set in many directories), and for verification of the behavior the same data via USB-C 3.1 gen 2 connected SSD (as well as direct Thunderbolt 3 connected SSD). On SMB shares typically delivering 100-108 MB/sec sustained (10-20GB mixed data) on gigabit network. Shared data from NVMe SSD on Mac machine (or from NAS). Behavior is consistent for all sources (Luminar is sloooow).

    Windows 10 Pro version 1909, Microsoft HEIC/HEIF support installed (working too on other software). Max. performance allowed, AC power.

    Catalog creation on imported images (smb share, gigabit, WiFi and local SSD disks as well as internal SSD)

    WiFi-5 smb share test

    Luminar 4.2.0 (5577)

    Network share (From mac with NVMe SSD on 1 gigabit network).

    1 CPU (1 thread) used (never more - out of 4/8 max)

    Typically 3-10% CPU power used at lower frequencies. Max 1-3% network speed used

    Catalogue containing 2051 files in many (sub)subdirectories.

    Image display periodically abysmally slow, lots of prolonged delays between (from seconds to half minutes or more) images in sequence.

    No heic/heif files handled. No videos handled.

    Lightroom 6.14 (old, but still going strong)

    All available CPU’s and Threads in use (4/8 out of 4/8)

    Typically 25-50% total CPU power used

    Max approx. 40-50% network speed

    No heic/heif files handled. Most videos handled (two HDR10+ videos ignored).

    Internal SSD Test catalogue creation

    Luminar: Slow catalogue creation. Up to 50 Megabyte/second read, typical less than 20.

    The setting “By Capture time” does not work. Not read from image, neither from OS, but not consistently either. June 8, 2020 displays 1657 of 2195 files for 2020 (none were made nor present for today). Example: File from April 20, 2020 at 13:17.in OS (not displayed on that date in Luminar showing zero files that day). File info (jpg) shows April 20, 2020 13:17 - both as file name, and in EXIF. Inside Luminar, the date is shown as June 8, 2020 17:17:15. OS dates are - primary - April 20, 2020, 13:17:01 (modified) and the OS specific dates June 8, 2020 19:17:15 (both created and last opened). Why not use the date from EXIF? That’s the only consistent date for any image.

    Lightroom catalogue creation:  Greased Lightning. Up to approx. 400 MB/sec, typically fluctuating around 100 megabyte/second including GPS address lookup. 34 video files ignored. 2 unsupported. Lightroom shows correct capture dates (of course, always has, since first edition ;-)

    Moving “around” in catalogues. Luminar is - ahem - challenging. The old Lightning is an express train in comparison. Same environment, on local NVMe SSD!!

    Comments

    Luminar: No heic/heif files handled. No videos handled.

    Periodically luminar hangs for up to 10-30 seconds, especially when working on network images, when switching to next image in a sequence in the same directory; nearly always when switching directories!

    Old Lightroom 6.14 is roughly a factor 8-10 FASTER at creating a catalogue, and selecting display of a subdirectory content is more or less immediate (also files on network share) - typically within a second for shared directories containing <100 files (Lightroom).

    Luminar can delay display completion for up to a minute in some cases for the same type of operations and files on identical network shares on identical hardware.

    The old Lightroom 6.14 is often considered to be abysmally slow. Not compared to my Luminar 4 on the same machine in the same environment on Windows 10 Pro. Lightroom is “greased lightning” compared to Luminar 4 on Windows 10.

    If the old Lightroom 6.14 speed wise runs rings around Luminar 4 on modern gear, and at the same time often delivers better image quality immediately after import; there must be something fundamentally wrong with the Windows 10 version of Luminar.

    The Windows 10 version is a pure and genuine farce in my view, also compared to the Mac version - even on the horribly bug ridden Catalina OS. That’s a feat in itself, or...  ;-)

    On the same files, in the same environment, Lightroom 6.14 from 2017 (!!!) performance simply outclasses Luminar 4.2.0 on Windows 10 Pro 1909 on identical hardware and in identical environment. Whether working completely on local (500GB) or internal (1TB) NVMe SSD's, or via cabled or wireless network.

    The Luminar 4 behavior is so dramatically ‘orrible, that it cannot have been a secret for management and developers - only for us paying customers.

    Conclusion: Luminar 4.2.0 (5577), what a bummer!

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Kurt,

    Thank you for taking the time to share your experience with us.

    At the moment, our devs have two major tasks: the algorithm performance improvements and resource use optimization.

    These are large-scale tasks that in the long-term perspective will give the app a significant boost as well as increase the development speed. Therefore, please rest assured that every day Luminar is getting better. We hope you'll be there with us to see this progress.

    Please also note that Luminar is for photo-editing only, it indeed does not support videos.

    Unfortunately, there's also no information yet on the matter of HEIC support implementation on Windows. There are some technical difficulties with the implementation of HEIC files compatibility. We'll definitely consider implementing it in the future, however, for now, there's no ETA for that. Please, stay tuned!

    If you have any further questions or would like us to take a deeper look at the performance issues you have experienced, please get in touch with our support team at https://skylum.com/support. Our team will be happy to help!

    -1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    ..... Therefore, please rest assured that every day Luminar is getting better.....

    haha — how is that supposed to work without an update? the update that has been promised for months is still not available - neither for Luminar 4 and certainly not for Luminar 3. May is long gone.

    STAY TUNED !!!

    2
    Comment actions Permalink
  • Avatar
    Member

    Y'all released an update that broke most systems from being able to use this software... Someone needs to fix whats busted instead of just taking money and not fixing the issues by recommending a band-aide work around... Folks paid good money to give your software a go and have been let down... Next step for many I'm sure is to start asking for a refund because the software does not work@ last update... Honestly... I haven't used it since last update broke it... And to me that's an issue... You cannot say its system related... I built a 3,000.00 system and it still does not work...lmaoo...

    1
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Member Hi! We are aware of some issues, we are working on them. Please reach our support team so we could help with your particular case: https://skylum.com/support

    -2
    Comment actions Permalink
  • Avatar
    Member

    Ananstasia

    "J Bish Hi! We are aware of some issues, we are working on them. Please reach our support team so we could help with your particular case: https://skylum.com/support"

    Have already been through all of that... No fixes in over 3mths... Unacceptable no matter how you spin it...

    3
    Comment actions Permalink
  • Avatar
    M L

    I just came back from a short trip with 1100 pictures and hoped the update has already been released because end of May or begin of June was mentioned. Sadly...no update yet, so I had to do parallel editing with LR and Luminar as Luminar on its own would be way to slow for a lot of edits in a row...waiting times, export times,...although I love a lot of edit options in Luminar 4 it is just not possible without at least doubling the edit time - if not even way more.

    Any news concerning the update? I would really like to use Luminar 4 but like this I personally can only use it for single edits but no batch edits of > 50 shots.

    2
    Comment actions Permalink
  • Avatar
    Victoria Grace

    HI there,

    Thanks for all your patience. The update will be released till the end of the month. Thanks for your understanding!

    -1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    Genau die gleiche Ankündigung hatten wir die vergangenen Monate.

    1
    Comment actions Permalink
  • Avatar
    M L

    I am very excited to see if it will be postponed again.

    Wolfgang Jarcik Das stimmt. ;-)  Hoffen wir das Beste.

    1
    Comment actions Permalink
  • Avatar
    Stefan Puffer

    I probably won't even bother with the update as I've pretty much given up using Luminar.  It's such garbage that I don't even publish my affiliate link anymore because I just can't recommend this software to anyone. 

    3
    Comment actions Permalink
  • Avatar
    Helga Egilsdottir

    Stefan Puffer,

    We are terribly sorry to hear about your experience with Luminar 4. 4.3.0 update showed great results in terms of performance speed. We do hope that it will dramatically improve our users' impressions and maybe you will give us another chance in future. Surely, we did not want to let you down. 

    -1
    Comment actions Permalink
  • Avatar
    Kurt Friis Hansen

    Hi, “daughter of Egil”


    Wouldn’t it help, if we - mere mortals actually paying for the, ahem, “privilege” with our own money - also were endowed with a chance to evaluate an actual release version 4.3.0? Like Lenin is supposed to have said: “Trust is fine, but control (verification ;-) better!”

    Just checked on my Windows 10 Pro machine, and my Luminar 4.2.0 informs me, that, my version is current.

    So, ehhh... you’ve probably gotten the releases mixed up (we customers get the flaky beta versions, while the (possibly) working release versions are reserved for internal pre-release testing (since I’ve still to see an actually, somewhat working release since the (also) ‘orrible 2018 and 3.x versions!!

    Sigh...

    1
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello Kurt. The update 4.3.0 will be released very soon. If everything goes fine we will be able to launch it within 2-3 weeks. Please stay tuned!

    -1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    just as I expected - June will be extended, the end of the month will be later. Skylum should hire a good programmer to finally fix the problems. We have been holding customers for months, not a single problem has been solved. We paid good money and still can't use Luminar (neither 3 nor 4) properly.

    1
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi Wolfgang! We hear everyone and are trying to do our best to release the new update as soon as possible. During this update, we have encountered some issues that is why it is delayed. The good news is that we have overcome them and are going to release the update 4.3.0 in the nearest time!

    -1
    Comment actions Permalink
  • Avatar
    Kurt Friis Hansen

    @Austin Miller: Frankly, your best is not good enough.

    It was not enough to get 2018 to deliver an acceptable performance, and certainly version 3 and now 4 shows, that you’re still not able to deliver working software - from time to time you even manage to produce releases,that for all practical purpose are plain unusable, if more than one or two images are involved in the limited number of formats, you support.

    You’re at least consistent - alas consistently behind the curve delivering questionable quality with tendency towards self-destruction when used, is not what I would strive after, if I where you. Luckily I’m not, and I have concluded, that in the long run Adobe may even be the preferable evil (even though I loathe their subscription approach). They at least deliver, which cannot be honestly said for Skylum; effectively emulating a low cost yearly “tax” or “subscription” of lower but, really, dubious value to boot.

    Maybe you should have invested more in software quality, and saved a bit on the influencer and affiliate excess. When even some former affiliates seem bent on distancing from Skylum, there can’t be much real substance left in the company in my view.

    0
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    Hi Austin,

    and how about Luminar 3?

    1
    Comment actions Permalink
  • Avatar
    Member

    Will/is the Nahimic driver issue being resolved as well?

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi everyone!

    Kurt, I truly understand your frustration. Please note that our developers are working hard to implement improvements to the overall performance of the software in each update. They also have some large-scale tasks that in the long-term perspective will give the app a significant boost. Therefore, please rest assured that every day Luminar is getting better. We hope you'll be there with us to see this progress.

    Wolfgang, we are working on the next update for Luminar 3 as well. Unfortunately, there's no precise ETA on the release date yet, but we will keep you updated.

    J Bish, the Nahimic driver issue is currently being investigated by our techs. Regrettably, for now, I cannot guarantee a fix in the very next update, but our team is working on fixing this issue as soon as possible. Please stay tuned! We will let you know when the fix for this issue is released.

    0
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    Hi Margaret Bright

    you wrote: "we are working on the next update for Luminar 3 as well. Unfortunately, there's no precise ETA on the release date yet, but we will keep you updated."

    You don't really believe that yourself - do you? For many months there has not been an update for Luminar 3 - not even the Magic Mouse problem has been fixed yet. Although I was allowed to test it months ago with a trial version (for Luminar 4) and the problem would actually be solved with it.

    0
    Comment actions Permalink

Please sign in to leave a comment.