New Luminar 4.2 Update: New Tools Turn Luminar Into a Creative Powerhouse

Comments

96 comments

  • Official comment
    Avatar
    Victoria Grace

    Hi guys,

    You may try using the offline installers if you've faced the update issue:

    Win OS:

    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline.exe

    Mac OS:

    https://downloads.skylum.com/luminar4/mac/Luminar4.dmg

    Speaking of the graphics and performance problems you've mentioned above, please, reach us at www.skylum.com/support so our techs can take a look at your particular case. Thanks!

    Comment actions Permalink
  • Avatar
    Member

    Every time I run 4.2 (on Windows 10) it asks for the activation code?

    2
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi Mark,

    Your anti-virus software and firewall may be the issue. Please try the following:

    If the solution above doesn't work, please send us your Hosts file for review to support@skylum.com. The file is located here:

    C:\Windows\System32\drivers\etc\

    Looking forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi.  I'm using Norton and I disabled it and same problem.

    My hosts file is just the default that comes with Windows 10, I've made no edits.

    Worked fine on 4.1.  Maybe I was too hasty with the upgrade?

    0
    Comment actions Permalink
  • Avatar
    Saravana Janardhan

    I get the below error. please help.

    1
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi all. Here are the offline installers for both Windows and Mac:

    1. Windows - https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline.exe
    2. Mac - https://downloads.skylum.com/luminar4/mac/Luminar4.dmg

    The offline installers should fix the issue you've described above!

    Let us know how it goes!

    -1
    Comment actions Permalink
  • Avatar
    Tim Nodelman

    Hi,

    I'm trying to update Luminar 4.1.0 version to 4.2 version on Mac with getting error

    0
    Comment actions Permalink
  • Avatar
    Saravana Janardhan

    Update: Looks like there is some issue with installer trying to access/write to "C:\Program Files\Skylum\Luminar 4" folder. If i rename and run installer it completes successfully.

    Developers check if this has something to do with the issue with installer.

    The above link points to 4.1.1 version. I am trying to update to 4.2.

     

    0
    Comment actions Permalink
  • Avatar
    Luca Santirocco

    2
    Comment actions Permalink
  • Avatar
    Michael Oertel

    I reseted all my licenses (Windows) of Luminar 4.

    When I activate the new Version 4.2, in the License Manager the OS "Mac" will be displayed.

    This is not correct - of course.

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi Michael. Could you please send us the screenshot here - support@skylum.com?

    0
    Comment actions Permalink
  • Avatar
    Robert Becker

    As with previous versions of Luminar 4, could you please post the MSI version of the 4.2 installer.  I have issues with the kernelbase.dll file which prevents the other loaders from working.  Please Please post the MSI version.  Thanks

    0
    Comment actions Permalink
  • Avatar
    Reed Harrison

    Looks like I am one of the folks who can't get Luminar 4.2 to load after successful installation.  Followed tech support guidance and made sure Windows10 had all the updates in place and still no success.  Was very happy with previous release, any quick tips on downgrading back?

    2
    Comment actions Permalink
  • Avatar
    Jose Plaza

     

    I am very excited to test Luminar 4.2, but as in previous versions, it cannot update by itself.

    Skylum, could you please provide a correct link for Luminar 4.2 windows offline installer?. The ones provided in several threats point to version 4.1.1 instead of 4.2.

    Furthermore, the link to the new manual still points to the old one (from december 2019) without the new tools.

    0
    Comment actions Permalink
  • Avatar
    George DeCamp

    Tried both ways to install update and still get the "OOPS" message and no install. I'm guessing you are looking into this.

    -1
    Comment actions Permalink
  • Avatar
    Szilveszter Zoltán

    Need a correct offline installers link because the above link points to 4.1.1 version. I am trying to update to 4.2.

    Launching the Luminar 4.1 can't update to 4.2

    2
    Comment actions Permalink
  • Avatar
    Paul Meachen

    I managed to download and install it OK - but it won't load.  First I get a message saying a database migrate is needed, then after I click on OK I get this, then when I click OK it closes:

    0
    Comment actions Permalink
  • Avatar
    Member

    @ Paul ... Mine after install said the same thing... I clicked ok and relaunched application... I am having many graphical issues within new update,,, Arrows showing just a black box unless scrolling over them with mouse, preview/zoom window is not working correctly after an edit... Buttons disappearing... Has frozen already once... 

    System is

    Win 10 64b Pro

    AMD 3900x 12 Core

    32gb Ram

    C Drive 500gb NVME 

    1
    Comment actions Permalink
  • Avatar
    Paul Meachen

    I've tried several times - same error over and over.

    0
    Comment actions Permalink
  • Avatar
    Member

    These graphical glitches I'm seeing seem to be related to either opening in regular window versus opening maximized Picture is maximized and you can see the glitch Im referring to that disappears if you minimize the app and then re enlarge it...

    0
    Comment actions Permalink
  • Avatar
    Darryl Brooks

    A Giraffe?

    0
    Comment actions Permalink
  • Avatar
    Member

    Here's a screen capture video of glitches happening in real time...

    https://drive.google.com/open?id=117sNk9Hn4vTWJTqp6tEmjcAAavzExCYU 

     

    Regards

    2
    Comment actions Permalink
  • Avatar
    Terry Hight

    attempting to update to 4.2   

    keep getting Luminar 4 4.1.1 (5343) is the currently newest version 

    Attempted the offline it just reinstalled same version . 4.1 

    on windows 7 

     

    2
    Comment actions Permalink
  • Avatar
    Mike Leslie

    Just Upgraded to 4.2,  

    1:  Browsing from catalog slow 75 seconds to display 153 photos.

    2:  After double clicking photo from browsing grid 20 seconds to be able to edit.

    3:  AI Sky Replacement not working.  Photo taken with Nikon D750 in portrait, in Luminar 4.2 I rotate image 90 deg CCW, then replace sky and sky replacement is 90 degrees off.  see attached.

    0
    Comment actions Permalink
  • Avatar
    Stanford Thornton

    You have some real video problems.  I'm running GeForce GTX 1060 video.  When I run AI Augmented Sky and try to Place Object the video jumps all around.  This is only one of many graphics problems this version has.  It was good with version 4.1.1

    You have managed to screw up a good piece of software.  Go back to the drawing board!!

    0
    Comment actions Permalink
  • Avatar
    Member

    My Software shows I have activated 2/2 licences, one when I bought it and the other yesterday when I upgraded to 4.2.

    I own a Windows 10 PC and I installed and upgraded on that PC.  I haven't owned a Mac since a Macintosh circa 1988.

    0
    Comment actions Permalink
  • Avatar
    Thomas S.

    I can't update to 4.2. The following message always comes up:

    System: Windows 7

     

    2
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Avatar
    Erwin Kargl

    Everything is fine here. No problem updating L4 on two machines.

    Thanks

    Erwin

    0
    Comment actions Permalink
  • Avatar
    Stanford Thornton

    My system is MSI laptop I7 16GB Ram Geforce GTX1060 video 6GB.  Runs the following with no problems Photoshop, Lightroom, ON1 Photo Raw 2020, Topaz DeNoise AI and Luminar 4.1.1.  The problem started with Luminar 4.2.

    0
    Comment actions Permalink

Please sign in to leave a comment.