No performance gains in 4.1.0

Answered

Comments

6 comments

  • Avatar
    Colin Grant

    Must admit I do not find it much faster either, if at all. Seems more stable and have had no crashes but that is it. Still nowhere near good enough for consideration as my got to editor.

    1
    Comment actions Permalink
  • Avatar
    E Matthezing

    I do see performance gains in 4.1 but not as much as i hoped for.

    Skylum has to look into the proper use of the GPU card. I have done several tests and almost no feature/option of Luminar4 uses the GPU.

    Currently i am a Lightroom user and the performance in that program is way better with the normal editing options. For example brushing, noise reduction etc. I have a iMac 27 2019 version with a Radeon Pro 575X 4 GB. When in Lightroom the gpu usage is normal to high with cpu not over 50%. In Luminar there is none to little GPU showing and most of the time 70 to 100 percent cpu usage. This is without working in Layers in Luminar4.

    In library mode the update to 4.1 is much quicker and exporting to jpg also on my machine. 

    1
    Comment actions Permalink
  • Avatar
    Colin Grant

    I am certainly seeing the high CPU use. The Library is faster, I agree, but that is really where it stops - there is nothing more of merit speed wise anywhere else.

    1
    Comment actions Permalink
  • Avatar
    Alexander Hof

    Agree, it's not good enough. I'm giving it a try tonight but getting frustrated by the minute. 

    2
    Comment actions Permalink
  • Avatar
    Daniel Johnson

    It’s still slow. Using as a plugin seems faster than standalone, I wonder how long we will need to wait for next update.

    2
    Comment actions Permalink
  • Avatar
    Anna V

    Hi Everyone, 

    Thank you for your feedback.

    We will do our best to improve the performance and speed with every update we release.

    Your patience in this matter is highly appreciated. 

     

    0
    Comment actions Permalink

Post is closed for comments.