Luminar 4 and EXIF data

Answered

Comments

10 comments

  • Official comment
    Avatar
    Anastasia Davis

    Hi Juan and Ian! Does it happen with all the images? Did you do any changes in Photoshop first? 
    Please reach our support team with this case: https://skylum.com/support

    Comment actions Permalink
  • Avatar
    Ian Murrell

    Juan Jackson

    I don't have Photoshop. I use Luminar 4 as a plugin from Affinity Photo via the same plugin (Luminar4.8bf) that is used for Photoshop.

    There does appear to be an issue with Exif Data.

    If I open a particular photo in Luminar 4 freestanding, and click on the Info Tab, it shows the camera model, lens model, ISO, Apperture, Shutter speed and focal length.

    If I open the same photo in Affinity Photo, then use the Luminar plugin to open it in Luminar, all of the Exif information is missing in the Info Tab, with the exception of the  Aperture setting, and that has a changed format. And as I've just noticed, the date in freestanding is the date shot, but it is the current date in the plug in version, and the file size is also different ??

    Thing is I can't remember this occurring with Luminar 4 before the latest version 4.1.0 (5191) so it may be the plugin file (which wasn't changed with the update) may now have some incompatibility.

    0
    Comment actions Permalink
  • Avatar
    Ian Murrell

    Anastasia Davis

    Have raised the issue with support as you requested.

    It does apply to all the JPG and TIFF images I have tried, and also regardless of whether there were any edits done in Affinity prior to passing the image to Luminar, or not.

    Rather fortunately, Affinity Photo is retaining the original EXIF data even when the image has been returned from Luminar 4, so the final export from Affinity does have the correct EXIF data. (That may or may not be the case with Photoshop, I don't know as I no longer have Photoshop).  So when Luminar 4 is used as a plugin from Affinity Photo, the issue only appears as a problem with information shown in the Info tab.

    0
    Comment actions Permalink
  • Avatar
    John Couvaras

    GPS data is not retained on export?

    0
    Comment actions Permalink
  • Avatar
    Ian Murrell

    John Couvaras

    John, GPS data (GPSVersion"ID, GPSLattitudeRef, GPSLattitude, GPSLongitudeRef, GPSLongitude, GPSAltitudeRef, GPSAltitude, GPSTimeStamp and GPSDateStamp) are all being retained here for both JPG and TIFF exports from Luminar 4.1.0 (5191) when Luminar 4 is used free standing.

    I have no idea what Exif Data is being returned when Luminar 4 is being used as a plugin from PhotoShop.

    When it is used as a plugin from Affinity Photo, the Exif GPS data (along with all the other Exif data) is present in Affinity when the original image is opened, and is still there after the layer is duplicated, sent to Luminar, edited and sent back. It isn't being displayed in the Luiminar 4 Info tab, so did it make the trip across and back, or is it simply left untouched in Affinity - I have no idea.

    My general reference for ExifData is ExifTool.

     

    0
    Comment actions Permalink
  • Avatar
    John Couvaras

    I do have LR installed but loading L4 direct and on export the GPS co-ordinates are definitely not there.

     

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi John,

    According to our techs, there may be issues with GPS data loss indeed, even in 4.1.0, this particular bit is still under investigation. 

     

    @Ian, the new version of Luminar 4.8bf is available in Luminar 4.1.0. There were some compatibility changes in this file, so, theoretically, it could've affected the way it works with Affinity. As you know, the integration of Affinity is neither officially documented nor officially supported, therefore, we cannot guarantee that the plugin will be working smoothly with this particular app. 

     

    As for the rest of the EXIF data cases (related to using Luminar 4 as a standalone or a plugin for the officially integrated host apps), there should be an improvement in Luminar 4.1.0.5191. 

    If you're experiencing any issues with EXIF data loss in 4.1.0.5191, please, get in touch with the support team, as requested.

     

    0
    Comment actions Permalink
  • Avatar
    Ian Murrell

    Kate Williams

    Thanks Kate, have updated the Luminar4.8bf file..

    0
    Comment actions Permalink
  • Avatar
    John Couvaras

    Thanks Kate

    Appreciate your support, but I am just tired of this and now pulling the plug.

    So many basis features are missing or very buggy. 
    I could make a list, but it will not achieve much so I have request a refund and will leave this forum when all done and dusted.

    Thx

    John

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Juan Jackson

    I installed 4.1.0.5191 and it fixed the issue. Thank you.

    0
    Comment actions Permalink

Please sign in to leave a comment.