How to Use Skylum’s Luminar 4 with Capture One

Pinned

Comments

8 comments

  • Avatar
    Zoran Kanti-Paul

    Does not work on Windows Pro 10 1909 either. Capture One 12 allows me to add Luminar 4 as a 'edit in' and 'open with', but it never actually fires up Luminar.

    1
    Comment actions Permalink
  • Avatar
    cristiano giani

    Don't work ,Allan.

    With your proceeding, it opens in Luminar, but when i re-open C1, it isn't no icon beside and we are from beginning.

    Furthermore, when i want to close Luminar, where is the button ''Apply''? And how and where i can save the file ?......

    it's a really annoying problem !!!........

    1
    Comment actions Permalink
  • Avatar
    Thomas Baumhauer

    Thanks for the notes. Unfortunetly it doesn't work for me. I've a fresh installation of Luminar 4 and Capture One 12 (both started and activated). But Capture One doesn't list Lumiar 4 in the plugin dialog. Other programs like FireFox, Affinity or Luminar 3 are listed.

    Any hints?

    0
    Comment actions Permalink
  • Avatar
    Igor Vyvey

    Agree with the above comments. Workflow does not work with either Capture One 12 or Capture One 20 for Fujifilm. Luminar 4 appears as a plugin and is ticked as activated but icon does not show against the plugin preferences dialog box or when invoking it in open with/edit with. My current workaround is to edit the RAF file as a TIFF in Photoshop, invoke the PS Luminar 4 filter, proceed with changes in L4 and apply, then save in PS and it will appear in C1. Cumbersome and tethers me to PS when I am looking at ways to cease my subscription in favour of C1.

    0
    Comment actions Permalink
  • Avatar
    Richard Harrington

    Make sure you have Luminar open and try the File > Edit Singe Image command and see if that works.

     

    If that works on your machine this should work on your machine.  We need to make sure you have a catalog in Luminar with at least one image in it.

     
    0
    Comment actions Permalink
  • Avatar
    Richard Harrington

    Also...  try having Luminar already running when you choose the Open in Command.

    Are you using a catalog of a session in C1?

     

    0
    Comment actions Permalink
  • Avatar
    Thomas Baumhauer

    Short update from my side: After upgrading Capute One 12 to Capture One 20 the registration of Luminar worked.

    0
    Comment actions Permalink
  • Avatar
    Allan Cruickshanks

    I have the same problem with Capture One 12 (Fuji Express version). When I try to send an image to Luminar 4, using Edit with/Luminar 4, a tiff file is created but never makes its way to Luminar 4, whether Luminar 4 is open or closed. There is no icon beside Luminar 4 in the Edit with menu.

    Strangely, I can edit in Lumiar 2018 or Luminar 3 using this method!

    Open with does absolutely nothing with Luminar 4, but does open a photo in Luminar 2018 or Luminar 3.

    In Capture One, Luminar 4 is listed as a plugin.

     

    UPDATE

    I think I may have just found a solution! In the Preferences for Capture One, Pick an app is listed as one of the plugins. So what I did was to use Edit with/Pick an app, allow the tiff file to be created, then go to Luminar 4.exe in the window that opens. I then closed both Capture One and Luminar 4, reopened Capture One, then went to Edit with Luminar 4 (which now appeared with an icon beside it), and would you believe that the tiff opened in Luminar 4!!

    Try that if you have had the same problem and post back to let me know if it works for you.

    0
    Comment actions Permalink

Please sign in to leave a comment.