Nik collection and Luminar 4

Answered

Comments

13 comments

  • Official comment
    Avatar
    Helena Carter

    Member, if you have a Google version, please try reinstalling the Nik Collection and check whether it becomes available to you under Edit > Plugins.

    If the plugins do not appear there, please try the following: 

    1. Download the folder with plugin files here, unzip the folder and save it somewhere where you can easily find it.
    2. In Luminar 3, click Edit > Plugins > Other > Open Plugin > point Luminar to the .plugin file in the folder you just copied in step 1.
    3. Repeat the process with each .plugin file.
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi! Could you specify which Nik Collection plugins are you referring to? Which year?
    Do other plugins work with Luminar?

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi.
    Thanks for asking me which plugins I'm using: I've just realized some work and some don't!
    So, Define, sharpener and viveza work but the others, which are the ones I use (...) don't...
    I think I purchased the collection in 2014, it's the 1.11 version
    Thanks for your help

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    They all show up here but I have DxO Nik not Google or before.

    0
    Comment actions Permalink
  • Avatar
    Howard Lebowitz

    I have the DxO version 2.3.1 for Mac and they all work.

    0
    Comment actions Permalink
  • Avatar
    Rob Williams

    I have just installed DxO version 2.5, and during the install I couldn't select my Luminar 4 as a host application.

    I still continued with the install however luminar doesn't see Nik stuff when I  right click and choose open in. Yet something which i don't own, Aurora HD is there !

     

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Rob,

    Please, reach us via https://skylum.com/support so we could assist you.

    0
    Comment actions Permalink
  • Avatar
    Howard Lebowitz

    Rob, The worked with the previous version but now with the 2.5 update they stopped working ;-(

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Howard, 

    Please contact us at  https://skylum.com/support  as well. In your support request, please also make sure to include the following screenshot: click Luminar 4> About...

     

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    They broke the plugin functionality in the 4.1 update. It will be fixed when the 4.2 update comes out. There is no eta. This was confirmed by Support.

    0
    Comment actions Permalink
  • Avatar
    Howard Lebowitz

    Thanks Colin. Since both Luminar and Nik were updated recently I was not sure which one was broken  

    Funny that Afinity Photo just implemented support for Nik software. 

    0
    Comment actions Permalink
  • Avatar
    James Coffey

    Hello Skylum,

     

    I have Luminar4.2 and Nik Collection 2.5 installed. I'm not sure how to to install NiK for Luminar4?

     

    Thanks you

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

     Hi James! Please reach our support team and we will help you out: https://skylum.com/support

    Best regards,

    0
    Comment actions Permalink

Please sign in to leave a comment.