How to Use Skylum’s Luminar 4 with Capture One

Pinned Featured Answered

Comments

26 comments

  • Official comment
    Avatar
    Helena Carter

    Hi,

    Just in case, please, also refer to the updated User Manual draft, there is a detailed guide there which might help you:

    https://manual.skylum.com/4/en/topic/how-to-user-skylum-s-luminar-4-with-capture-one

    Comment actions Permalink
  • Avatar
    Michael Sonshine

    Thank you for the post.

    I believe the steps to modify the Preference settings provides an updated default set for both Open With and Edit With, making it easier to do both, but I wanted to point out that a user could use both Open With and Edit With without setting those Preference settings by then going to the "Other" entry and scrolling down.

    I have been doing that for quite some time to access both Flex and Luminar, and the linkage works properly, but setting the Preferences does make the process a bit faster and easier, so thanks for mentioning it.

     

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    This does not work. I have Capture One 12 and cannot get this to work in the way you suggested. I can see Luminar 4 as an option for Open With, but Luminar 4 never opens.

    0
    Comment actions Permalink
  • Avatar
    Michael Sonshine

    I have not had any problem accessing Luminar 4 from CaptueOne, either using the Open With or the Edit With functionality. I do have to remember what folder to save the image back to because L4 often does not know, but if I specify the correct folder the edited image shows up back in C1 just as it should.

    I work on a Mac so I can not speak for those who work on Windows machines.

     

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    OK so I am on windows 10 Pro 1909, and this does not work.

    0
    Comment actions Permalink
  • Avatar
    Michael Sonshine

    My wife uses Windows 10 and I will try this on her machine. I guess I will have to download and install both a C1 trial and a L4 trial (if the machine will let me, given I have a license associated with my email), but I will try and see if I have the same issues.

     

    1
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    I edited the Capture One exe to launch as Administrator, did the same for Luminar 4.

    During the edit with process, Capture One actually creates the TIFF, I see the processing windows etc. and then the TIFF file in my library in Capture One. but then nothing. It just sits there. I have also tried opening Luminar 4 FIRST, then trying it. Nope that does not work either.

     

     

    0
    Comment actions Permalink
  • Avatar
    Michael Sonshine

    Out of curiosity is C1 able to launch any other software with the Open With and Edit With links? I use that all the time with Photoshop and some of the Topaz software as well as Dxo's ViewPoint 3 and they all work well.

    Do you have any luck with Open With and Edit With using other software? Is it only Luminar that is giving you this issue? Or is it general?

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    Yes, Affinity all good..

    0
    Comment actions Permalink
  • Avatar
    Michael Sonshine

    Well, I guess my results are a bit of a mixed bag.

    First, I installed the trial version of both C1 v12 and L4 on my wife's Windows 10 machine (which is exceedingly slow since it is a browsing and reading machine, not a photo editing machine, and hence has a slow processor and a physical hard drive). 

    I then set up C1 so that it would ask for other editors (Preferences -> Plugins), opened a raw image and sent it to L4 using Edit With It properly created the tiff file and, after what seemed like an interminable wait, started L4. But since L4 is in trial mode on that machine it came up with the splash screen rather than opening with the actual image, and that was true for each subsequent test. Each one actually started L4 but the trial splash screen prevented L4 from opening the image.

    One thing to note is that L4 started UNDER C1 and I did not even know it had started until I minimized C1 looking for L4. Only then could I see L4. Could that be an issue for you as well?

     

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    Well if Luminar was starting on my pc I would see the icon on the taskbar..That is not the case.

    What version of windows is that machine? Mine is the latest version of Windows Pro 10 64bit which is 1909.

    0
    Comment actions Permalink
  • Avatar
    Michael Sonshine

    Well, I guess that is my mistake.

    I checked my wife's machine and it turns out that she has never upgraded from Windows 8, so she does not have 10 on her system. Perhaps that is why L4 is working on her machine but not on yours.

     

    0
    Comment actions Permalink
  • Avatar
    Igor Vyvey

    I confirm that this does not work on Windows 10 using either C1 12 or C1 20 (full versions) with L4 (full version). Processing happens in C1 but never opens L4. No issues in C1 opening with or editing with any other software except L4. The only workaround I have found so far is to edit TIFF with Photoshop, select L4 filter (the plugin adds that functionality to PS) then apply, save in PS and resulting edited TIFF shows in C1. Cumbersome but there you go. I guess yet another parity with Mac issue that out to be resolved, or better yet have a dedicated C1 plugin developed for.

    NB I note that even if L4 shows as activated in C1 preferences the little L4 icon does not show in either preferences or when selecting L4 in open with/edit with, which indicates a lack of sync.

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    Yes I can confirm about the lack of the L4 icon..I do not see that either.

    0
    Comment actions Permalink
  • Avatar
    Richard Harrington

    Try the suggested workflow using a SESSION in Capture One instead of a catalog and let me know.  Also, make sure that you've previously launched Luminar and have at least one photo in your catalog.

    0
    Comment actions Permalink
  • Avatar
    Igor Vyvey

    Thanks for the suggestion @richard however no joy as attempts were made in new C1 20 session. L4 was previously initiated on its own and it makes no difference whether L4 is open or closed at time of either open with or edit with in C1. There are also several photos in my L4 Catalog.

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    Same here. Session/catalog, no difference. This simply does not work.

    0
    Comment actions Permalink
  • Avatar
    Richard Harrington

    Make sure you have Luminar open and try the File > Edit Singe Image command and see if that works.

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    Umm..what are you talking about?? You have missed the entire point of this thread. No one is talking about going from Luminar TO C1.

    It is the other way around that we need. LOL

    So to recap.

    C1 12 or 2020 TO L4 does not work on Windows 10.

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    The issue might be this? For some reason Luminar 4's icon does not show up in the edit list..Path is correct obviously.

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    SOLVED!

    Instead of adding Luminar 4 through the Plugin preferences, I instead chose the "Pick an app" menu item.

    Searched for the Luminar 4 exe, and added it there.

    Lo and behold, Luminar 4 fired up. You still have to know the path back to the tif that Capture One creates. But this is a breakthrough for me.

    And then now the Luminar 4 ICON is showing in Capture one, in the two menus for Open with, or Edit with, and they BOTH work and launch Luminar 4 too.

    I hope this helps some of you.





    1
    Comment actions Permalink
  • Avatar
    Igor Vyvey

    Thanks Zoran Kanti-Paul that's helpful as it does away with having to have PS to use its plugin. It does work but doesn't let you apply L4 changes and requires pointing L4 in the right direction for the return trip to C1. Whilst I still have PS I find it easier to use its plugin to L4 as it automatically saves the resulting edited tif in C1. cheers!

     

    0
    Comment actions Permalink
  • Avatar
    Zoran Kanti-Paul

    Thanks Igor Vyvey. The apply part you mentioned, do you mean there is no way to send it back to C1? That is true. I am doing what you are doing, sending out from C1 to L4, then editing, and exporting that tif back to the same folder that C1 created the tif in. It is not as nice at was with photoshop. But I dumped all my Adobe products. So it is C1, L4 and Affinity for me now.

    0
    Comment actions Permalink
  • Avatar
    Dan Parsons

    Note that if you continue to use Luminar and Capture One this way (having Luminar save on top of the file you originally sent to Luminar in the first place), it will damage your photo if you tweak and save a second time. See details here. Still looking for a way to have safe & secure round trip access between Capture One and Luminar, but given I've been reporting this issue for over a year now without any fixes made to it, I think we're stuck.

    0
    Comment actions Permalink
  • Avatar
    Michael Sonshine

    I have tried this with Dxo's PhotoLab2 and did not see any issue with exporting to L4, editing, exporting back to the same file, editing more in L4 and re-exporting back to the same file. The second exported image was identical to the first except for the additional change I made.

    I understand that you mentioned CaptureOne but my post was meant to indicate that whatever this issue is may not be an L4 issue. If it does not happen with PhotoLab2 then perhaps it is a CaptureOne issue.

     

    0
    Comment actions Permalink
  • Avatar
    Dan Parsons

    My reply was directed at the post directly before mine, the one by Zoran.

    0
    Comment actions Permalink

Please sign in to leave a comment.