LUminar 4 Plugin for Photo does not Work (Blank Screen no Photo shows)

Answered

Comments

7 comments

  • Avatar
    Elena Blum

    Hi Riaan,

    First of all Open Luminar 4 and click File - Install plugins and install Luminar 4 for anything you have on the list.

    Than try installing the plugin manually.

    1. Make sure Photoshop is closed.
    2. Download the plugin from here.
    3. Navigate to the Photoshop Plugins folder. The default path is: C:\Program Files\Common Files\Adobe\Plug-Ins\CC
      For Photoshop CS5 and CS6 the path will look like this: C:\Program Files\Adobe\Adobe Photoshop version name\Plug-Ins\Filters
    4. Copy the .8bf file into the folder you've opened in Step 3

    If it doesn't work please contact our support team and we will do our best to assist you https://skylum.com/support

    0
    Comment actions Permalink
  • Avatar
    Nissan Lev-Ran

    Sorry but no! this "new" Plugin does not do any change... 
    Same blank dark window... 

    0
    Comment actions Permalink
  • Avatar
    Riaan Roux

    It has been almost 2 weeks and this issue still is not resolved.  All files and MSInfo sent to Support and...just nothing.  I cannot use Luminar 4 as the Plugin does not work.  Please, can the technical team make this a matter of urgency?

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Riaan, 

    I've sent you an email! Please check your inbox!

    0
    Comment actions Permalink
  • Avatar
    Linda Warden

    It does not work in Photoshop for me either and tech support is not answering my emails.  I want my money back!

     

    0
    Comment actions Permalink
  • Avatar
    Riaan Roux

    I am at wits end?  I have tried every suggestion from completely re-installing my Adobe CC (which took me a LONG time to complete and got harassed by Adobe for re-installing as they want to know WHY for licensing).  I rolled back display drivers to older versions and back up to the latest versions.  I uninstalled Luminar and all plugins an installed all clean and fresh again and still, I cannot get Luminar Plugin for Photoshop to display an image.  It remains blank.  I am sure others have had this same issue and reported it.  Is there any way to solve this problem?

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Riaan,

    Please confirm that you have reinstalled all three programs, according to the instructions provided per email.

    If so and the issue persists, please try reinstalling the plugins:

    Click on the Luminar / Aurora icon> Run as administrator

    Click File> Install Plugins

    Click uninstall next to Photoshop.

    Click on Install.

    Also please reach us more information about Photoshop version at https://skylum.com/support

    0
    Comment actions Permalink

Post is closed for comments.