L4 Completely Unusable. Most broken software I have ever used.

Answered

Comments

12 comments

  • Avatar
    Saurabh Shetty

    Other than the usual slowdowns and the crashes, I had the same problems with the erase and the clone tool. I have seen the pan issue occurring atleast once every day. And that undo button is long overdue.
    Skylum team, if you are listening and I know you are, please fix your s/w before we lose our patience and move on to something else.

    2
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Colin and Saurabh, 

    We're aware of some of the performance issues in the Windows version of Luminar 4. Our team is doing their best to sort them out. We're planning to roll out a rather big update that will contain performance improvements. Stay tuned. 

    As far as the undo button is concerned - there are some tech limitations with the implementation of this button on Windows due to the lack of local history. However, if our team finds a solution, we'll be sure to implement it. 

     

     

     

    -2
    Comment actions Permalink
  • Avatar
    LeoN E

    Hi Kate, the performance fixes are good, but what about crash

    0
    Comment actions Permalink
  • Avatar
    Jaron Horst

    I have to agree - the performance and crash issues with L4 are rather extensive when running on Windows.  Even when only using a few special features (AI Sky, Sunlight, and Background Replace) after doing my RAW editing in another application, I'm running into a lot of issues with slow UI and crashing.

    1
    Comment actions Permalink
  • Avatar
    John Couvaras

    Agree with the sentiments here. Edit undoes are elementary and having to sacrifice a whole layer is quite ridiculous. 
    Makes me think the Windows version is just the poor child of the Mac version.

    I have requested details for a refund and have not heard back...no surprise here.
    "We're planning to roll out a rather big update that will contain performance improvements. Stay tuned."  - that will be the decider.
    Fail to see how they can take your loot, and then go to market with what is really a beta version.
    Lets see where it goes

    1
    Comment actions Permalink
  • Avatar
    John Couvaras

    "As far as the undo button is concerned - there are some tech limitations with the implementation of this button on Windows due to the lack of local history. However, if our team finds a solution, we'll be sure to implement it. "

     

    This is quite fundamental actually.

    Why can others do it?

    2
    Comment actions Permalink
  • Avatar
    Colin Merritt

    Kate Williams  ,

    It's been 7 days. I've heard nothing about any updates. No solutions, no suggestions, no help whatsoever. How long do I have to wait? Should I just uninstall Luminar, and go back to Adobe, and maybe come back in a few months to see if anything has improved?

    1
    Comment actions Permalink
  • Avatar
    Patrick Garcia

    For me this is still an issue. When ereasing things there is no option to do it easy step by step. If I dont like what happened I have to delete the layer and redo everything. And the performance is still terrible. Marking things to erease has a about 2 seconds delay and somethimes it overdrags because i move and the application didnt realize yet that I released the mouse button. What do you recommend? There is no response to that issue even after half a year later.

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hi Patrick. We are going to issue a new update soon that will have significant performance improvements! Please stay tuned for updates!

    0
    Comment actions Permalink
  • Avatar
    Jaron Horst

    Austin Miller Is this the big update that was promised 5 months ago?  I'm still waiting for a useful/reliable Windows build!  Wish I would have asked for my money back when I could as L4 is almost useless for me just now!

    0
    Comment actions Permalink
  • Avatar
    Member

    I'm having he very same thing as Colin was saying. I use the clone on almost all of my photos and it gets all blocky and starts showing random chunks of the photo in different places. Also very bad lag. I just found out it's not just me. There's already been one update since I've purchased this so I hope the next one really fixes this problem because it's very frustrating.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi,

    As to the Clone and Stamp issue, please, reach us via https://skylum.com/support and we'll gladly assist you.

    0
    Comment actions Permalink

Please sign in to leave a comment.