Comments

14 comments

  • Avatar
    Wudds Mcgurk

    I also have this issue, have opened a support ticket about it.

     

    I can open photos but then nothing happens and everything is greyed out or empty boxes where the filters should be.

    1
    Comment actions Permalink
  • Avatar
    Findley Watt

    This is a joke, nothing but problems. check it out now

    3
    Comment actions Permalink
  • Avatar
    Findley Watt

    temporary fix for this - if anyone has the same problem is to edit the image from lightroom or photoshop

    1
    Comment actions Permalink
  • Avatar
    Wudds Mcgurk

    did you have any luck with the standalone yet? I still can't get this working and still not had a response from support

    0
    Comment actions Permalink
  • Avatar
    Findley Watt

    Still no luck with standalone version. I just import the raw image into LR and then go edit in>Luminar 4 and boom. its pretty amazing what the program can do

    1
    Comment actions Permalink
  • Avatar
    Ive Grbić

    Same thing here. Luminar won't load RAW files for editing. I have to restart the app a few times in order to load a new file for editing. Really frustrating.

    1
    Comment actions Permalink
  • Avatar
    Bruce Campbell

    Same thing.  Using as standalone, but can't edit any file, raw or jpeg. Everything greyed out. Edit option in "View - Sidebar" menu is also greyed out.  Also, previews of Looks in Looks panel are not showing and cannot be applied. However, the different categories of Looks can be selected.

    I've tried uninstalling and re-installing.

    Everything seemed to work OK until I got notice to install update. (I got the early version released on 11/11/19. The update was released on 18th November).

    I've used Luminar standalone version since 2018 release, but I can't keep making excuses for it. Its buggy and slow.

    At least version 3 still works.

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Bruce Campbell

    Just opened up L4 in hope of a bug fix update. None available. But lo and behold it works the way it should. Edits are back, Looks are back.

    Now I'm totally confused. I wonder when they will go awol again.

     

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi. Please contact us via https://skylum.com/support and we will figure something out.

    0
    Comment actions Permalink
  • Avatar
    Bruce Campbell

    Kirk, haven't contacted support because the edit menu has behaved itself since my last post and therefore there is no need to contact you.

    I have no idea what the problem was.

    As an aside, L4 seems to be much faster than L3 - a welcome improvement. Still learning where all the tools are now located.

    0
    Comment actions Permalink
  • Avatar
    Joel Hammond

    I'm still having the same problem as Bruce. I've contacted support but have only received a message telling me how busy they are and to be patient. I had the same issue in Luminar 3 and was never able to resolve it. It would be nice to see what your software can do. It worked for 2-3 images, then stopped working. I've tried to uninstall and reinstall without success. Any help is appreciated!

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi Joel.

    Could you specify your email address?

    0
    Comment actions Permalink
  • Avatar
    R Ka

    Hi Kirk, 

    Been dogged with issues on Luminar 4.2 First it is the RAM and CPU usage. And now, while I have it running, the editing makes no difference to the RAW image. I can play with the sliders, I see image processing momentarily with the wait symbol going round but no difference to the image. Reinstall did not work. Only the Luminar looks at the bottom of the screen are working but the actual manual edits are not working

    Update:

    Just figured this out. Has something to do with the "Luminar looks". Apparantly, the editing does not work until I choose one of the looks. Basically, am forced to choose a look and then it would work on that look. So then I noted a cross icon "X" button on top of the looks cable, still yet to figure out what that does. Apparently toggling that adds a "X" on that image in the left side vertical library and kind of darkens the image there but don't know what that means or actually does. 

    So the only way, I can make this work is basically, to choose some "Luminar Look" in that Looks ribbon below, slide the slider all the way to the left so the looks do not appear and then start playing with the edits. Can hit the Looks button on the top left once that is done to not show the "Luminar Looks" and have the image occupy that space to make it bigger. 

    By all means, those Luminar Looks are useful and nice but should not be forced to select them to then edit the image. Basically first applying them, then having them show and then applying the actual edits. 

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    R Ka Hi! We have replied to another post of yours. 
    It is good to hear that the issue was resolved. Nevertheless, the Edit panel should work just fine even without the Looks applied. Could you send us screenshots of the issue to support@skylum.com ?

    0
    Comment actions Permalink

Please sign in to leave a comment.