Luminar 4 Install Internet Connection?

Comments

22 comments

  • Avatar
    Ivan Møllebjerg

    Same here

     

    0
    Comment actions Permalink
  • Avatar
    Daniel Chetroni

    the same problem here :(

    0
    Comment actions Permalink
  • Avatar
    Ivan Møllebjerg

    I solved it - my mesh network have a antivirus filter, which I deactivated during install - then it worked!! - hope it will Work for you too - have fun

    0
    Comment actions Permalink
  • Avatar
    Daniel Chetroni

    Not working :(

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi,

    Your anti-virus software and firewall may be the issue. Please try the following:

    In case it doesn't work, please try to use an alternate installer:

    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline.msi

    Or contact our support team if you have some issues and we will do our best to assist you https://skylum.com/support

    2
    Comment actions Permalink
  • Avatar
    Вадим Михайлов

    I used the link above to install Luminar 4 to another disk.

    The effect is the same.

    I got a box with statement that internet connection is required.

    The same issue was at Luminar 3 launch. Guess not much changed since.

    0
    Comment actions Permalink
  • Avatar
    Вадим Михайлов

    This may not be obvious, but the installation was succesfully completed in both cases.

    But when the program launches, I cannot enter authentication code because of the internet connection box.

    0
    Comment actions Permalink
  • Avatar
    Member

    It was my mesh network firewall that caused the issue also!

    Thanks for the help.

    0
    Comment actions Permalink
  • Avatar
    Daniel Chetroni

    I solve it with a new rule in windows defender.

    Thanks.

    0
    Comment actions Permalink
  • Avatar
    Stephen Lunn

    I have the same issue with Luminar 4, and it was the same for 3 and Aurora. My question would be is that I don't have this issue with any other piece of software that uses an installer so what certificates are you missing that is causing flags for so many users Firewalls!

    0
    Comment actions Permalink
  • Avatar
    Rikard Jörnesten

    I tried everything. Disabled anti-virus & firewall. Cleaned registry with CC cleaner. Un-installed and tried the offline installer. Nothing works. Don't really know what else to do. 

    0
    Comment actions Permalink
  • Avatar
    Timo Sondermeyer

    @Daniel,

    How did you do that?

    Can you explain? I think it'll be a great help for other users

    0
    Comment actions Permalink
  • Avatar
    Stefán Baxter

    Same here :(

    0
    Comment actions Permalink
  • Avatar
    philip woolway

    The alternative off line installer as posted by Elena Blum worked for me. Previously I had gone through all the firewall, virus stuff and ensured it was running as administrator to no avail (my mac book on the same desk as my PC and on the same network worked fine first time). 

    0
    Comment actions Permalink
  • Avatar
    Вадим Михайлов

    I tried desktop VPN finally and it worked.

    Thanks to Roy Blackwell who made a post here https://community.skylum.com/hc/en-us/community/posts/360006649360-HELP-I-CAN-NOT-START-THE-TEST-VERSION-TO-ENTER-THE-ACTIVATION-CODE

    0
    Comment actions Permalink
  • Avatar
    Rikard Jörnesten

    Tired of this problem and no reply from Skylum. Guess I'll get another software.

    0
    Comment actions Permalink
  • Avatar
    Giovanni Farina

    I had the same problem where I couldn't install because of a connection error, then I resolved it installing with the offline version, but out of curiosity today I tried to rename the installer Luminar 4 instead of Luminar4Setup, and it worked.

    0
    Comment actions Permalink
  • Avatar
    Timo Sondermeyer

    I'm sure they're working on the problem, but it would be nice if the affected users would be informed by Skylum

    All users have paid money to work with Luminar and are now faced with the problem of not being able to activate the software because apparently no internet connection has been established.

    Unfortunately I haven't received any information from support yet.
    I have already sent the error message and the host file.

    What are the next steps?

    BR
    Timo

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    @Rikard, have you tried using one of these alternative installers? 

    Mac Full: https://downloads.skylum.com/luminar4/mac/Luminar4.dmg 

    Win Msi: https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline.msi

    I'm struggling to locate your support request in CRM that would contain your hosts file. Was the email with which you've signed up different from the one you've used to contact support? If so, please, specify it. 

     

    @Timo, we've just processed your request.

     

    @Everyone, please ensure the following: 

     

     

    0
    Comment actions Permalink
  • Avatar
    Timo Sondermeyer

    Thanks Kate

    Your hint with the host file worked at my Laptop.

    0
    Comment actions Permalink
  • Avatar
    Pacific

    You go

    C:\Windows\System32\drivers\etc

    Open file hosts by notepad or you can copy that file to other folder to edit it.

    Clear all and save it.

    Try open Luminar 4 again.

    0
    Comment actions Permalink
  • Avatar
    Scott Battaion

    Solution by Pacific worked on my Acer Spin 111 laptop running Windows 10. Below is a more detailed description of the process.:

    • Used path C:\Windows\System32\drivers\etc
    • Made a backup of the original "hosts" file that was saved onto desktop
    • Opened it in Notepad
    • Selected all text in document and deleted it
    • Saved edited file to desktop
    • Removed .txt file extension so it appears as just a generic "file" like the others in the "etc" folder
    • Deleted the existing original "hosts" file from "etc" folder
    • Copied the edited "hosts" file from desktop to "etc" folder
    • Restarted Luminar Flex

    It now connects to the Internet. It shows the number of days left on trial and registration information fields that can be filled in--the software can now be registered.

    Awful lot of trouble to simply install a piece of software. C'mon, Skylum, this is an ongoing problem going all the way back to Luminar 2018. Please get your act together. As a paying customer and end user I shouldn't be tasked with creating workarounds and beta testing/debugging something as basic as the software installation process.

    1
    Comment actions Permalink

Please sign in to leave a comment.