Luminar Flex is not working as a smart object plugin in Adobe Photoshop cc 2020

Comments

22 comments

  • Avatar
    Angela Andrieux

    Hi Ronnie,

    Manually installing the plugin should help:

    1. Make sure Photoshop is closed.
    2. In Finder please click Go > Go to Folder and paste the following path: /Library/Application Support/MacPhun Software/LuminarFlex/Plug-Ins/. There will be a bunch of files in there, the one you're interested in is LuminarFlexPlugin.plugin.
    3. Open a new Finder tab or window and navigate to Applications/your_version_of_Phothoshop/Plug-ins/Filters/
    4. Copy LuminarFlexPlugin.plugin into the folder that you opened in Step 3.
    5. Launch Photoshop and see if you have Luminar Flex under Filter > Skylum Software.

    If you encounter any further issues, please contact us at www.skylum.com/support and we'll investigate further.

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Are these directions for PC Windows 10 users? 

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Ronnier,

    yes, of course!

    Please try installing the plugin manually on Windows.

    1. Make sure Photoshop is closed.
    2. Download the plugin from here.
    3. Navigate to the Photoshop Plugins folder. The default path is: C:\Program Files\Adobe\Adobe Photoshop version name\Required\Plug-Ins\Filters
      For Photoshop CS5 and CS6 the path will look like this: C:\Program Files\Adobe\Adobe Photoshop version name\Plug-Ins\Filters
    4. Copy the .8bf file into the folder you've opened in Step 3
    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Problem solved!!  Thank you so much.

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Well, I spoke too soon.  It started again.  Support, advised me that Luminar Flex is not supported by Adobe Photoshop CC 2020 At this time. ☹️

    0
    Comment actions Permalink
  • Avatar
    Rob Yoho

    Wow. All my non-destructive workflow done with previous version of Photoshop and Luminar Flex is now totally useless. I just confirmed this same non-working behavior described above (even after manual plug-in install--BTW, all that does is add plug-in capability of Flex in Photoshop but doesn't fix the Smart Object incompatibility) . Not surprising, unfortunately I was an early adaptor of Luminar 3 and quickly realized it was totally useless for me since there was no plug-in or Smart Object compatibility with Photoshop.  Then I got Flex which was marketed as the fix for Luminar 3 not working with Photoshop.  So I used Flex with Photoshop via Smart Objects and that worked for a while.  Until new photoshop version arrived. So now all those Photoshop files that used Flex as a Smart Object are totally useless.  Then you market Luminar 4 saying it's a replacement for both Luminar 3 and Flex.  So I buy it. I don't have it installed yet but read another comment on this forum that the Photoshop Smart Objects don't work with Luminar 4. What I'm left with is ruined Photoshop files that used Flex as a Smart Object and a new Luminar 4 that doesn't work with Smart Objects. So, Skylum, any idea when or if ever this will be fixed? 

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Oh no!  Does Luminar 4 has the same problem?

    0
    Comment actions Permalink
  • Avatar
    Rob Yoho

    According to this post in this forum, Luminar 4 Smart Object is not working.

    https://community.skylum.com/hc/en-us/community/posts/360006547399-Smart-Filter-Problem

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Oh sh---, I am done. I will have to go back to Adobe Photoshop CC 2019.  

    0
    Comment actions Permalink
  • Avatar
    Rob Yoho

    Interestingly, the Flex Plug-in works fine with PS CC 2020 for new edits.  In other words, if you edit a new photo in PS CC 2020, create a Smart Object layer, send the layer to Flex, edit in Flex and send back to PS CC 2020, everything works fine. If you then want to re-edit the Smart Object, double click on it and it returns to Flex just fine.  Make new edits in Flex and send back to PS CC 2020, that works, too.  So the critical piece that isn't working is when you take a file that was originally edited in the previous Photoshop CC using Flex as a Smart Object.  In PS CC 2020, when you try to send the Smart Object back to Flex, it doesn't work.  Go figure.  So it half works.  Although I suspect your idea of reinstalling Photoshop CC 2019 will work, you will only need it for files created in 2019 that have Flex Smart Objects.  By extension, you need to keep every version of PS and every version of plug-ins and then use those versions on the files created with those programs and plug-ins.  Welcome to the future of software incompetence.  This is a DAM (Dig Asset Manager) mess and huge waste of time.

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Wow, that explains why I thought my problem was solved when I worked on a new project in CC 2010.  Later, I had to pull up a file I worked in CC 2019, and the problem reappeared.  This sucks. I will just work in CC 2019, until this mess is straighten out.  

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Thanks Rob!

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    I was lied to, the Luminar 4 does not work as a smart object work flow in PS cc 2020. Luminar Flex and Luminar 4, work flawlessly in  PS cc 2019. 

    0
    Comment actions Permalink
  • Avatar
    Rob Yoho

    I figured that would be the case. You would think that something so straightforward would be known before release. I don’t think Skylum knows the difference between a plug-in and Smart Object compatibility. Or full compatibility that includes being able to re-edit the Smart Object. This is a major fail. BTW, I received email reply to my tech email about Flex no longer working in PS 2020 and their answer was that Flex is not compatible with PS 2020. Have a nice day! At the end of the day, we no longer have a Luminar product that works with Photoshop as a Smart Object and all previous edits using Photoshop and Flex as a Smart Object are orphaned and useless.

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    I could not agree with you more!

    0
    Comment actions Permalink
  • Avatar
    Love You Photography

    I have also problems with the plug in as smartobject with a new file! f the plugin has to be recalculated (for example, by exemption or by copying to another level) Luminar invites with a blank surface and I can not do anything anymore.

     

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi everyone, 

    I've reported the complaints to our tech team and they will take a closer look at the reported issues. 

    As soon as there's an update from our QA team, we'll let you know. 

     

    N.B.! We have a separate thread regarding the issues with using Luminar 4 as smart object. 

    If your comment pertains to Luminar 4, I invite you to this thread: https://community.skylum.com/hc/en-us/community/posts/360006547399-Smart-Filter-Problem 

     

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    Thank you

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Dear all, 

    I've just got an update from our QA team. 

    Unfortunately, since we were focused on Luminar 4 release, Flex was not tested for compatibility of new Adobe products, therefore, there may be issues like that. 

    As you guys have mentioned, the plugin should work fine for the new edits that were made in Photoshop 2020. 

    If we have any news regarding the next Flex update, we'll notify our community. 

     

    As far as Luminar 4 concerned, I've also posted an update here: https://community.skylum.com/hc/en-us/community/posts/360006547399-Smart-Filter-Problem 

     

    0
    Comment actions Permalink
  • Avatar
    Johannes Wienke

    8 months ago this was reported and I am still struggling with this issue. Any chance this will ever get fixed?

    0
    Comment actions Permalink
  • Avatar
    Ronnie Booze

    I don’t think it will ever be fixed in Luminar Flex. Your only option is get the Luminar 4.2 or 4.3. 

    0
    Comment actions Permalink

Please sign in to leave a comment.