Luminar 4 Won't open




  • Official comment
    Kate Williams

    Hi Everyone, 

    Please try reinstalling Luminar 4 / Luminar 3 in the following way: 

    1. Go to “Apps and Features” by right click on the Start button;
    2. Find Luminar there and click [Uninstall] (you can also uninstall from the Control Panel);
    3. Type %appdata% in Search (folder Roaming should open);
    4. Find the folder “Luminar 4” and delete it (it deletes your license for Luminar 4 too. Please, note that your Custom and downloaded Looks will be removed, so make sure to save them somewhere);
    5. Go to Pictures -> Luminar 4 Catalog and rename it (if you have your Catalog anywhere else, find it and rename it).
    6. Install the app once again and launch it: 
    7. Choose to Create a New Catalog and add a small folder with images or a single image for editing. 

    The same instruction will be applicable for Luminar 3 too. All you need to do is remove "Luminar 3" folder + rename Luminar 3 catalog. 

    Luminar 3 can be installed via this link: 

    If the issue persists after these steps, please, contact our team at and attach the following info to the email:

    a) your hardware specs: 

    • Press the Windows logo key + R.
    • Type msinfo32 in the dialog box that opens and hit Enter on your keyboard.
    • In the window that opens, make sure you have System Summary highlighted on the left.
    • Click File > Export.
    • Type the name of the file and save it somewhere where you can easily find it
      and attach this text file to your email.

    b) the crash logs: 

    1. Reproduce the issue. 
    2. Press the Windows logo key + R.
    3. Type eventvwr in the dialog box that opens and hit Enter on your keyboard.
    4. In the window that opens click the triangle next to Windows Logs on the left. A directory tree should open.
    5. Click Application in the directory tree. 
    6. In the main part of the window find the two topmost entries marked with Error named Application Error and .NET Runtime.
    7. Hold CTRL and click your left mouse button on each entry to select them both.
    8. Right-click on any of the two selected entries and click Save Selected Events.
    9. Name the file, save it, and attach it to your email. 

    Having this data, we'll be able to investigate the issue further. 



    Comment actions Permalink
  • Avatar
    Shawn Pearce

    I actually had the same problem and after a fresh restart of my pc it worked

    Comment actions Permalink
  • Avatar
    Richard Burns

    10-4 on the restart.  That fixed the opening issue.

    R. Burns


    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Richard - Glad to hear all is well. Let us know if we can help with anything else!

    Comment actions Permalink
  • Avatar
    Ann Varley

    I was successful after a fresh restart of my PC, but once closed Luminar 4 will not reopen for next image I wish to adjust. Does this mean I'm going to have to restart my PC EVERY TIME I want to use this software?

    Comment actions Permalink
  • Avatar
    Ninamay Hoffheiser

    I'm having the same issue. I just installed Luminar 4 (leaving 3 installed), converted my Luminar 3 catalog, and then the program opened. I was able to activate Luminar 4, but once I closed the program, I can't run it anymore.

    I've uninstalled Luminar 3 and rebooted, and no luck. What happens now when I try to open Luminar 4 is that the splash screen displays for a few seconds and then disappears. Luminar 4 doesn't open, though.

    Any ideas?

    Comment actions Permalink
  • Avatar
    Roger Burt

    I'm having the same problem. The front/welcome screen opens, little spinning blue circle for a few seconds then drops out. I have tried rebooting twice but no joy. Quite frustrating 

    Comment actions Permalink
  • Avatar
    Steve Busic

    I'm experiencing this same issue (splash screen then nothing) on both Luminar 4 and version 3 which I left installed.  Luminar Flex opens through LR but then won't recognize the TIF or JPG file it created for the editing process.  Restarting isn't resolving the issue on any of them in my case. 

    Comment actions Permalink

Post is closed for comments.