Luminar 3.1.4. update with Catalina OS support

Comments

32 comments

  • Official comment
    Avatar
    Alina Skylum

    Hi Everyone!

    We are sorry for the inconvenience.

    We have already fixed the issue, please update the app via Luminar 3 > Check for updates. 

    In case you still face this issue updating Luminar 3 please try reinstalling Luminar in the following way:

    We recommend doing a full uninstall with AppCleaner. AppCleaner is a free app that automatically removes not only applications but also the related files, making 'clean' uninstall easy.

    • Download AppCleaner from here (click this text to open link).
    • Install AppCleaner and start it.
    • Drag Luminar from your Applications folder into the AppCleaner window. When removing Luminar, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.
    • Once you've uninstalled Luminar, restart your Mac and download a fresh version of Luminar from the link below: https://downloads.skylum.com/luminar/mac/Luminar3.dmg
    • In case you receive the error message “You do not have sufficient permission to the specified folder” please simply click [OK] and finish the installation.

     

     

    Comment actions Permalink
  • Avatar
    Eduardo Mueses

    See Here

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Eduardo,

    I have already replied to that post.

    Please, try using an alternate installer: https://downloads.skylum.com/luminar/mac/Luminar3.dmg

    If this doesn't help, please, contact us via https://skylum.com/support

    0
    Comment actions Permalink
  • Avatar
    Dennis Atkinson

    I tried the alternative installer, it downloaded and installed successfully, however the result is the same as before. I have folders showing 0 files that have files in them that I am trying to work on. It also shows some folders that don't seem to exist on the hard drive. Will this be fixed?

     

    4
    Comment actions Permalink
  • Avatar
    Bowman Gray

    I'm not touching these "fixes" until I see confirmation that they are working.

    1
    Comment actions Permalink
  • Avatar
    Danny Bezak

    The alternate link above must be an old version, as all is the same and when within the app, it still says it needs updated and also still the problem with the 0 files in folders! The update won't install either.

    2
    Comment actions Permalink
  • Avatar
    Mark Johnson

    Tried using the link above, no change at all, Don't use it. Just a ploy to pass it onto someone else I suspect.

    1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    Neue Version installiert, ich kann keine Verbesserung feststellen:

    Fotos in einen Ordner importiert   - Ordner zeigt 0 Fotos obwohl im Finder zu sehen. Im Ordner „zuletzt importiert“ wurde ein Unterordner mit heutigem Datum angelegt - dort sieht man das importierte Foto.

    Magic Mouse hüpft weiterhin zwischen den Fotos hin und her - wird wahrscheinlich wieder für nächstes Update versprochen.

    Plugin für Fotos funktioniert zwar, das Datum der letzten Bearbeitung bleibt im Finder allerdings unverändert - Finde ich auch nicht gut.

     

    1
    Comment actions Permalink
  • Avatar
    Bowman Gray

    OK, so the backup link to do a fresh install of the update now works as a plugin with Apple Photos.. - Now we need to have them fix the HDR suite of programs.. 

    Luminar 3 download that worked for me - https://downloads.skylum.com/luminar/mac/Luminar3.dmg

    0
    Comment actions Permalink
  • Avatar
    Heino Deutschmann

    The alternate link is the same version that I have installed 3.13 and it's not possible to Install the Update 3.14, the following Window opened every time

    0
    Comment actions Permalink
  • Avatar
    Bahram Monshat

    The new links are not working for me. The app crashes immediately after it opens.

    1
    Comment actions Permalink
  • Avatar
    Kim Austin

    @ Bahram Monshat

    Same result here.

    Tried 30 minutes ago and got this (running on iMac)

    0
    Comment actions Permalink
  • Avatar
    Larry Bootland

    Software does not install online or from any of the links in this thread.

    1
    Comment actions Permalink
  • Avatar
    Eric Loit

    I've updated to the latest version of Catalina (supplemental update included) as well as this latest download.   It installed fine but has not address the issues that I have.

    On importing images they are not being reflected in the folder though using the finder they are properly there,   As well under the "All Photos" shortcut for the date the images are being duplicated each time I restart Luminar.   This erroneous behaviour was what I reported previous to the latest update and I can confirm the same issues still exist in this latest update.   From my perspective there is no change in operation of the standalone product.

    1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    Hi Eric,

    I have now reported these errors to support. Whether it is useful?

    0
    Comment actions Permalink
  • Avatar
    Bahram Monshat

    Hi Skylum,

    Hi.
    There was no DPA6233TPQ.com.macphun.luminar3 in AppCleaner. I deleted all files in Appcleaner before I installed the new version. It crashes. Please advise. Thanks.
     
     
    0
    Comment actions Permalink
  • Avatar
    Heino Deutschmann

    Thanks Alina, now L3 works well with Apple Photos

    0
    Comment actions Permalink
  • Avatar
    Mark Johnson

    After the 3rd attempt it's working, sort of, ive lost all my edits, I mean like nearly 4000 edits........

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    Windows or Mac, Mark. Just updated on Mac and all is fine and all edits are still there so far as I can see.

     

    0
    Comment actions Permalink
  • Avatar
    Mark Johnson

    On a Macbook pro, may be in the trash bin, but after 3 attempts and countless go's last night I'm not what is what.

    0
    Comment actions Permalink
  • Avatar
    Mark Johnson

    Of someone wouldn't mind telling me what the folder, with all my edits in could be called that would be great, i'll see if I still have on my mac somewhere.

     

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Anna V

    Hi Mark, 

    I am sorry to hear that.

    Please contact us at http://www.skylum.com/support  and we'll be happy to help.

     

    0
    Comment actions Permalink
  • Avatar
    Anna V

    Hi Bahram Monshat

    Please try reinstalling Luminar 3. Follow the steps below:

    • delete the app with AppClenaer. Download AppCleaner from here:http://www.freemacsoft.net/appcleaner
    • Go to Pictures -> Luminar Catalog and rename the Luminar Catalog file. Please make sure to rename the catalog file, not just the folder. The catalog file has the extension .luminar and is located inside of the Luminar Catalog folder.(if you have created the Catalog in another Location, please navigate there and rename the Catalog file). 
    • Go to Application Support (launch Finder > Go > Go to Folder > paste  /Library/Application Support/ > MachPhun Software ) and delete luminar3 folder. 
    • Go to Terminal and type: “defaults delete com.macphun.luminar3”, click enter.
    • After that please install from the link below: https://luminar3.s3-accelerate.amazonaws.com/mac/Luminar3Installer.zip 
    0
    Comment actions Permalink
  • Avatar
    Dennis Atkinson

    That's done the trick, all working now thanks

    0
    Comment actions Permalink
  • Avatar
    Bahram Monshat

    Hi Anna V.

    Thanks. With the exception of "Go to Terminal and type: “defaults delete com.macphun.luminar3”, click enter.", which I didn't understand, I followed all your instruction. It opened under the temp catalogue, but it crashed when I attempted to use the original cat.

    0
    Comment actions Permalink
  • Avatar
    Larry Bootland

    This resolved the install for me. Thanks.

    0
    Comment actions Permalink
  • Avatar
    Bahram Monshat

    Hi Anna V,

    Success at last! The weird thing was I had two catalogs in one folder, one under another subfolder. Got rid of one. All is perfect now and no loss of previous edits. Thanks very much.

    0
    Comment actions Permalink
  • Avatar
    Gal Steinberg

    Not working for me, I followed those instructions and I still get 0 on the folder

    0
    Comment actions Permalink
  • Avatar
    Eric Loit

    Hi Gal,

    I had the same issues and I determined the problem to be a corrupt catalog.   This happened when I added images under Catalina prior to this last Luminar update.   Also causes under the "All Photos" shortcut for the date of the photos to duplicate for as many times as you restart Luminar.  Continued to happen with the latest Luminar update.

    My solution was to create a new catalog.  When doing so all the folder functions seem to work.   If I need to go back to the older images and edits I would just open the older catalog when needed so previous work is not lost.

    Hope this helps.

    0
    Comment actions Permalink
  • Avatar
    Reinhard Temmel

    Had the same problem, created a new catalogue which seams to work so far. I can open old catalogues with my images including editing history - I do not understand the procedure to uninstall L3 and reinstall if everything you have to do is creating a new catalogue.

    BUT:  that means that I cannot add images to an existing catalogue in the future and therefore have to redesign my catalogue structure?

    As L3 is slowly working with big catalogues I am using a new catalogue for each year - so: for 2019 I have to create a new catalogue (lets say 2019a), in this catalogue I can import new images. As it is impossible to merge two catalogues I cannot create a new album containing images from catalogue 2019 & 2019a.

    Now my demand for the possibility to merge catalogues is even more important.

    Is there a way to repair the obviously corrupted catalogue?

    I hope this will not happen again with the next update to L4?!

     

    0
    Comment actions Permalink

Please sign in to leave a comment.