MacOS 10.15 Catalina Compatibility

Pinned Featured Answered

Comments

146 comments

  • Official comment
    Avatar
    Alina Skylum

    Hi Everyone!

    We are sorry for the inconvenience.

    We have already fixed the issue, please update the app via Luminar 3 > Check for updates. 

    In case you still face this issue updating Luminar 3 please try reinstalling Luminar in the following way:

    We recommend doing a full uninstall with AppCleaner. AppCleaner is a free app that automatically removes not only applications but also the related files, making 'clean' uninstall easy.

    • Download AppCleaner from here (click this text to open link).
    • Install AppCleaner and start it.
    • Drag Luminar from your Applications folder into the AppCleaner window. When removing Luminar, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.
    • Once you've uninstalled Luminar, restart your Mac and download a fresh version of Luminar from the link below: https://downloads.skylum.com/luminar/mac/Luminar3.dmg
    • In case you receive the error message “You do not have sufficient permission to the specified folder” please simply click [OK] and finish the installation.

     

     

    Comment actions Permalink
  • Avatar
    Randy Wachs

    This company has been touting Luminar 4's "great new features" for months. They are seeking more upgrade revenue while diverting their finite coding resources to building a new, "mousetrap." There have been Developer betas of Catalina for at least a couple months. (The final developer beta would have been very, very, close to the publicly distributed release. It certainly could have been used to identify major points of conflict such as the changes to the native Photos application.) To my eyes, this isn't a a surprise to the folks at Skylum. Making already sold products compatible and reliable is demonstrably not their priority. Even much software with the "2018" moniker is openly not going to be compatible with Catalina per the company's recent announcement. If you aren't willing to buy their newest incarnation each year (and truthfully spend much of the next months serving as paying "beta testers," you should avoid this company's products in my opinion.

    I have NOT yet upgraded to Catalina. There is one legacy 32 bit app I rely upon which has no corresponding 64 bit alternative. For this reason alone, I am delaying a major OS upgrade for at least a few releases for the first time in many years. Abandoning 32 bit apps has been well communicated and is a necessary (and painful for some) step in the evolution of Mac OS. That said, this is an upgrade which will cause issues for many, some in unexpected ways. Verified backups and an abundance of caution are needed before embarking on this upgrade.

     

    For the record, I also have stopped using my multiple paid versions of Skylum software for anything beyond an occasional experiment (and since Aurora 2018 and Luminar 2  are  apparently reaching end of life and won't work after I eventually migrate to Catalina) and for all practical purposes Luminar 3 which has never worked properly for me since purchase, I am effectively out of this ecosystem. Luckly, this Skylum issue isn't a deal breaker for me as I gave up on their support intentions several months ago. I do find it inexcusable that these significant compatibility issues are being communicated after the public release of Catalina. I feel sorry for those losing time and perhaps even critical photographic assets as a result. 

    15
    Comment actions Permalink
  • Avatar
    Bill K

    The reasons I use L as a plug-in with Photos vs standalone is that when opening an image in L, it forces a conversion of any jpg or raw to a tiff.  My workflow does not use any tiff files .. when exporting to my personal photography site, I convert the raw to jpg.  If I want to print something, I convert my raw to tiff.

    The failure to support Catalina as a plug-in would have been know with the most rudimentary level of testing.  The work-around is neither practical, usable or desirable for most people who are using L as a plug-in.

    We receive frequent marketing via email from Skylum trying to up-sell us multiple products.  Why didn't they inform their clients (the majority are using Mac OSX) about this issue prior to the public release date?

    9
    Comment actions Permalink
  • Avatar
    Urban Wilde

    i was so frustrated that i have re-looked into ON1 and DXO Labs. Both websites have issued warnings not to update to Catalina. So, Luminar is not alone. Nevertheless, i don't trust that Luminar can fix this given their unawareness of the upcoming issue and i have asked them to refund my early bird purchase of L4.

    9
    Comment actions Permalink
  • Avatar
    Craig Herrick

    You have got to be kidding me.  So I'm not supposed to do a major MacOS upgrade because ONE of the many software programs I use won't work. This is why they release a beta version months in advance... so app developers can figure out how to interface with the new OS.  This is software development 101.  It does me no good to have a great photo editing program if I can't open or save the file!   Upgrade to 4... I think not.  Fix 3 please. 

    9
    Comment actions Permalink
  • Avatar
    Justinian Neutag

    emails advertising LUMINAR 4 - 3238

    emails saying LUMINAR 3 doesnt work with the official mac OS Catalina - 0

    I hope you work day and night on this, otherwise you are currently in the situation of a big mistake!

    9
    Comment actions Permalink
  • Avatar
    Jos Vromen

    Why am I not surprised ? 

    8
    Comment actions Permalink
  • Avatar
    Eric Loit

    Kate,

    Though we all appreciate the update and can understand that the Apple with Catalina is the underlaying problem causing the software not to work.  Skylum is developing software and would have had access to the numerous pre-releases from Apple and should have been VERY aware of the incompatibility that Catalina was going to introduce.   Additionally Skylum is probably aware that the Apple ecosystem has the quickest adoption of updates out of any OS in the marketplace.   Proper communication was really necessary here.   I've been inundated with notices of Luminar 4 coming.. even last change to upgrade at a preferred price yet there was not a single notice or warning of this impending crisis.

    The result is many of us has upgraded to Catalina unaware of the compatibility issue.   The lack of communication of what should have been a known problem is a credibility and trust issue that anyone using your software and company will now have.   For any that use it in their editing pipeline, this is a critical issue that can impact them or their business and as such is unacceptable.

    What is required now is some firm commitments with real time lines associated in resolving the issue without having to purchase an upgrade as you can imagine anyone now will be very resistive to want to do.   Second, there should be direct communication to the rest of the user base via email, like the marketing we are getting, making all users aware of the situation.   I think this, at a bare minimum,  is required to salvage any customer faith in Skylum and start down the path of rehabilitating some customer good will.

    8
    Comment actions Permalink
  • Avatar
    Craig Herrick

    So is there an estimate as to when my paid software will again work?  First, I'm surprised this caught anyone off guard.  As with every Apple annual upgrade, this one was proceeded by an extended beta release period.  Second, I'm surprised you let your customer base discover this problem on their own.  I still have not seen any information from you put out to your broader customer base.  Perhaps you are hoping some just won't notice their Luminar doesn't work.  

    I read an article yesterday which implied that Luminar isn't the only piece of software which is having problems so I will give you that.  But as a customer, I'm displease with your lack of candor and I'm doubting that I will upgrade to L4, thought your emails advertising the program haven't stopped... even though right now I guess it will be dead on arrival. 

    When will my L3 start working?  

    7
    Comment actions Permalink
  • Avatar
    Jos Vromen

    Exposure X5, again no problems at all.

    Which Skylum apps are going to be compatible with macOS Catalina? Luminar 4, Luminar 3, Luminar Flex and Aurora HDR 2019.

    So this is the end for CK, Tonality etc.  ? Nice that you mentioned that before. Oh, you didn't? Why am I not surprised (again)?

    Thanks again,

    Jos

    6
    Comment actions Permalink
  • Avatar
    Craig Herrick

    It would be nice if you just came clean with the issue.  Right now I just don't trust you.  You have not been forthcoming with the issue.  

    6
    Comment actions Permalink
  • Avatar
    Member

    You spoke some wise words my friend. Really wise words. Companies like Skylum are pushing me back to Usenet where you can find this sh*t for free. A bad move, I do know it, but this company deserves nothing better.

    5
    Comment actions Permalink
  • Avatar
    Markus Ullius

    I won't buy any Skylum products any more. This is a very unprofessional company in my opinion. No cr3-support after more than a year and now the Catalina disaster and the end of support of Tonality (and probably other products). SHAME ON YOU, SKYLUM! I won't stop telling everybody about this to warn people about being cheated by this company.

    5
    Comment actions Permalink
  • Avatar
    Mr.E

    Same here.

    Never Again.

    5
    Comment actions Permalink
  • Avatar
    Dan Worland

    So I have to ask Elena, Skylum still sells software it doesn’t support? (Intensify). Isn’t that like Microsoft trying to still sell Windows XP? That would be nuts right? Yet Skylum does it?

    5
    Comment actions Permalink
  • Avatar
    Kyle Wagaman

    Hi Elena,

    Per Apple's App Store Review Guidelines, 2.4.5 viii, "Apps should run on the currently shipping OS."

    To continue selling Intensify on the Mac App Store with compatibility notes of "macOS 10.9 or later" when Skylum doesn't intend to update it to run on macOS Catalina is both unethical and running afoul of Apple's guidelines.

    5
    Comment actions Permalink
  • Avatar
    Lawrence S. Rosenberg

    So when I use the work-around, I get a 72MB tiff file. How do I get a JPEG saved back to Apple Photos?

    4
    Comment actions Permalink
  • Avatar
    Tony Collins

    Well you have until my L4 eval period ends if you want to retain me as a customer.

    4
    Comment actions Permalink
  • Avatar
    Markus Ullius

    This is the second time Skylum pisses me off. After still not supporting Canon's CR3-Format for more than a year now the software (Luminar 3, Aurora 2019, Photolemur 3) does not run as Photos-plugin under Catalina! 

    And on the other hand they make big advertising for Luminar 4... 

    I won't buy any products of this company treating their existing customers in this way anymore. This is not professional!

    I'm really disappointed by this unprofessional company :(

    4
    Comment actions Permalink
  • Avatar
    Chase B.

    Hi Anna, 

    It's a serious inconvenience. I submitted two issues to support yesterday. It's the end of the day today and I haven't heard a word back. I've lost hours trying to figure this out. I'm in the middle of downgrading from Catalina back to Mojave so I can use Lumina and Aurora. Which requires me to back up my imac, wipe it clean, and then I can re-install mojave. And hope nothing else goes wrong. 

    I can understand skylum not being ready or unable to resolve the catalina issue before catalina came out. What I don't understand is the complete lack of communication to all the Mac users. If I would have been alerted not to upgrade to Catalina until Skylum got it sorted out...that would have been ok. Instead, I've lost hours of time and had to delay delivering photos to several clients. I even edited a huge batch of photos from aurora with no errors. I went to open the jpegs and they're empty. I really hope I don't have to re-edit all of them. Then even more hours of time lost. 

    Good communication is one of the MOST important things about a good business. I hope skylum can learn from this. They've got a good product, but it's not a great idea to consistently upset your customers, because skylum does have some serious competition. I'm sure skylum will lose a few customers over this and a few simple emails and alerts would prevent all of this frustration and lost time.

    4
    Comment actions Permalink
  • Avatar
    Bowman Gray

    Again, no emails to update on what is being fixed and what isn't. Are they abandoning the Aurora HDR platform as well? We are told "fix by year-end", but that hardly inspires any confidence. No word and again, no apologies. They have entered the class of companies that find their customers to be a pain in the ass except when it comes time to ask them to buy something new. I will never buy from them again.

    4
    Comment actions Permalink
  • Avatar
    Dan Worland

    End of the year!!! I guess you are busy releasing luminar 4 that won’t work till you release luminar 5. This is one reason I got refunded my preorder. They don’t support raw files that canon uses since March of 2018. Now dragging their feet on Catalonia. What makes anybody think luminar will work? I’ve moved on, you might consider doing the same.

    4
    Comment actions Permalink
  • Avatar
    Max

    Finally at least an official statement like about every other vendor. Now let’s see who can fix his software first.

    3
    Comment actions Permalink
  • Avatar
    Bill K

    Hi Anastasia.  Could you confirm that "Catalina support for L3" (and L4) means that Skylum will provide the same (or better) plug-in functionality that exists with L3 and Mojave i.e. use Apple Photos for DAM and edit with L via the Extensions feature?

    Are you planning to release the fix prior to the release of L4 ?

    Currently all of my photo processing is on hold because of this lack of support

    Thanks

    3
    Comment actions Permalink
  • Avatar
    Tony Collins

    It's not really a good look. I'd strongly suggest not releasing L4 without catalina compatibility.

    3
    Comment actions Permalink
  • Avatar
    Chase B.

    So, I upgraded to Catalina...perhaps too early. Now I cannot edit my photos. I actually bought aurora hdr this morning and it works fine. I had no idea Luminar was broken. I have a client waiting for me to return photos. My only option is to figure out how to revert to mojave? That's ridiculous. Like many others have mentioned, why didn't skylum fix this issue before the official catalina release and if skylum could not fix it...then why didn't we all get a few emails warning us not to upgrade? You're going to lose customers over this. I like Luminar...but now I'm facing a decision. Revert back to mojave and see how that goes. Leave Luminar for Lightroom. Leave Luminar for Affinity. Will I get a refund for Luminar?

    3
    Comment actions Permalink
  • Avatar
    Lawrence S. Rosenberg

    BTW, it would sure be nice to hear from the management at Skylum on this issue. Did today's supplemental update to macOS Catalina change anything, or not. Sometimes I suspect that there must be like one programmer who works on this and that person is presently not in. Maybe they will come in on the weekend? :-)

    3
    Comment actions Permalink
  • Avatar
    Dan Worland

    Lol, yea Skylum stopped supporting Canon Cameras over a year ago with Canon's newer CR3 RAW file format. So now they are going to abandon MAC users as well. A tech company just to lazy to keep up with tech changes I guess. 

    So how do I get a refund on my preorder on luminar 4? I bought it before I updated my camera with the Canon EOS R just to find out Luminar doesnt support Canon's RAW files anymore!!! It's been over a year Canon has released CR3 and It's obvious Luminar isn't going to support it after this much time. So what makes anyone think they will update their software to support Apples Catalina OS? Or any future OS updates... Apple gives developers development packages so compatibility is not an issue when new OS is released. I guess Luminar missed that memo. 

    If your on the fence about buying Luminart, DON'T. Run, run away as fast as you can people!!! Invest in a company that listens to their consumers and has the talent to keep up... 

    3
    Comment actions Permalink
  • Avatar
    Dan Worland

    No offense Helena but we been hearing that kind of response for a year with Canon CR3 raw files. “Update coming soon”, “working on it 24/7”, yada yada yada.

    3
    Comment actions Permalink
  • Avatar
    Craig Herrick

    I wonder if Skylum tried running the patch install on a Mac running Catalina?  I've now tried half dozen times and get the same error.  Tried after a reboot as well. 

    3
    Comment actions Permalink

Post is closed for comments.