Library problem with Luminar 3 on MacOS Catalina

Comments

12 comments

  • Avatar
    Kirk Osborn

    Hi. Please contact us via https://skylum.com/support and we will figure something out.

    -2
    Comment actions Permalink
  • Avatar
    Gal Steinberg

    I'm having the same problem, the library is not refreshing the files.

    If I create a new library sees my files, but the existing one doesn't. 

     

    1
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Gal,

    Please contact us via https://skylum.com/support like my colleague has mentioned. Hope to hear from you soon.

    -1
    Comment actions Permalink
  • Avatar
    Sam Friedman

    My problem turned out to be that I somehow had placed that particular block of photos in the trash. Until you empty the trash on Luminar, the files stay put, and thank Heavens I had not done so!

     

    Anxiously awaiting Version 4...

    0
    Comment actions Permalink
  • Avatar
    Gal Steinberg

    @Helenta, but I did, and I just got the same response that you will update an update later this year.

    This is not an acceptable answer - for a product we paid for. 

    1
    Comment actions Permalink
  • Avatar
    Jonathan Pelah

    Hey, I have the exact problem. Because of it I cannot use Luminar outside "Quick Edits" section.
    Please fix it.

    1
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Jonathan! Could you try creating a new catalog to see if the issue remains?

    0
    Comment actions Permalink
  • Avatar
    Member

    I do have the same problem. When do you plan of offer a update concerning this problem?

     

    1
    Comment actions Permalink
  • Avatar
    Helena Carter

    For everyone encountering issues with Catalina.

    We've just got a word from our Technical department and they told us that an update for Luminar 3 with fix will be released as soon as possible.

    Please, stay tuned!

    0
    Comment actions Permalink
  • Avatar
    Sam Friedman

    I submitted a service note, but I wanted to put it out in public as well. I now have got the EXTREME Luminar problem of the program ERASING my photos! Your library structure appears to be incredibly faulty, and had I not been obsessive/compulsive about backups, I would have lost my portfolio. This is unforgivable.  Unless you have some obvious reason for this happening and a FIX (at least in L4), I will respectfully request a full refund for the monies I have invested in L3  AND L4. 

    Consider me EXTREMELY disappointed in Luminar and Skylum. 

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Sam! 
    I can't find a thread with you and our support team. Did we investigate the issue? 
    Also, please give us more info on the issue.

    0
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    Hi Helena,

    the next update is promised here in the forum meanwhile for end of the year. 

    Soon as possible !!!!

    0
    Comment actions Permalink

Please sign in to leave a comment.