Moving a zoomed cropped image in build 4245

Comments

7 comments

  • Avatar
    David Tillett

    Angela, I have found the problem. I was sent a pre-release version of Luminar to test if it fixed the crashes that I was getting. It came with a debug option that, having spent my working life sorting out computers, I had a look at! Even though I then upgraded my original copy of the Luminar Jupiter app it somehow remembers the setting I had experimented with. Going back into the pre-release version and resetting the debug settings then reopening the current official release has made this behave as it was doing before with regards to moving around in zoomed cropped images getting clipping views using option key.

    The bad news is that it also returns the performance back to how it was, so takes ages to update images when turning filters on and off, colour of images changes slightly when releasing mouse button after moving slider, slow to update when dodging and burning.

    So the hot fix is nowhere near as good as I first thought. I just hope that the improvements that exist and which I found by accident get migrated to the production version as soon as possible. Regardless of the 300 improvements claimed for Jupiter I find that the February release is more usable for me.

    1
    Comment actions Permalink
  • Avatar
    David Tillett

    Hi Konstatin,

    It was the Mac release 3961, which still had the debug window option left in! Given I have a 4K Retina iMac I wondered what would happen if I turned the low res option off. I found that this dealt with some of the performance issues I had been suffering since upgrading to Jupiter - can just flick filters on and off to check effect, dodging and burning slow and images changing slightly when releasing mouse button after moving slider. All of these are worse than with the February release. However with the low res settings off I got the problems with zoom etc.

    I did let Denis from support, who sent me the pre-release version, know that I had been playing.

    I didn't realise that the debug settings were held outside the actual app and would have an effect on other Jupiter versions which obviously contain the same code options, just not the debug window to turn things on and off.

    I have been keeping copies of the various app files so was able to reset the debug options so zooming etc work with the hotfix release, but I am tempted to put Jupiter to one side and continue to use the February release since in actual editing it feels that this release is more usable, as I am still developing my post production skills I want to be able to observe the effect of filters by flicking them on and off.

    I know the filter issue has been accepted as a bug for fixing in future release, but if the issues of images changing after releasing a slider is not a known issue then I can report it as a bug and submit a screen recording.

     

    1
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi David,

    I'm not able to replicate that issue.

    Would you be so kind to send us the screen recording of this process/issue? Please follow the instructions below:

     

    1. Launch Finder>Applications>Quick Time Player.

    2. Tray Menu>File>New Screen Recording.

    3. Click on the Red Circle in the Screen Recording window that appears.

    4. Click on the screen to start screen recording.

    5. Reproduce the issue.

    6. Right-click on Quick Time Player on the doc menu -> Stop screen recording.

    7. A window should appear with the video of the screen recording. In the upper left corner of the screen, click on File -> Save.

    8. Choose the location and name and click on Save. The screen recording will be saved there.

    9. Send us the screen recording.

     

    You may upload it to WeTransfer:

     

    https://www.wetransfer.com/ 

    Please, click on share button -> Link -> add file ->

    Once the file is uploaded, click on share button -> Transfer -> and send us the link "http://we.tl/XXXXXXXXXX"

     

     

    Your cooperation is greatly appreciated.

    0
    Comment actions Permalink
  • Avatar
    David Tillett

    Angela, while I am sorting out the time to do the recording in methodical way I have just tested again. The problem exists in the release version of Jupiter, a development build that support sent me after I reported crashes and the latest hot fix build. Doesn't exist in the February update.

    I have just moved to a new system so if I can borrow my old system back from my wife I will see if it exists on different hardware.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi David,

    That is good info to know. We look forward to the screen recording. If you get a chance to test on your old computer let us know the results.

    0
    Comment actions Permalink
  • Avatar
    Konstantin Zolo

    Hi David,

    Thank you for sharing this.

    Could you please specify what pre-released version you were referring to? If it's the win_fix version then performance should remain the same.

    0
    Comment actions Permalink
  • Avatar
    Konstantin Zolo

    David,

    Thank you for your response.

    We would appreciate if you could send a screen recording to our support team at support@skylum.com. Thank you in advance.

    0
    Comment actions Permalink

Please sign in to leave a comment.