Will not load on my PC

Answered

Comments

5 comments

  • Avatar
    Alina Skylum

    Hi Michael,

    Thank you for joining our community!

    First of all, we need to make sure you're up to date with all Microsoft libraries:

    Download NET Framework 4.6.1: https://www.microsoft.com/en-US/download/details.aspx?id=49982

    Here's a link to Visual C++ 2015 https://www.microsoft.com/en-us/download/details.aspx?id=48145 

    It's better to have C++ 2013 installed as well: https://www.microsoft.com/en-us/download/details.aspx?id=40784 

    VCredist: https://www.microsoft.com/en-us/search/result.aspx?q=vcredist_x64 

    If Visual C++ says it is already installed, choose "Repair" option to make sure it is installed correctly. 

    All links should lead to official Microsoft resources. It's also recommended to reinstall Luminar 2018 after that and restart your PC.

     

    Try to install Luminar 2018 as an administrator (Right click on the install file -> Launch as an Administrator).

    Here's a link to an installation file, just in case.

     

    In case Luminar 2018 still doesn't start you can try to download an archive file with pre-installed Luminar 2018 in there:

    https://www.dropbox.com/s/lczxcmrs0mrznc7/Luminar%202018.zip?dl=0 

    Please do the following: 

    1) Go to your Program Files folder (C:\Program Files) and unzip the downloaded file:

    2) Go to the Luminar folder and find Luminar2018.exe file in there.

    3) Right click on that file -> Send to -> Desktop (Shortcut)

    4) Go to your Desktop and launch Luminar 2018.

    Let me know how it goes.

    0
    Comment actions Permalink
  • Avatar
    Michael Carter

    Alina --

    Thanks for the quick and helpful response. Installed the software you suggested, and Luminar loads without a hitch. 

    Great tech support.

    Michael Carter

    0
    Comment actions Permalink
  • Avatar
    Bryan Leech

    Hi,

    I have successfully installed on one computer with Win 10, but on another with 64-bit Win 7 Home Premium, 8Gb RAM (program is registered), I have no luck even following the advice given here . The archive file runs perfectly but when I attempt to update it, the program fails to run. There is a message that flashes too quickly to read, but starts with something like "Cannot run without..." by which time it's gone and the standard "Stopped working..." message appears.  I am stumped. Any suggestions please?

    0
    Comment actions Permalink
  • Avatar
    Bryan Leech

    Hi,

    Back again. With reboots at every step, finally - success. So thank you, but have now succeeded (with the assistance of the information above).

    Bryan.

    0
    Comment actions Permalink
  • Avatar
    Anna V

    Hi Bryan, 

    I am glad that it works. 

    However,  it is not a normal behavior. You don't have to reboot your PC every time you launch the app. 

    Please send us the following info about your PC with the link to this thread to support@skylum.com and we will be glad to assist you there:

    If you are on Windows, please do the following:

    • Press the Windows logo key + R.
    • Type msinfo32 in the dialog box that opens and hit Enter on your keyboard.
    • In the window that opens, make sure you have System Summary highlighted on the left.
    • Click File > Export.
    • Type the name of the file and save it somewhere where you can easily find it and attach this text file to your reply to this email.

    Hope to hear from you soon there.

    0
    Comment actions Permalink

Please sign in to leave a comment.